aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-15 21:44:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-15 21:44:06 +0000
commit2f1065d8ee4ee4c85bcc1695c31256f174972f03 (patch)
treef0f1df02cf412ec5c18e04139865323e02921df4
parentc4ee4c94c72fd77a690497787e7085f662d146f7 (diff)
downloadports-2f1065d8ee4ee4c85bcc1695c31256f174972f03.tar.gz
ports-2f1065d8ee4ee4c85bcc1695c31256f174972f03.zip
After decades of war one company, who had gained powerful supplying both sides
with weaponary, steps forwards and crushes both warring factions in one swift movement. Using far superior weaponary and AI craft, the company was completely unstoppable and now no one can stand in their way. Thousands began to perish under the iron fist of the company. The people cried out for a saviour, for someone to light this dark hour... and someone did. PR: ports/83418 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Notes
Notes: svn path=/head/; revision=139306
-rw-r--r--games/Makefile1
-rw-r--r--games/starfighter/Makefile53
-rw-r--r--games/starfighter/distinfo2
-rw-r--r--games/starfighter/files/patch-makefile25
-rw-r--r--games/starfighter/pkg-descr11
-rw-r--r--games/starfighter/pkg-plist15
6 files changed, 107 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 404f591251db..14c73bddc12d 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -469,6 +469,7 @@
SUBDIR += spider
SUBDIR += ssamtse
SUBDIR += ssc
+ SUBDIR += starfighter
SUBDIR += starlanes
SUBDIR += stratagus
SUBDIR += stvef-paks
diff --git a/games/starfighter/Makefile b/games/starfighter/Makefile
new file mode 100644
index 000000000000..56a030435d50
--- /dev/null
+++ b/games/starfighter/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: starfighter
+# Date created: 13 Jul 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= starfighter
+DISTVERSION= 1.1-1
+CATEGORIES= games
+MASTER_SITES= http://www.parallelrealities.co.uk/download.php?type=zip&file=
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Chris Bainfield is fighting for the freedom of the galaxy
+
+FETCH_BEFORE_ARGS+= -o ${DISTNAME}${EXTRACT_SUFX}
+
+USE_GMAKE= yes
+USE_SDL= image mixer sdl
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-1.1
+
+OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+
+MAKEFILE= makefile
+MAKE_ENV= CXX="${CXX}"
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+ ${RM} ${DOCSDIR}/LICENSE
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+# Fix Makefile
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}| ; \
+ s|\(-Wall\)|${CFLAGS} \1|' \
+ ${WRKSRC}/${MAKEFILE}
+
+# Fix SDL include statement
+ @${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|' \
+ ${WRKSRC}/code/*.cpp ${WRKSRC}/code/*.h
+
+# Enable/disable compilation optimizations
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${REINPLACE_CMD} -e 's|-O3||g' ${WRKSRC}/${MAKEFILE}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/games/starfighter/distinfo b/games/starfighter/distinfo
new file mode 100644
index 000000000000..4a1f57c68b6f
--- /dev/null
+++ b/games/starfighter/distinfo
@@ -0,0 +1,2 @@
+MD5 (starfighter-1.1-1.tar.gz) = 6a4b704dbc83c7403842b936f95ee958
+SIZE (starfighter-1.1-1.tar.gz) = 2523399
diff --git a/games/starfighter/files/patch-makefile b/games/starfighter/files/patch-makefile
new file mode 100644
index 000000000000..77e18ff0b88c
--- /dev/null
+++ b/games/starfighter/files/patch-makefile
@@ -0,0 +1,25 @@
+--- makefile.orig Mon Aug 18 09:48:23 2003
++++ makefile Wed Jul 13 18:40:23 2005
+@@ -7,9 +7,9 @@
+ PACK = starfighter.pak
+ DOCS = docs/*
+
+-BINDIR = /usr/games/
+-DATADIR = /usr/share/games/parallelrealities/
+-DOCDIR = /usr/share/doc/starfighter/
++BINDIR = $(PREFIX)/bin/
++DATADIR = $(PREFIX)/share/$(PROG)/
++DOCDIR = $(PREFIX)/share/doc/$(PROG)/
+ # top-level rule to create the program.
+ all: $(PROG)
+
+@@ -31,7 +31,5 @@
+ # install
+ install:
+ mkdir -p $(DATADIR)
+- strip $(PROG)
+- install -o root -g games -m 755 $(PROG) $(BINDIR)$(PROG)
+- install -o root -g games -m 644 $(PACK) $(DATADIR)$(PACK)
+- cp $(DOCS) $(DOCDIR)
++ $(BSD_INSTALL_PROGRAM) $(PROG) $(BINDIR)$(PROG)
++ $(BSD_INSTALL_DATA) $(PACK) $(DATADIR)$(PACK)
diff --git a/games/starfighter/pkg-descr b/games/starfighter/pkg-descr
new file mode 100644
index 000000000000..af0265302665
--- /dev/null
+++ b/games/starfighter/pkg-descr
@@ -0,0 +1,11 @@
+After decades of war one company, who had gained powerful supplying both sides
+with weaponary, steps forwards and crushes both warring factions in one swift
+movement. Using far superior weaponary and AI craft, the company was completely
+unstoppable and now no one can stand in their way. Thousands began to perish
+under the iron fist of the company. The people cried out for a saviour, for
+someone to light this dark hour... and someone did.
+
+WWW: http://www.parallelrealities.co.uk/starfighter.php
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/games/starfighter/pkg-plist b/games/starfighter/pkg-plist
new file mode 100644
index 000000000000..84eaf3b0f4f2
--- /dev/null
+++ b/games/starfighter/pkg-plist
@@ -0,0 +1,15 @@
+bin/starfighter
+%%PORTDOCS%%%%DOCSDIR%%/ammo.gif
+%%PORTDOCS%%%%DOCSDIR%%/cash.gif
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/plasmaAmmo.png
+%%PORTDOCS%%%%DOCSDIR%%/plasmaDamage.png
+%%PORTDOCS%%%%DOCSDIR%%/plasmaRate.png
+%%PORTDOCS%%%%DOCSDIR%%/rocketAmmo.png
+%%PORTDOCS%%%%DOCSDIR%%/sflogo.gif
+%%PORTDOCS%%%%DOCSDIR%%/shield.gif
+%%PORTDOCS%%%%DOCSDIR%%/superCharge.png
+%%PORTDOCS%%%%DOCSDIR%%/targetArrow.png
+%%DATADIR%%/starfighter.pak
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%