aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-20 10:54:55 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-20 10:54:55 +0000
commit35a2d230ba9b8aa3ae90c63ff4070dda29ca26ce (patch)
tree3344af35a25b28bc2ca930637352373786489e39
parente8a2db3f9d8a4e84e7cc109f171b00653f95b975 (diff)
downloadports-35a2d230ba9b8aa3ae90c63ff4070dda29ca26ce.tar.gz
ports-35a2d230ba9b8aa3ae90c63ff4070dda29ca26ce.zip
Add libbegemot 1.11, a function library for begemot tools.
PR: ports/86327 Submitted by: Andrey V. Elsukov <bu7cher@yandex.ru>
Notes
Notes: svn path=/head/; revision=143200
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libbegemot/Makefile41
-rw-r--r--devel/libbegemot/distinfo2
-rw-r--r--devel/libbegemot/files/patch-Makefile.in25
-rw-r--r--devel/libbegemot/files/patch-configure.ac28
-rw-r--r--devel/libbegemot/pkg-descr5
-rw-r--r--devel/libbegemot/pkg-plist5
7 files changed, 107 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0992abaefed7..83d9fd545ad7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -428,6 +428,7 @@
SUBDIR += libassetml
SUBDIR += libast
SUBDIR += libavl
+ SUBDIR += libbegemot
SUBDIR += libbfd
SUBDIR += libbinio
SUBDIR += libbnr
diff --git a/devel/libbegemot/Makefile b/devel/libbegemot/Makefile
new file mode 100644
index 000000000000..3c1c2d384619
--- /dev/null
+++ b/devel/libbegemot/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: libbegemot
+# Date created: Sep 15 2005
+# Whom: Andrey V. Elsukov <bu7cher@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libbegemot
+PORTVERSION= 1.11
+CATEGORIES= devel
+MASTER_SITES= http://people.freebsd.org/~harti/libbegemot/
+DISTNAME= libbegemot-${PORTVERSION}
+
+MAINTAINER= bu7cher@yandex.ru
+COMMENT= A function library for begemot tools
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBLTDL= yes
+INSTALLS_SHLIB= yes
+
+WANT_AUTOCONF_VER= 259
+WANT_AUTOMAKE_VER= 19
+WANT_LIBTOOL_VER= 15
+
+MAN1= cstrc.1 frame.1 getfields.1 intro.1 panic.1 prstat.1 readline.1 \
+ rpoll.1 strnchr.1 strnlen.1 strsave.1 strtrimsp.1 verb.1 xalloc.1
+MLINKS= xalloc.1 xrealloc.1
+
+run-autotools:
+ @(cd ${CONFIGURE_WRKSRC} && ${PREFIX}/bin/aclocal19 \
+ -I ${PREFIX}/share/libtool15/libltdl/ )
+ @(cd ${CONFIGURE_WRKSRC} && ${PREFIX}/bin/autoconf259 )
+
+post-install:
+.for i in ${MAN1}
+ @${CP} ${WRKSRC}/${i:S/.1/.man/} ${WRKSRC}/${i}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${MANPREFIX}/man/man1
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/libbegemot/distinfo b/devel/libbegemot/distinfo
new file mode 100644
index 000000000000..8a0d51952e53
--- /dev/null
+++ b/devel/libbegemot/distinfo
@@ -0,0 +1,2 @@
+MD5 (libbegemot-1.11.tar.gz) = bc13b7cd70c3c7cb232c3d05609b4032
+SIZE (libbegemot-1.11.tar.gz) = 266310
diff --git a/devel/libbegemot/files/patch-Makefile.in b/devel/libbegemot/files/patch-Makefile.in
new file mode 100644
index 000000000000..5bbfff7aeb08
--- /dev/null
+++ b/devel/libbegemot/files/patch-Makefile.in
@@ -0,0 +1,25 @@
+--- Makefile.in.orig Wed Jun 1 11:50:27 2005
++++ Makefile.in Sat Sep 17 21:43:49 2005
+@@ -116,17 +116,17 @@
+ $(MKINSTALLDIRS) $(DESTDIR)$(includedir)
+ $(MKINSTALLDIRS) $(DESTDIR)$(mandir)/man$(MSECT)
+
+- $(LIBTOOL) --mode=install $(INSTALL_DATA) $(LIB) $(DESTDIR)$(libdir)
++ $(LIBTOOL) --mode=install $(BSD_INSTALL_DATA) $(LIB) $(DESTDIR)$(libdir)
+
+ # for file in $(HDR) ; do \
+ # $(INSTALL_DATA) $(srcdir)/$$file $(DESTDIR)$(includedir) ;\
+ # done
+ for file in $(LHDR) ; do \
+- $(INSTALL_DATA) $$file $(DESTDIR)$(includedir) ;\
+- done
+- for file in $(MSRC) ; do \
+- $(INSTALL_DATA) $(srcdir)/$$file.man $(DESTDIR)$(mandir)/man$(MSECT)/$$file.$(MSECT) ;\
++ $(BSD_INSTALL_DATA) $$file $(DESTDIR)$(includedir) ;\
+ done
++# for file in $(MSRC) ; do \
++# $(INSTALL_DATA) $(srcdir)/$$file.man $(DESTDIR)$(mandir)/man$(MSECT)/$$file.$(MSECT) ;\
++# done
+
+ clean:
+ -rm -f *.o *.lo *.la *.core core *~ .depend polltest stattest frame verbtest
diff --git a/devel/libbegemot/files/patch-configure.ac b/devel/libbegemot/files/patch-configure.ac
new file mode 100644
index 000000000000..4ce632092c33
--- /dev/null
+++ b/devel/libbegemot/files/patch-configure.ac
@@ -0,0 +1,28 @@
+--- configure.ac.orig Thu Sep 15 14:18:10 2005
++++ configure.ac Thu Sep 15 15:34:24 2005
+@@ -232,8 +232,14 @@
+ AC_CACHE_CHECK([how to print quads],
+ ac_cv_quad_fmt,
+ [if test "$ac_have_inttypes_h" = "yes" ; then
+- ac_cv_quad_fmt=PRIu64
+- else
++ AC_EGREP_CPP(yes,
++[
++# include <inttypes.h>
++# ifdef PRIu64
++yes
++# endif
++],
++ ac_cv_quad_fmt=PRIu64,
+ AC_TRY_RUN(
+ [[
+ # include <stdio.h>
+@@ -251,7 +257,7 @@
+ ac_cv_quad_fmt='"q"',
+ ac_cv_quad_fmt='"ll"',
+ ac_cv_quad_fmt='"ll"')
+- fi ])
++ fi ]))
+ AC_DEFINE_UNQUOTED(QUADFMT, $ac_cv_quad_fmt)
+
+ # ------------------------------------------------------------
diff --git a/devel/libbegemot/pkg-descr b/devel/libbegemot/pkg-descr
new file mode 100644
index 000000000000..1c6a0cf2ced3
--- /dev/null
+++ b/devel/libbegemot/pkg-descr
@@ -0,0 +1,5 @@
+This is the begemot utility function library. It is needed to
+build most of the begemot tools.
+
+- Andrey V. Elsukov
+bu7cher@yandex.ru
diff --git a/devel/libbegemot/pkg-plist b/devel/libbegemot/pkg-plist
new file mode 100644
index 000000000000..0945347caaef
--- /dev/null
+++ b/devel/libbegemot/pkg-plist
@@ -0,0 +1,5 @@
+lib/libbegemot.a
+lib/libbegemot.so
+lib/libbegemot.so.1
+include/begemot.h
+include/rpoll.h