aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-02-07 23:29:51 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-02-07 23:29:51 +0000
commit37b36b9f671d16f8071caeb9c21d30897dda45c6 (patch)
treee3e26678b3db792a0092c5b017527a8a3dad951a
parent0e22bbfb423be0a310b16228a62bd4fe1cc9bbce (diff)
downloadports-37b36b9f671d16f8071caeb9c21d30897dda45c6.tar.gz
ports-37b36b9f671d16f8071caeb9c21d30897dda45c6.zip
BROKEN on 5.x: does not compile
Notes
Notes: svn path=/head/; revision=100307
-rw-r--r--devel/doc++/Makefile8
-rw-r--r--java/kaffe/Makefile8
-rw-r--r--math/asir2000/Makefile8
-rw-r--r--math/oleo/Makefile4
-rw-r--r--x11-servers/driglide/Makefile8
-rw-r--r--x11-toolkits/xclasses/Makefile8
6 files changed, 39 insertions, 5 deletions
diff --git a/devel/doc++/Makefile b/devel/doc++/Makefile
index 23d26e5a75ef..e047713f3c12 100644
--- a/devel/doc++/Makefile
+++ b/devel/doc++/Makefile
@@ -62,6 +62,12 @@ ADDITIONAL_DOCS= ClassGraph.class \
supportedTeXmacros.html \
toc.html
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not compile"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
@@ -70,4 +76,4 @@ post-install:
done
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/java/kaffe/Makefile b/java/kaffe/Makefile
index 5a821cb75371..55666fcc9dab 100644
--- a/java/kaffe/Makefile
+++ b/java/kaffe/Makefile
@@ -27,9 +27,15 @@ PLIST_SUB+= PORTVER=${PORTVERSION} ARCH=${ARCH}
MAN1= kaffe.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not compile"
+.endif
+
post-install:
@${MKDIR} ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/BUILD_ENVIRONMENT ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/license.terms ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/asir2000/Makefile b/math/asir2000/Makefile
index 141d123032d9..9bb0a144b00e 100644
--- a/math/asir2000/Makefile
+++ b/math/asir2000/Makefile
@@ -34,6 +34,12 @@ LIB_DATA= alpi bfct bgk const cyclic defs.h dfff dmul fctrdata fctrtest \
fff gr ifplot katsura launch mat nf num primdec \
ratint robot solve sp sturm xm
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not compile"
+.endif
+
pre-install:
@${MKDIR} ${DATADIR}
@${MKDIR} ${DOCSDIR}
@@ -52,4 +58,4 @@ post-install:
@${TAR} xfz ${DISTDIR}/${ASIR_DOC} -C ${DOCSDIR}
@${INSTALL_MAN} ${DOCSDIR}/${MAN1} ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 559e10ed012e..6c333da5dbcd 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -37,6 +37,10 @@ CONFIGURE_ARGS+= --without-motif
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not compile"
+.endif
+
pre-everything::
.if !defined(WITH_MOTIF)
@${ECHO_MSG}
diff --git a/x11-servers/driglide/Makefile b/x11-servers/driglide/Makefile
index bda9c40403ca..5ba6cc3abb04 100644
--- a/x11-servers/driglide/Makefile
+++ b/x11-servers/driglide/Makefile
@@ -29,7 +29,13 @@ ONLY_FOR_ARCHS= i386
# Glide DOES NOT work with CFLAGS greater than -O2
CFLAGS+= -O
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not compile"
+.endif
+
post-extract:
cd $(WRKSRC) && ${ACLOCAL} -I ${LOCALBASE}/share/aclocal
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/xclasses/Makefile b/x11-toolkits/xclasses/Makefile
index 851af5278a6b..cb36a60768b2 100644
--- a/x11-toolkits/xclasses/Makefile
+++ b/x11-toolkits/xclasses/Makefile
@@ -25,6 +25,12 @@ USE_X_PREFIX= yes
USE_XPM= yes
WRKSRC= ${WRKDIR}/xclasses
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502000
+BROKEN= "Does not compile"
+.endif
+
post-patch:
.for file in build System/ARules.FreeBSD
@${PERL} -pi \
@@ -63,4 +69,4 @@ do-install:
@cd ${WRKSRC} && ${SH} build install
@${INSTALL_SCRIPT} ${WRKSRC}/setenvxc ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>