aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-20 17:42:55 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-20 17:42:55 +0000
commit6055c390fa88a4b31300ba98e6aec7cf9ef584cb (patch)
treebd134d95c6985557c16c667f368887f762ce5bb7
parent8cb80f164d599e2a0997c739c5ca71d49afa84e1 (diff)
downloadports-6055c390fa88a4b31300ba98e6aec7cf9ef584cb.tar.gz
ports-6055c390fa88a4b31300ba98e6aec7cf9ef584cb.zip
o Actually build instead of just using shipped bytecode
o Do not add to jar that which is not necessary
Notes
Notes: svn path=/head/; revision=50268
-rw-r--r--net/jift/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/net/jift/Makefile b/net/jift/Makefile
index 11f19a947ac2..6bf714bbfb60 100644
--- a/net/jift/Makefile
+++ b/net/jift/Makefile
@@ -20,16 +20,24 @@ RUN_DEPENDS= ${JAVAVM}:${PORTSDIR}/java/javavmwrapper \
USE_ZIP= yes
NO_WRKSUBDIR= yes
+BUILD_WRKSRC= ${WRKSRC}/classes
PLIST_SUB= JAR_DIR=${JAR_DIR} \
JAR_FILE=${JAR_FILE}
JDK_VERSION= 1.2.2
+JAVAC_CMD= ${LOCALBASE}/jdk${JDK_VERSION}/bin/javac
JAR_CMD= ${LOCALBASE}/jdk${JDK_VERSION}/bin/jar
JAVAVM= ${LOCALBASE}/bin/javavm
JAR_DIR= share/java/jar/${PORTNAME}
JAR_MANIFEST= ${FILESDIR}/manifest
DOC_FILES= copying.txt readme.txt
+CLASS_PACKAGE= net/sourceforge/jift
+CLASS_SRCDIRS= node/query \
+ node/net/packet \
+ node/net/crypto \
+ node/net \
+ .
post-patch:
# remove trailing ^M
@@ -40,7 +48,11 @@ post-patch:
# as far as build goes... ;)
do-build:
- cd ${WRKSRC} && ${JAR_CMD} -cmf ${JAR_MANIFEST} ${WRKDIR}/${JAR_FILE} net
+ @${MKDIR} ${BUILD_WRKSRC}
+.for dir in ${CLASS_SRCDIRS}
+ @${JAVAC_CMD} -d ${BUILD_WRKSRC} -classpath ${BUILD_WRKSRC} -sourcepath ${WRKDIR} ${WRKDIR}/${CLASS_PACKAGE}/${dir}/*.java
+.endfor
+ @cd ${BUILD_WRKSRC} && ${JAR_CMD} -cmf ${JAR_MANIFEST} ${WRKDIR}/${JAR_FILE} *
do-install:
@${MKDIR} ${PREFIX}/${JAR_DIR}