aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-18 20:53:17 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-18 20:53:17 +0000
commit75d3c00e8228f0eed494604b64abc6d13af86d28 (patch)
tree09ac2d9d13a083d79ec1aa938968d09dc2081408
parentf7a165cc542c1c2bd4ed0e158947aac6658ecee4 (diff)
downloadports-75d3c00e8228f0eed494604b64abc6d13af86d28.tar.gz
ports-75d3c00e8228f0eed494604b64abc6d13af86d28.zip
Adding port misc/p5-Geo-Cache, Oan object interface for GPS waypoints
Committed by: aaron Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=156319
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Geo-Cache/Makefile26
-rw-r--r--misc/p5-Geo-Cache/distinfo3
-rw-r--r--misc/p5-Geo-Cache/pkg-descr8
-rw-r--r--misc/p5-Geo-Cache/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index b26ef4b3db85..2be7feee9924 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -338,6 +338,7 @@
SUBDIR += p5-Data-Buffer
SUBDIR += p5-File-CounterFile
SUBDIR += p5-File-Sort
+ SUBDIR += p5-Geo-Cache
SUBDIR += p5-Geo-Weather
SUBDIR += p5-Geography-Countries
SUBDIR += p5-I18N-Charset
diff --git a/misc/p5-Geo-Cache/Makefile b/misc/p5-Geo-Cache/Makefile
new file mode 100644
index 000000000000..ccae754f1042
--- /dev/null
+++ b/misc/p5-Geo-Cache/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Geo-Cache
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Cache
+PORTVERSION= 0.06
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Geo
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Object interface for GPS waypoints
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/Time/CTime.pm:${PORTSDIR}/devel/p5-Time-modules
+
+MAN3= Geo::Cache.3 \
+ Geo::Gpx.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/misc/p5-Geo-Cache/distinfo b/misc/p5-Geo-Cache/distinfo
new file mode 100644
index 000000000000..d16bf98a7efd
--- /dev/null
+++ b/misc/p5-Geo-Cache/distinfo
@@ -0,0 +1,3 @@
+MD5 (Geo-Cache-0.06.tar.gz) = def80785039f32b4b75a90904ac96f1d
+SHA256 (Geo-Cache-0.06.tar.gz) = 545fc50ed77b000b1a9c4017227347e4926a354d7e8da52ae5ed0c5513b7359c
+SIZE (Geo-Cache-0.06.tar.gz) = 11371
diff --git a/misc/p5-Geo-Cache/pkg-descr b/misc/p5-Geo-Cache/pkg-descr
new file mode 100644
index 000000000000..20298bb3c6b2
--- /dev/null
+++ b/misc/p5-Geo-Cache/pkg-descr
@@ -0,0 +1,8 @@
+Provide an object interface to Geocaching.com waypoints and/or geocaches,
+using the Groundspeak GPX file as the reference for what fields are valid.
+
+Methods are provide for various of the fields that require special
+treatment.
+
+WWW: http://search.cpan.org/dist/Geo-Cache
+Author: Rich Bowen <rbowen@rcbowen.com>
diff --git a/misc/p5-Geo-Cache/pkg-plist b/misc/p5-Geo-Cache/pkg-plist
new file mode 100644
index 000000000000..7b82c7160ae9
--- /dev/null
+++ b/misc/p5-Geo-Cache/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Geo/Cache.pm
+%%SITE_PERL%%/Geo/Gpx.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Cache/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Cache
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo