aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-25 10:59:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-25 10:59:09 +0000
commita2ee9211ad5bd1b39f7505ca8533308e59b5362f (patch)
tree07f66a5f82a15909fd099a6b4bcaa93c17aac395
parent25d2a59c4c9869d51cbd21fc475ad24503de361f (diff)
downloadports-a2ee9211ad5bd1b39f7505ca8533308e59b5362f.tar.gz
ports-a2ee9211ad5bd1b39f7505ca8533308e59b5362f.zip
- Remove PYTHON_REL < 250, since USE_PYTHON 2.5+
Notes
Notes: svn path=/head/; revision=269677
-rw-r--r--databases/py-sqlalchemy/Makefile4
-rw-r--r--databases/py-sqlalchemy06/Makefile4
-rw-r--r--deskutils/conduit/Makefile5
-rw-r--r--deskutils/deskbar-applet/Makefile5
-rw-r--r--devel/py-gdata/Makefile4
-rw-r--r--devel/py-kid/Makefile9
-rw-r--r--japanese/trac/Makefile4
-rw-r--r--news/sabnzbdplus/Makefile13
-rw-r--r--www/py-amf/Makefile10
-rw-r--r--www/py-django-devel/Makefile4
-rw-r--r--www/py-django/Makefile4
-rw-r--r--www/py-django11/Makefile4
-rw-r--r--www/py-django12/Makefile4
-rw-r--r--www/py-django13/Makefile4
-rw-r--r--www/py-satchmo/Makefile4
15 files changed, 4 insertions, 78 deletions
diff --git a/databases/py-sqlalchemy/Makefile b/databases/py-sqlalchemy/Makefile
index 2af7da906335..e23deca40ead 100644
--- a/databases/py-sqlalchemy/Makefile
+++ b/databases/py-sqlalchemy/Makefile
@@ -58,12 +58,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.0.8:${PORTSDIR}/databases/py-ps
.endif
.if !defined(WITHOUT_SQLITE)
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
-.else
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
.endif
-.endif
.if !defined(WITHOUT_SYBASE)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Sybase.py:${PORTSDIR}/databases/py-sybase
diff --git a/databases/py-sqlalchemy06/Makefile b/databases/py-sqlalchemy06/Makefile
index 2af7da906335..e23deca40ead 100644
--- a/databases/py-sqlalchemy06/Makefile
+++ b/databases/py-sqlalchemy06/Makefile
@@ -58,12 +58,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}psycopg2>=2.0.8:${PORTSDIR}/databases/py-ps
.endif
.if !defined(WITHOUT_SQLITE)
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
-.else
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
.endif
-.endif
.if !defined(WITHOUT_SYBASE)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Sybase.py:${PORTSDIR}/databases/py-sybase
diff --git a/deskutils/conduit/Makefile b/deskutils/conduit/Makefile
index 1a149575392a..07582179e8d1 100644
--- a/deskutils/conduit/Makefile
+++ b/deskutils/conduit/Makefile
@@ -53,11 +53,6 @@ RUN_DEPENDS+= eog:${PORTSDIR}/graphics/eog
CONFIGURE_ARGS+= --enable-eog-plugin
.endif
-.if ${PYTHON_REL} < 250
-BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-elementtree
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-elementtree
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/data/Makefile.in
diff --git a/deskutils/deskbar-applet/Makefile b/deskutils/deskbar-applet/Makefile
index 855cdec80bf2..95d34eb34aa4 100644
--- a/deskutils/deskbar-applet/Makefile
+++ b/deskutils/deskbar-applet/Makefile
@@ -48,11 +48,6 @@ CONFIGURE_ARGS+=--disable-evolution
PLIST_SUB+= EVO="@comment "
.endif
-.if ${PYTHON_REL} < 250
-BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-elementtree
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-elementtree
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
s|%%LOCALBASE%%|${LOCALBASE}|g' \
diff --git a/devel/py-gdata/Makefile b/devel/py-gdata/Makefile
index c388834164c5..bef1c9c4389b 100644
--- a/devel/py-gdata/Makefile
+++ b/devel/py-gdata/Makefile
@@ -29,10 +29,6 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-elementtree
-.endif
-
# avoid warning with Python > 2.5
.if ${PYTHON_REL} > 250
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src_atom-mock_service.py \
diff --git a/devel/py-kid/Makefile b/devel/py-kid/Makefile
index 38432ab83127..44301798746e 100644
--- a/devel/py-kid/Makefile
+++ b/devel/py-kid/Makefile
@@ -35,11 +35,4 @@ post-install:
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 250
-BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-elementtree
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/trac/Makefile b/japanese/trac/Makefile
index 3f33034d8581..bf4042a7810b 100644
--- a/japanese/trac/Makefile
+++ b/japanese/trac/Makefile
@@ -85,11 +85,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
.if defined(WITH_PGSQL)
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopg2/__init__.py:${PORTSDIR}/databases/py-psycopg2
.else
-. if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
-. else
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
-. endif
.endif
.if !defined(WITHOUT_SUBVERSION)
diff --git a/news/sabnzbdplus/Makefile b/news/sabnzbdplus/Makefile
index d951a0da1a0f..f88580bd407d 100644
--- a/news/sabnzbdplus/Makefile
+++ b/news/sabnzbdplus/Makefile
@@ -17,7 +17,8 @@ COMMENT= A web-interface based binary newsgrabber in python, with nzb support
RUN_DEPENDS= cheetah:${PORTSDIR}/devel/py-cheetah \
${PYTHON_SITELIBDIR}/cherrypy/__init__.py:${PORTSDIR}/www/py-cherrypy \
- ${PYTHON_SITELIBDIR}/pythonutils/configobj.py:${PORTSDIR}/devel/py-utils
+ ${PYTHON_SITELIBDIR}/pythonutils/configobj.py:${PORTSDIR}/devel/py-utils \
+ ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
LICENSE= GPLv2
@@ -42,16 +43,6 @@ OPTIONS= PAR2CMDLINE "Required for postprocessing of par files." on \
.include <bsd.port.pre.mk>
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/cElementTree.so:${PORTSDIR}/devel/py-celementtree
-.endif
-
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
-.else
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
-.endif
-
.if !defined(WITHOUT_PAR2CMDLINE)
RUN_DEPENDS+= par2repair:${PORTSDIR}/archivers/par2cmdline
.endif
diff --git a/www/py-amf/Makefile b/www/py-amf/Makefile
index d8dbcd3ae5dd..baf465df1120 100644
--- a/www/py-amf/Makefile
+++ b/www/py-amf/Makefile
@@ -21,12 +21,4 @@ PYEASYINSTALL_ARCHDEP= yes
PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-elementtree
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/uuid.py:${PORTSDIR}/devel/py-uuid
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/fpconst.py:${PORTSDIR}/math/py-fpconst
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/py-django-devel/Makefile b/www/py-django-devel/Makefile
index 70c0fa020bd3..fb8dfa0f565a 100644
--- a/www/py-django-devel/Makefile
+++ b/www/py-django-devel/Makefile
@@ -60,12 +60,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MyS
.endif
.if defined(WITH_SQLITE)
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
-.else
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
.endif
-.endif
.if defined(WITH_FASTCGI)
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup
diff --git a/www/py-django/Makefile b/www/py-django/Makefile
index 1ab649be143c..2c0ffc55ee19 100644
--- a/www/py-django/Makefile
+++ b/www/py-django/Makefile
@@ -53,12 +53,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MyS
.endif
.if defined(WITH_SQLITE)
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
-.else
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
.endif
-.endif
.if defined(WITH_FASTCGI)
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup
diff --git a/www/py-django11/Makefile b/www/py-django11/Makefile
index 9931a9804871..adf4e6d6f0e2 100644
--- a/www/py-django11/Makefile
+++ b/www/py-django11/Makefile
@@ -55,12 +55,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MyS
.endif
.if defined(WITH_SQLITE)
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
-.else
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
.endif
-.endif
.if defined(WITH_FASTCGI)
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup
diff --git a/www/py-django12/Makefile b/www/py-django12/Makefile
index 1ab649be143c..2c0ffc55ee19 100644
--- a/www/py-django12/Makefile
+++ b/www/py-django12/Makefile
@@ -53,12 +53,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MyS
.endif
.if defined(WITH_SQLITE)
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
-.else
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
.endif
-.endif
.if defined(WITH_FASTCGI)
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup
diff --git a/www/py-django13/Makefile b/www/py-django13/Makefile
index 1ab649be143c..2c0ffc55ee19 100644
--- a/www/py-django13/Makefile
+++ b/www/py-django13/Makefile
@@ -53,12 +53,8 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MySQLdb>=1.2.2:${PORTSDIR}/databases/py-MyS
.endif
.if defined(WITH_SQLITE)
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite23
-.else
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_sqlite3.so:${PORTSDIR}/databases/py-sqlite3
.endif
-.endif
.if defined(WITH_FASTCGI)
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}flup>0:${PORTSDIR}/www/py-flup
diff --git a/www/py-satchmo/Makefile b/www/py-satchmo/Makefile
index e3e9ce7456f5..011c3f67c24d 100644
--- a/www/py-satchmo/Makefile
+++ b/www/py-satchmo/Makefile
@@ -38,10 +38,6 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}django-threaded-multihost>=0:${PORTSDIR}/ww
${PYTHON_PKGNAMEPREFIX}django-app-plugins>=0:${PORTSDIR}/www/py-django-app-plugins \
${PYTHON_PKGNAMEPREFIX}django-signals-ahoy>=0:${PORTSDIR}/www/py-django-signals-ahoy
-.if ${PYTHON_REL} < 250
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-elementtree
-.endif
-
.if defined(WITH_DOCS)
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sphinx>0:${PORTSDIR}/textproc/py-sphinx
BUILD_DEPENDS+= rst2xml>0:${PORTSDIR}/textproc/py-docutils