aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-04 02:18:21 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-04 02:18:21 +0000
commita6429924fc57a145369eb5b2d3d0f45c65656b19 (patch)
treea7703a1b06cbba057e160e6f7af6e66d74cfc940
parent31bf3a3efffb2842e5c1ffda6275830a3e3c8ae5 (diff)
downloadports-a6429924fc57a145369eb5b2d3d0f45c65656b19.tar.gz
ports-a6429924fc57a145369eb5b2d3d0f45c65656b19.zip
PERL -> REINPLACE
Noticed on: bento
Notes
Notes: svn path=/head/; revision=69423
-rw-r--r--audio/ccaudio/Makefile5
-rw-r--r--audio/ccaudio2/Makefile5
-rw-r--r--comms/vpb2/Makefile5
-rw-r--r--devel/byaccj/Makefile3
-rw-r--r--devel/ilu/Makefile3
-rw-r--r--devel/re2c/Makefile5
-rw-r--r--dns/bind9-dlz/Makefile7
-rw-r--r--ftp/lukemftpd/Makefile5
-rw-r--r--irc/tirc/Makefile3
-rw-r--r--net/bind9-dlz/Makefile7
-rw-r--r--print/acroread4/Makefile9
-rw-r--r--security/bcwipe/Makefile3
-rw-r--r--security/chkrootkit/Makefile6
-rw-r--r--security/fwanalog/Makefile6
-rw-r--r--security/qident/Makefile4
-rw-r--r--sysutils/npadmin/Makefile3
-rw-r--r--textproc/txt2html/Makefile3
-rw-r--r--textproc/txt2html/pkg-descr2
18 files changed, 52 insertions, 32 deletions
diff --git a/audio/ccaudio/Makefile b/audio/ccaudio/Makefile
index 663a7f47e56b..c957e4c6dedc 100644
--- a/audio/ccaudio/Makefile
+++ b/audio/ccaudio/Makefile
@@ -15,12 +15,13 @@ MAINTAINER= dyfet@gnu.org
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_AUTOCONF= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
post-extract:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|-release \@LT_RELEASE\@||g'
+ @find ${WRKSRC} -name "Makefile.in" | \
+ xargs ${REINPLACE_CMD} -e 's|-release \@LT_RELEASE\@||g'
.include <bsd.port.mk>
diff --git a/audio/ccaudio2/Makefile b/audio/ccaudio2/Makefile
index 663a7f47e56b..c957e4c6dedc 100644
--- a/audio/ccaudio2/Makefile
+++ b/audio/ccaudio2/Makefile
@@ -15,12 +15,13 @@ MAINTAINER= dyfet@gnu.org
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_AUTOCONF= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
post-extract:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|-release \@LT_RELEASE\@||g'
+ @find ${WRKSRC} -name "Makefile.in" | \
+ xargs ${REINPLACE_CMD} -e 's|-release \@LT_RELEASE\@||g'
.include <bsd.port.mk>
diff --git a/comms/vpb2/Makefile b/comms/vpb2/Makefile
index f4f06f36a7f3..7a43cc75ec71 100644
--- a/comms/vpb2/Makefile
+++ b/comms/vpb2/Makefile
@@ -16,12 +16,13 @@ MAINTAINER= dyfet@gnu.org
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_AUTOCONF= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
post-extract:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|-release \$$\(LT_RELEASE\)||g'
+ @find ${WRKSRC} -name "Makefile.in" | \
+ xargs ${REINPLACE_CMD} -e 's|-release \$$\(LT_RELEASE\)||g'
.include <bsd.port.mk>
diff --git a/devel/byaccj/Makefile b/devel/byaccj/Makefile
index 2b3cd28119ea..a2aa74a127e5 100644
--- a/devel/byaccj/Makefile
+++ b/devel/byaccj/Makefile
@@ -15,9 +15,10 @@ DISTNAME= byaccj1.1
MAINTAINER= davidxu@viatech.com.cn
WRKSRC= $(WRKDIR)/byaccj1.1/src
+USE_REINPLACE= yes
post-patch:
- @${PERL} -pi -e 's#<malloc.h>#<stdlib.h>#' ${WRKSRC}/defs.h ${WRKSRC}/*c
+ @${REINPLACE_CMD} -e 's#<malloc.h>#<stdlib.h>#' ${WRKSRC}/defs.h ${WRKSRC}/*c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/yacc ${PREFIX}/bin/byaccj
diff --git a/devel/ilu/Makefile b/devel/ilu/Makefile
index 5a4dce62cec1..d33cf8e9444a 100644
--- a/devel/ilu/Makefile
+++ b/devel/ilu/Makefile
@@ -32,6 +32,7 @@ CONFIGURE_ARGS= --enable-http-protocol --enable-os-threads=posix \
--disable-cplusplus-shared-libary
NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX}/ilu
@@ -59,7 +60,7 @@ startup_dir= ${PREFIX}/etc/rc.d
startup_script= ${startup_dir}/50.ilu.sh
pre-patch:
- @${PERL} -pi -e 's,<malloc.h>,<stdlib.h>,' \
+ @${REINPLACE_CMD} -e 's,<malloc.h>,<stdlib.h>,' \
${WRKSRC}/stubbers/parser/ilu.bison \
${WRKSRC}/stubbers/parser/genregs.c \
${WRKSRC}/stubbers/parser/iluparse.c.dist \
diff --git a/devel/re2c/Makefile b/devel/re2c/Makefile
index 8ef1ce76dd0d..58119049fc9d 100644
--- a/devel/re2c/Makefile
+++ b/devel/re2c/Makefile
@@ -14,14 +14,15 @@ MASTER_SITES= http://www.tildeslash.org/re2c/ \
MAINTAINER= eivind@FreeBSD.org
USE_GMAKE= yes
+USE_REINPLACE= yes
MAN1= re2c.1
ALL_TARGET= default
pre-patch:
- @${PERL} -pi -e 's|^CFLAGS.*$$|CFLAGS+=-Wall -I. -Wno-unused -Wno-parentheses|' ${WRKSRC}/Makefile
- @${PERL} -pi -e 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/parser.cc ${WRKSRC}/parser.y
+ @${REINPLACE_CMD} -e 's|^CFLAGS.*$$|CFLAGS+=-Wall -I. -Wno-unused -Wno-parentheses|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' ${WRKSRC}/parser.cc ${WRKSRC}/parser.y
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/re2c ${PREFIX}/bin
diff --git a/dns/bind9-dlz/Makefile b/dns/bind9-dlz/Makefile
index ff5b3331e75a..4bf4b7e7e60a 100644
--- a/dns/bind9-dlz/Makefile
+++ b/dns/bind9-dlz/Makefile
@@ -31,6 +31,7 @@ PLIST= ${WRKDIR}/.PLIST.more
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --localstatedir=/var --disable-linux-caps
WRKSRC= ${WRKDIR}/bind-${ISCVERSION}
+USE_REINPLACE= yes
DIR= ${WRKSRC}/bin/
DLZVERSION= 0.2.1
@@ -79,12 +80,12 @@ MAN8= dnssec-keygen.8 dnssec-makekeyset.8 dnssec-signkey.8 dnssec-signzone.8 \
rndc-confgen.8 rndc.8
pre-patch:
- ${PERL} -pi -e "s=bind-9.2.1/==" ${EXTRA_PATCHES}
+ ${REINPLACE_CMD} -e "s=bind-9.2.1/==" ${EXTRA_PATCHES}
post-patch:
- ${PERL} -pi -e "s=/usr/local/pgsql/include=${LOCALBASE}/include=" \
+ ${REINPLACE_CMD} -e "s=/usr/local/pgsql/include=${LOCALBASE}/include=" \
${WRKSRC}/bin/named/Makefile.in
- ${PERL} -pi -e "s=/usr/local/pgsql/lib=${LOCALBASE}/lib=" \
+ ${REINPLACE_CMD} -e "s=/usr/local/pgsql/lib=${LOCALBASE}/lib=" \
${WRKSRC}/bin/named/Makefile.in
.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.8 \
rndc/rndc.8
diff --git a/ftp/lukemftpd/Makefile b/ftp/lukemftpd/Makefile
index 2178553bf134..7f94c49a8a48 100644
--- a/ftp/lukemftpd/Makefile
+++ b/ftp/lukemftpd/Makefile
@@ -14,6 +14,7 @@ MASTER_SITES= ftp://ftp.netbsd.org/pub/NetBSD/misc/lukemftp/ \
MAINTAINER= debolaz@debolaz.com
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
DOCS= ChangeLog README THANKS
@@ -25,7 +26,7 @@ FIXPREFIX= ftpd.8 ftpd.conf.5 ftpusers.5
pre-patch:
.for f in ${FIXPREFIX}
- ${PERL} -pi -e "s@^\.Dq Pa /etc@.Dq Pa ${PREFIX}/etc@g; \
+ ${REINPLACE_CMD} -e "s@^\.Dq Pa /etc@.Dq Pa ${PREFIX}/etc@g; \
s@^\.Pa /etc@.Pa ${PREFIX}/etc@g; \
s@^\.It Pa /etc/@.It Pa ${PREFIX}/etc/@g; \
s@^\.Ss /etc/@.Ss ${PREFIX}/etc/@g; \
@@ -35,7 +36,7 @@ pre-patch:
s@${PREFIX}/etc/pwd.db@/etc/pwd.db@g" \
${WRKSRC}/src/${f}
.endfor
- ${PERL} -pi -e \
+ ${REINPLACE_CMD} -e \
"s@^#define\t_DEFAULT_CONFDIR\t\"/etc\"@#define\t_DEFAULT_CONFDIR\t\"${PREFIX}/etc\"@" \
${WRKSRC}/src/pathnames.h
diff --git a/irc/tirc/Makefile b/irc/tirc/Makefile
index 058ddf9b603a..01a01fa78faf 100644
--- a/irc/tirc/Makefile
+++ b/irc/tirc/Makefile
@@ -12,13 +12,14 @@ MASTER_SITES= ftp://ftp.mayn.de/pub/unix/network/irc/tirc/
MAINTAINER= dr@astorit.com
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= "--with-ansi-colours"
MAKE_FLAGS= CONF_ARGS="--prefix=${PREFIX}"
MAN1= tirc.1
post-patch:
- @${PERL} -pi -e 's:__PREFIX__:${PREFIX}:g' ${WRKSRC}/*.c ${WRKSRC}/*.1
+ @${REINPLACE_CMD} -e 's:__PREFIX__:${PREFIX}:g' ${WRKSRC}/*.c ${WRKSRC}/*.1
post-install:
strip ${PREFIX}/bin/tirc
diff --git a/net/bind9-dlz/Makefile b/net/bind9-dlz/Makefile
index ff5b3331e75a..4bf4b7e7e60a 100644
--- a/net/bind9-dlz/Makefile
+++ b/net/bind9-dlz/Makefile
@@ -31,6 +31,7 @@ PLIST= ${WRKDIR}/.PLIST.more
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --localstatedir=/var --disable-linux-caps
WRKSRC= ${WRKDIR}/bind-${ISCVERSION}
+USE_REINPLACE= yes
DIR= ${WRKSRC}/bin/
DLZVERSION= 0.2.1
@@ -79,12 +80,12 @@ MAN8= dnssec-keygen.8 dnssec-makekeyset.8 dnssec-signkey.8 dnssec-signzone.8 \
rndc-confgen.8 rndc.8
pre-patch:
- ${PERL} -pi -e "s=bind-9.2.1/==" ${EXTRA_PATCHES}
+ ${REINPLACE_CMD} -e "s=bind-9.2.1/==" ${EXTRA_PATCHES}
post-patch:
- ${PERL} -pi -e "s=/usr/local/pgsql/include=${LOCALBASE}/include=" \
+ ${REINPLACE_CMD} -e "s=/usr/local/pgsql/include=${LOCALBASE}/include=" \
${WRKSRC}/bin/named/Makefile.in
- ${PERL} -pi -e "s=/usr/local/pgsql/lib=${LOCALBASE}/lib=" \
+ ${REINPLACE_CMD} -e "s=/usr/local/pgsql/lib=${LOCALBASE}/lib=" \
${WRKSRC}/bin/named/Makefile.in
.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.8 \
rndc/rndc.8
diff --git a/print/acroread4/Makefile b/print/acroread4/Makefile
index 91c914c74434..f1bf2c42699e 100644
--- a/print/acroread4/Makefile
+++ b/print/acroread4/Makefile
@@ -26,6 +26,7 @@ RUN_DEPENDS= /compat/osf1/usr/shlib/libc.so:${PORTSDIR}/emulators/osf1_base
ONLY_FOR_ARCHS= i386 alpha
+USE_REINPLACE= yes
LATEST_LINK= acroread4
NO_FILTER_SHLIBS= yes
@@ -40,9 +41,9 @@ PLIST_SUB= "ARCHDIR=alphaosf"
pre-configure:
.if ${ARCH} == "i386"
- @${PERL} -pi.fbsd -e 's:Linux\):FreeBSD|Linux):g' ${WRKSRC}/INSTALL
+ @${REINPLACE_CMD} -e 's:Linux\):FreeBSD|Linux):g' ${WRKSRC}/INSTALL
.elif ${ARCH} == "alpha"
- @${PERL} -pi.fbsd -e 's:OSF1\):FreeBSD|OSF1):g' ${WRKSRC}/INSTALL
+ @${REINPLACE_CMD} -e 's:OSF1\):FreeBSD|OSF1):g' ${WRKSRC}/INSTALL
${SED} -e 's/@comment ALPHA-ONLY://g' ${PKGDIR}/pkg-plist > ${PLIST}
.endif
@@ -55,11 +56,11 @@ do-install:
post-install:
.if ${ARCH} == "i386"
- @${PERL} -pi -e 's:Linux\):FreeBSD|Linux):g' ${PREFIX}/Acrobat4/bin/acroread
+ @${REINPLACE_CMD} -e 's:Linux\):FreeBSD|Linux):g' ${PREFIX}/Acrobat4/bin/acroread
-@/compat/linux/usr/bin/strip ${PREFIX}/Acrobat4/Reader/intellinux/bin/acroread
@brandelf -t Linux ${PREFIX}/Acrobat4/Reader/intellinux/bin/acroread
.elif ${ARCH} == "alpha"
- @${PERL} -pi -e 's:OSF1\):FreeBSD|OSF1):g' ${PREFIX}/Acrobat4/bin/acroread
+ @${REINPLACE_CMD} -e 's:OSF1\):FreeBSD|OSF1):g' ${PREFIX}/Acrobat4/bin/acroread
@strip ${PREFIX}/Acrobat4/Reader/alphaosf/bin/acroread
.endif
@cd ${PREFIX}/Acrobat4/bin && \
diff --git a/security/bcwipe/Makefile b/security/bcwipe/Makefile
index 43237efc65a0..e65b859ce86f 100644
--- a/security/bcwipe/Makefile
+++ b/security/bcwipe/Makefile
@@ -14,12 +14,13 @@ DISTNAME= BCWipe-${PORTVERSION:S/./-/g:S/-/./}
MAINTAINER= crow@nektor.hu
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/./-/g:S/-/./}
MAN1= bcwipe.1
post-patch:
- @${PERL} -pi -e "s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/bcwipe ${PREFIX}/bin
diff --git a/security/chkrootkit/Makefile b/security/chkrootkit/Makefile
index 812047625585..1081350d25ab 100644
--- a/security/chkrootkit/Makefile
+++ b/security/chkrootkit/Makefile
@@ -12,6 +12,8 @@ MASTER_SITES= ftp://ftp.pangeia.com.br/pub/seg/pac/
MAINTAINER= cordeiro@luinil.nic.br
+USE_REINPLACE= yes
+
ALL_TARGET= chkrootkit chklastlog chkwtmp chkproc ifpromisc
DOCFILES= COPYRIGHT README README.chklastlog README.chkwtmp
@@ -19,8 +21,8 @@ DOCFILES= COPYRIGHT README README.chklastlog README.chkwtmp
BINMODE= 0700
pre-patch:
- ${PERL} -pi -e "s/^CC/#CC/; s/^CFLAGS/#CFLAGS/" ${WRKSRC}/Makefile
- ${PERL} -pi -e \
+ ${REINPLACE_CMD} -e "s/^CC/#CC/; s/^CFLAGS/#CFLAGS/" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e \
's#\./chklastlog#${PREFIX}/sbin/chklastlog#g; \
s#\./chkwtmp#${PREFIX}/sbin/chkwtmp#g; \
s#\./chkproc#${PREFIX}/sbin/chkproc#g; \
diff --git a/security/fwanalog/Makefile b/security/fwanalog/Makefile
index cc4da4d9c535..9a8f334a6a5d 100644
--- a/security/fwanalog/Makefile
+++ b/security/fwanalog/Makefile
@@ -14,6 +14,7 @@ MAINTAINER= cy@FreeBSD.org
RUN_DEPENDS= analog:${PORTSDIR}/www/analog
+USE_REINPLACE= yes
ETCDIR= ${PREFIX}/etc/${PORTNAME}
PLIST_SUB+= ETCDIR=${ETCDIR}
CONFFILES= fwanalog-dom.tab \
@@ -24,10 +25,11 @@ CONFFILES= fwanalog-dom.tab \
services.conf
post-patch:
- ${PERL} -pi -e "s,the script's directory.*$$,${ETCDIR},;" \
+ ${REINPLACE_CMD} \
+ -e "s,the script's directory.*$$,${ETCDIR},;" \
-e 's,cd .*$$,cd ${ETCDIR},; s,sh\$$/,\$$/.,' \
${WRKSRC}/fwanalog.sh
- ${PERL} -pi -e 's/"freebsd/"ipf/; s/"ipflog/"messages/' \
+ ${REINPLACE_CMD} -e 's/"freebsd/"ipf/; s/"ipflog/"messages/' \
${WRKSRC}/fwanalog.opts.freebsd
do-build:
diff --git a/security/qident/Makefile b/security/qident/Makefile
index a5bc29957560..5d965958b070 100644
--- a/security/qident/Makefile
+++ b/security/qident/Makefile
@@ -14,6 +14,8 @@ MAINTAINER= dd@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/libident.a:${PORTSDIR}/security/libident
+USE_REINPLACE= yes
+
MANSECTS= 1
MAN1= qident.1
MANCOMPRESSED= maybe
@@ -26,7 +28,7 @@ MANCOMPSUFFIX=
.endif
post-patch:
- @${PERL} -pi -e 's/getopt[.]h/unistd.h/g' ${WRKSRC}/*
+ @${REINPLACE_CMD} -e 's/getopt[.]h/unistd.h/g' ${WRKSRC}/*
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/qident ${PREFIX}/bin/qident
diff --git a/sysutils/npadmin/Makefile b/sysutils/npadmin/Makefile
index 57ef855db885..c5ab02587ed9 100644
--- a/sysutils/npadmin/Makefile
+++ b/sysutils/npadmin/Makefile
@@ -15,9 +15,10 @@ MAINTAINER= dom@happygiraffe.net
MAN1= npadmin.1
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/textproc/txt2html/Makefile b/textproc/txt2html/Makefile
index ef7540df54bf..ffb53158016e 100644
--- a/textproc/txt2html/Makefile
+++ b/textproc/txt2html/Makefile
@@ -14,9 +14,10 @@ MASTER_SITES= http://www.aigeek.com/txt2html/
MAINTAINER= croyle@gelemna.org
NO_BUILD= yes
+USE_REINPLACE= yes
do-configure:
- @${PERL} -pi -e "s|/usr/local|${PREFIX}|g; \
+ @${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g; \
s|${PREFIX}/lib|${DATADIR}|" ${WRKSRC}/txt2html.pl
do-install:
diff --git a/textproc/txt2html/pkg-descr b/textproc/txt2html/pkg-descr
index ca6d941353a0..d254e5b77760 100644
--- a/textproc/txt2html/pkg-descr
+++ b/textproc/txt2html/pkg-descr
@@ -6,4 +6,4 @@ apparent structure of the source document (mostly whitespace and
typographic layout), and attempts to mark that structure explicitly
using HTML.
-WWW: http://www.aigeek.com/txt2html/ \ No newline at end of file
+WWW: http://www.aigeek.com/txt2html/