aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-09-20 19:30:58 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-09-20 19:30:58 +0000
commitc51569415992084e7092c73b9c76a28cd8adbadf (patch)
tree39908a13a5cf8ad34d8f5b906f56f6f3341e8ebb
parent550077c59e0933ce327ad143536052ec30958bc2 (diff)
downloadports-c51569415992084e7092c73b9c76a28cd8adbadf.tar.gz
ports-c51569415992084e7092c73b9c76a28cd8adbadf.zip
Fix bad C++ code. Unmark BROKEN.
Reported by: kris Approved by: portmgr (marcus), fjoe (mentor, implicit)
Notes
Notes: svn path=/head/; revision=118303
-rw-r--r--net/osrtspproxy/Makefile8
-rw-r--r--net/osrtspproxy/files/patch-libapp-tlist.h38
2 files changed, 39 insertions, 7 deletions
diff --git a/net/osrtspproxy/Makefile b/net/osrtspproxy/Makefile
index 497db0f159cb..91350d9604b1 100644
--- a/net/osrtspproxy/Makefile
+++ b/net/osrtspproxy/Makefile
@@ -17,14 +17,8 @@ COMMENT= The RTSP Proxy Kit is a reference implementation of an RTSP proxy
HAS_CONFIGURE= YES
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rtspproxy/rtspproxy ${PREFIX}/sbin
${INSTALL_SCRIPT} ${FILESDIR}/rtspproxy.sh ${PREFIX}/etc/rc.d/rtspproxy.sh.sample
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/osrtspproxy/files/patch-libapp-tlist.h b/net/osrtspproxy/files/patch-libapp-tlist.h
new file mode 100644
index 000000000000..dcd72c4f0e81
--- /dev/null
+++ b/net/osrtspproxy/files/patch-libapp-tlist.h
@@ -0,0 +1,38 @@
+--- libapp/tlist.h.orig Mon Sep 20 15:00:01 2004
++++ libapp/tlist.h Mon Sep 20 15:00:36 2004
+@@ -94,7 +94,7 @@
+ T& operator*( void )
+ {
+ assert( m_pList && m_pNode );
+- return m_pNode->GetData();
++ return this->m_pNode->GetData();
+ }
+ protected:
+ Iterator( TSingleList<T>* pList, TSingleNode* pNode ) :
+@@ -114,7 +114,7 @@
+ const T& operator*( void ) const
+ {
+ assert( m_pList && m_pNode );
+- return m_pNode->GetData();
++ return this->m_pNode->GetData();
+ }
+ protected:
+ ConstIterator( const TSingleList<T>* pList, TSingleNode* pNode ) :
+@@ -282,7 +282,7 @@
+ T& operator*( void )
+ {
+ assert( m_pList && m_pNode );
+- return m_pNode->GetData();
++ return this->m_pNode->GetData();
+ }
+ protected:
+ Iterator( const TDoubleList<T>* pList, TDoubleNode* pNode ) :
+@@ -302,7 +302,7 @@
+ const T& operator*( void ) const
+ {
+ assert( m_pList && m_pNode );
+- return m_pNode->GetData();
++ return this->m_pNode->GetData();
+ }
+ protected:
+ ConstIterator( const TDoubleList<T>* pList, TDoubleNode* pNode ) :