aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-12-31 13:18:35 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-12-31 13:18:35 +0000
commitc6252e04dccb226d74f860cedd3568d579cd9d44 (patch)
tree745139f12d22a6c9145ca5e8b5131270500820ad
parent7c91e0c9f5d42c6759586ee97d7bdc240f5a5067 (diff)
downloadports-c6252e04dccb226d74f860cedd3568d579cd9d44.tar.gz
ports-c6252e04dccb226d74f860cedd3568d579cd9d44.zip
- Chase libxine Shared library
Forgotten by: nobutaka (5 times in a row) - Sync with debian package: * Fixed an out-of-bounds error in src/support/widgets/zlist.c discovered by Matthias Urlichs. * Fixed a segfault on exit when no audio device available. - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=125600
-rw-r--r--graphics/pornview/Makefile4
-rw-r--r--graphics/pornview/files/patch-debian53
2 files changed, 55 insertions, 2 deletions
diff --git a/graphics/pornview/Makefile b/graphics/pornview/Makefile
index 671532c19f55..d5dc0c7111c2 100644
--- a/graphics/pornview/Makefile
+++ b/graphics/pornview/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pornview
PORTVERSION= 0.2.0.p.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
.if defined(WITH_LIBXINE)
-LIB_DEPENDS+= xine.9:${PORTSDIR}/multimedia/libxine
+LIB_DEPENDS+= xine.12:${PORTSDIR}/multimedia/libxine
CONFIGURE_ARGS+= --enable-xine
.elseif defined(WITH_MPLAYER)
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
diff --git a/graphics/pornview/files/patch-debian b/graphics/pornview/files/patch-debian
new file mode 100644
index 000000000000..ee888b98943d
--- /dev/null
+++ b/graphics/pornview/files/patch-debian
@@ -0,0 +1,53 @@
+--- pornview-0.2pre1.orig/src/support/image_loader.c
++++ src/support/image_loader.c
+@@ -81,7 +81,7 @@
+ image_loader_stop (ImageLoader * il)
+ {
+ #ifdef USE_GTK2
+- GError *err;
++ GError *err = NULL;
+ #endif
+
+ if (!il)
+@@ -174,7 +174,7 @@
+ gint c;
+
+ #ifdef USE_GTK2
+- GError *err;
++ GError *err = NULL;
+ #endif
+
+ if (!il)
+@@ -241,7 +241,7 @@
+ int b;
+
+ #ifdef USE_GTK2
+- GError *err;
++ GError *err = NULL;
+ #endif
+
+ if (!il->loader || il->pixbuf)
+--- pornview-0.2pre1.orig/src/support/widgets/gtkxine.c
++++ src/support/widgets/gtkxine.c
+@@ -632,7 +632,7 @@
+ */
+ if (this->vo_driver != NULL)
+ xine_close_video_driver (this->xine, this->vo_driver);
+- if (this->vo_driver != NULL)
++ if (this->ao_driver != NULL)
+ xine_close_audio_driver (this->xine, this->ao_driver);
+
+ /*
+--- pornview-0.2pre1.orig/src/support/widgets/zlist.c
++++ src/support/widgets/zlist.c
+@@ -634,7 +634,8 @@
+ CELL_X_FROM_COL (list, j), area->y,
+ list->cell_x_pad, area->height);
+
+- cell = ZLIST_CELL_FROM_INDEX (list, idx);
++ if (idx < list->cell_count)
++ cell = ZLIST_CELL_FROM_INDEX (list, idx);
+
+ cell_area.x = CELL_X_FROM_COL (list, j) + list->cell_x_pad;
+ cell_area.y = CELL_Y_FROM_ROW (list, i) + list->cell_y_pad;
+