aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-17 20:00:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-17 20:00:26 +0000
commitcac2fe7459b8bf97093bde1950d7ce97e2403448 (patch)
tree2b4f26e6c8f58e66e2278406f7de6203ad7cdc02
parentcc915b719336c923349d93f3fbc40395a907f5df (diff)
downloadports-cac2fe7459b8bf97093bde1950d7ce97e2403448.tar.gz
ports-cac2fe7459b8bf97093bde1950d7ce97e2403448.zip
- Update to 4.2
Submitted by: Danny Pansters <danny@ricin.com> (maintainer via privat mail)
Notes
Notes: svn path=/head/; revision=190238
-rw-r--r--devel/py-qt4-core/Makefile6
-rw-r--r--devel/py-qt4-core/distinfo6
-rw-r--r--devel/py-qt4-core/files/patch-configure.py65
3 files changed, 57 insertions, 20 deletions
diff --git a/devel/py-qt4-core/Makefile b/devel/py-qt4-core/Makefile
index fad292630c25..03cda815974e 100644
--- a/devel/py-qt4-core/Makefile
+++ b/devel/py-qt4-core/Makefile
@@ -5,12 +5,12 @@
# $FreeBSD$
PORTNAME= core
-PORTVERSION= 20070318
+PORTVERSION= 4.2
CATEGORIES= devel python
-MASTER_SITES= http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt4/ \
+MASTER_SITES= http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/ \
http://freebsd.ricin.com/ports/distfiles/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}qt4-
-DISTNAME= PyQt-x11-gpl-4-snapshot-${PORTVERSION}
+DISTNAME= PyQt-x11-gpl-${PORTVERSION}
MAINTAINER= danny@ricin.com
COMMENT= Python bindings for the Qt4 toolkit, QtCore module
diff --git a/devel/py-qt4-core/distinfo b/devel/py-qt4-core/distinfo
index b42fc45ded6f..3317bc659e04 100644
--- a/devel/py-qt4-core/distinfo
+++ b/devel/py-qt4-core/distinfo
@@ -1,3 +1,3 @@
-MD5 (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = 538cd5167ccb14a6b6a3ee687432617a
-SHA256 (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = d98516e20b02194264c199deddda2562845efca64315608522cc05a36c9210c7
-SIZE (PyQt-x11-gpl-4-snapshot-20070318.tar.gz) = 1076275
+MD5 (PyQt-x11-gpl-4.2.tar.gz) = af4baa7f7441914f9a527ef3cf788fef
+SHA256 (PyQt-x11-gpl-4.2.tar.gz) = 6fa8a853a66ae500f36629793e7d4c54896c7ccf6337c2b90ea0175b28aa7ae6
+SIZE (PyQt-x11-gpl-4.2.tar.gz) = 5661258
diff --git a/devel/py-qt4-core/files/patch-configure.py b/devel/py-qt4-core/files/patch-configure.py
index aa0e588eed68..15124b8d0be8 100644
--- a/devel/py-qt4-core/files/patch-configure.py
+++ b/devel/py-qt4-core/files/patch-configure.py
@@ -1,6 +1,6 @@
---- configure.py.orig Mon Feb 19 04:39:13 2007
-+++ configure.py Tue Feb 20 15:38:35 2007
-@@ -135,19 +135,19 @@
+--- configure.py.orig Tue Apr 10 17:59:52 2007
++++ configure.py Thu Apr 12 20:48:21 2007
+@@ -140,24 +140,24 @@
def check_modules(self):
pyqt_modules.append("QtCore")
@@ -12,8 +12,6 @@
- check_module("QtTest", "QtTest", "QTest::qSleep(0)")
- check_module("QtXml", "qdom.h", "new QDomDocument()")
- check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
-- check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
-- check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
+ #check_module("QtGui", "qwidget.h", "new QWidget()")
+ #check_module("QtNetwork", "qhostaddress.h", "new QHostAddress()")
+ #check_module("QtOpenGL", "qgl.h", "new QGLWidget()")
@@ -22,7 +20,18 @@
+ #check_module("QtTest", "QtTest", "QTest::qSleep(0)")
+ #check_module("QtXml", "qdom.h", "new QDomDocument()")
+ #check_module("QtAssistant", "qassistantclient.h", "new QAssistantClient(\"foo\")")
-+ #check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
++
++ #if sipcfg.universal:
++ # sipconfig.inform("QtDesigner module disabled with universal binaries")
++ #else:
++ # check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
+
+- if sipcfg.universal:
+- sipconfig.inform("QtDesigner module disabled with universal binaries")
+- else:
+- check_module("QtDesigner", "QExtensionFactory", "new QExtensionFactory()")
+-
+- check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
+ #check_module("QAxContainer", "qaxobject.h", "new QAxObject()", "QAxContainer")
- if os.path.isdir("dbus"):
@@ -32,7 +41,7 @@
def code(self):
# Note that the order of the dependent modules is important.
-@@ -201,31 +201,31 @@
+@@ -211,31 +211,31 @@
generate_code("QAxContainer", ["QAxContainer", "QtGui", "QtCore"])
# Generate the consolidated module.
@@ -79,7 +88,35 @@
def qpylibs(self):
# See which QPy libraries to build.
-@@ -825,7 +825,7 @@
+@@ -376,7 +376,8 @@
+ makefile.generate()
+ tool.append("pyrcc")
+ else:
+- sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
++ #sipconfig.inform("pylupdate4 and pyrcc4 will not be built because the Qt XML module is missing.")
++ pass
+
+ if "QtDesigner" in pyqt_modules:
+ enabled = True
+@@ -460,7 +461,7 @@
+ sipconfig.inform("The Qt mkspecs directory is in %s." % qt_datadir)
+ sipconfig.inform("These PyQt modules will be built: %s." % string.join(pyqt_modules))
+ sipconfig.inform("The PyQt modules will be installed in %s." % opt_pyqtmoddir)
+- sipconfig.inform("The Designer plugin will be installed in %s." % os.path.join(opt_plugindir, "designer"))
++ #sipconfig.inform("The Designer plugin will be installed in %s." % os.path.join(opt_plugindir, "designer"))
+
+ if opt_api:
+ sipconfig.inform("The QScintilla API file will be installed in %s." % os.path.join(opt_qscidir, "api", "python"))
+@@ -470,7 +471,7 @@
+
+ sipconfig.inform("The PyQt .sip files will be installed in %s." % opt_pyqtsipdir)
+
+- sipconfig.inform("pyuic4, pyrcc4 and pylupdate4 will be installed in %s." % opt_pyqtbindir)
++ sipconfig.inform("pyuic4 will be installed in %s." % opt_pyqtbindir)
+
+ if opt_vendorcheck:
+ sipconfig.inform("PyQt will only be usable with signed interpreters.")
+@@ -873,7 +874,7 @@
sipconfig.error("This version of PyQt and the %s edition of Qt have incompatible licenses." % qted)
# Confirm the license.
@@ -88,7 +125,7 @@
print "Type 'L' to view the license."
print "Type 'yes' to accept the terms of the license."
print "Type 'no' to decline the terms of the license."
-@@ -847,7 +847,7 @@
+@@ -895,7 +896,7 @@
if resp == "l":
os.system("more LICENSE")
@@ -97,12 +134,12 @@
# If there should be a license file then check it is where it should be.
if lfile:
if os.access(os.path.join("sip", lfile), os.F_OK):
-@@ -1367,7 +1367,7 @@
- scidir = os.path.join(qt_datadir, "qsci")
+@@ -1434,7 +1435,7 @@
+ installs=[(pyqt.module_installs(), opt_pyqtmoddir)]
- if opt_api or os.path.isdir(scidir):
-- installs.append(("PyQt4.api", os.path.join(scidir, "api", "python")))
-+ installs.append(("QtCore.api", os.path.join(scidir, "api", "python")))
+ if opt_api:
+- installs.append(("PyQt4.api", os.path.join(opt_qscidir, "api", "python")))
++ installs.append(("QtCore.api", os.path.join(opt_qscidir, "api", "python")))
sipconfig.ParentMakefile(
configuration=sipcfg,