aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Barner <barner@FreeBSD.org>2005-09-20 10:26:27 +0000
committerSimon Barner <barner@FreeBSD.org>2005-09-20 10:26:27 +0000
commite8a2db3f9d8a4e84e7cc109f171b00653f95b975 (patch)
treefdfd968146ecc9edabd09429309d7303b91952bf
parent25b3c96db27b33adfe4d5efb2b5aa1c386d38107 (diff)
downloadports-e8a2db3f9d8a4e84e7cc109f171b00653f95b975.tar.gz
ports-e8a2db3f9d8a4e84e7cc109f171b00653f95b975.zip
- fix build on 7-current [1]
- Add forgotten internal dependency for FreeBSD 4. Reported by: mich [1]
Notes
Notes: svn path=/head/; revision=143199
-rw-r--r--devel/valgrind-snapshot/files/patch-coregrind_Makefile.am11
-rw-r--r--devel/valgrind/files/patch-coregrind_Makefile.am11
2 files changed, 14 insertions, 8 deletions
diff --git a/devel/valgrind-snapshot/files/patch-coregrind_Makefile.am b/devel/valgrind-snapshot/files/patch-coregrind_Makefile.am
index 1c0c3f0ad94b..f0ad904ea698 100644
--- a/devel/valgrind-snapshot/files/patch-coregrind_Makefile.am
+++ b/devel/valgrind-snapshot/files/patch-coregrind_Makefile.am
@@ -1,9 +1,12 @@
--- coregrind/Makefile.am.orig Sun May 9 13:00:57 2004
-+++ coregrind/Makefile.am Tue Sep 20 00:04:17 2005
-@@ -172,11 +172,23 @@
++++ coregrind/Makefile.am Tue Sep 20 11:41:51 2005
+@@ -172,11 +172,26 @@
vg_unsafe.h
if !IS_LINUX
++if IS_FREEBSD4
++MANUAL_DEPS_EXTRA = $(inplacedir)/libc_r.so.4
++endif
+if IS_FREEBSD5
MANUAL_DEPS_EXTRA = $(inplacedir)/libc_r.so.5 \
$(inplacedir)/libkse.so.1 \
@@ -24,7 +27,7 @@
MANUAL_DEPS = $(noinst_HEADERS) $(include_HEADERS) $(inplacedir)/libpthread.so.0 ${MANUAL_DEPS_EXTRA}
-@@ -190,9 +202,23 @@
+@@ -190,9 +205,23 @@
ln -sf $(top_builddir)/$(subdir)/$$i $$to; \
done
if !IS_LINUX
@@ -44,7 +47,7 @@
+ ln -sf libpthread.so.0 $(inplacedir)/libpthread.so.2
+endif
+if IS_FREEBSD7
-+ ln -sf libpthread.so.0 $(inplacedir)/libc_r.so.6
++ ln -sf libpthread.so.0 $(inplacedir)/libc_r.so.6
+ ln -sf libpthread.so.0 $(inplacedir)/libthr.so.2
+ ln -sf libpthread.so.0 $(inplacedir)/libpthread.so.2
+endif
diff --git a/devel/valgrind/files/patch-coregrind_Makefile.am b/devel/valgrind/files/patch-coregrind_Makefile.am
index c3eff9742481..008a9649a911 100644
--- a/devel/valgrind/files/patch-coregrind_Makefile.am
+++ b/devel/valgrind/files/patch-coregrind_Makefile.am
@@ -1,9 +1,12 @@
--- coregrind/Makefile.am.orig Sun Mar 14 13:52:47 2004
-+++ coregrind/Makefile.am Tue Sep 20 00:01:58 2005
-@@ -162,11 +162,23 @@
++++ coregrind/Makefile.am Tue Sep 20 12:00:42 2005
+@@ -162,11 +162,26 @@
vg_unsafe.h
if !IS_LINUX
++if IS_FREEBSD4
++MANUAL_DEPS_EXTRA = $(inplacedir)/libc_r.so.4
++endif
+if IS_FREEBSD5
MANUAL_DEPS_EXTRA = $(inplacedir)/libc_r.so.5 \
$(inplacedir)/libkse.so.1 \
@@ -24,7 +27,7 @@
MANUAL_DEPS = $(noinst_HEADERS) $(include_HEADERS) $(inplacedir)/libpthread.so.0 ${MANUAL_DEPS_EXTRA}
-@@ -180,9 +192,23 @@
+@@ -180,9 +195,23 @@
ln -sf $(top_srcdir)/$(subdir)/$$i $$to; \
done
if !IS_LINUX
@@ -44,7 +47,7 @@
+ ln -sf libpthread.so.0 $(inplacedir)/libpthread.so.2
+endif
+if IS_FREEBSD7
-+ ln -sf libpthread.so.0 $(inplacedir)/libc_r.so.6
++ ln -sf libpthread.so.0 $(inplacedir)/libc_r.so.6
+ ln -sf libpthread.so.0 $(inplacedir)/libthr.so.2
+ ln -sf libpthread.so.0 $(inplacedir)/libpthread.so.2
+endif