aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-05-13 00:16:04 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-05-13 00:16:04 +0000
commit44a7216f7973853e807faa0a8f5fb7cd0b912bff (patch)
tree7aabbd687314021712db307fb78e9369a0e5dd0a
parentfefb49f219f730d0ef3f68b75946ebff493a767b (diff)
downloadports-44a7216f7973853e807faa0a8f5fb7cd0b912bff.tar.gz
ports-44a7216f7973853e807faa0a8f5fb7cd0b912bff.zip
Build fix, misc. cleanup.
Submitted by: Jeremy Lea <reg@shale.csir.co.za>
Notes
Notes: svn path=/head/; revision=18821
-rw-r--r--devel/mico/Makefile21
-rw-r--r--devel/mico/files/patch-ak19
-rw-r--r--devel/mico/files/patch-am102
-rw-r--r--devel/mico/pkg-plist618
4 files changed, 434 insertions, 326 deletions
diff --git a/devel/mico/Makefile b/devel/mico/Makefile
index 848f2d76ff0b..5f3be34b095a 100644
--- a/devel/mico/Makefile
+++ b/devel/mico/Makefile
@@ -3,7 +3,7 @@
# Date created: 11 July 1998
# Whom: Marc G. Fournier <scrappy@freebsd.org>
#
-# $Id: Makefile,v 1.30 1999/04/22 00:16:53 scrappy Exp $
+# $Id: Makefile,v 1.31 1999/05/02 21:21:57 mharo Exp $
#
DISTNAME= mico-2.2.3
@@ -14,21 +14,14 @@ MAINTAINER= scrappy@freebsd.org
.include <bsd.port.pre.mk>
-.if ${PORTOBJFORMAT} == "elf"
-LIBSTDC= ${PREFIX}/lib/gcc-lib/i386-unknown-freebsdelf${OSREL}/2.8.1/libstdc++.a
-.else
-LIBSTDC= ${PREFIX}/lib/gcc-lib/i386-unknown-freebsd${OSREL}/2.8.1/libstdc++.a
+.if ${OSVERSION} < 400004
+CC= egcc
+CXX= eg++
+BUILD_DEPENDS= egcc:${PORTSDIR}/lang/egcs
.endif
-LIB_DEPENDS= gtk10.1:${PORTSDIR}/x11-toolkits/gtk10 \
+LIB_DEPENDS= gtk12.1:${PORTSDIR}/x11-toolkits/gtk12 \
tcl80.1:${PORTSDIR}/lang/tcl80
-BUILD_DEPENDS= g++28:${PORTSDIR}/lang/gcc28 \
- ${LIBSTDC}:${PORTSDIR}/lang/glibstdc++28
-
-BROKEN= Cannot find a working cpp
-
-CC= gcc28
-CXX= g++28
USE_QT= yes
USE_AUTOCONF= yes
@@ -38,7 +31,7 @@ WRKSRC= ${WRKDIR}/mico
CONFIGURE_ARGS= --with-qt --with-gtk --with-tcl \
--disable-optimize --disable-mini-stl
-CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk10-config"
+CONFIGURE_ENV= GTK_CONFIG="${X11BASE}/bin/gtk12-config"
MAN1= idl.1 imr.1 nsadmin.1
MAN5= micorc.5
diff --git a/devel/mico/files/patch-ak b/devel/mico/files/patch-ak
index c6c68a83d84b..2a9cdb5099bf 100644
--- a/devel/mico/files/patch-ak
+++ b/devel/mico/files/patch-ak
@@ -1,5 +1,5 @@
---- configure.in.orig Wed Oct 21 10:29:16 1998
-+++ configure.in Sun Nov 15 15:20:10 1998
+--- configure.in.orig Wed Oct 21 15:29:16 1998
++++ configure.in Wed May 12 16:48:24 1999
@@ -102,7 +102,7 @@
# extra dirs
#
@@ -23,3 +23,18 @@
;;
*cygwin32*)
have_cdk=yes;
+@@ -486,14 +491,6 @@
+ if test X"$JAVAC" = Xno -o X"$JAVACUPDIR" = Xno; then
+ AC_MSG_WARN(you have not installed JDK 1.1 and JavaCUP. java parts disabled.)
+ HAVE_JDK=no
+-fi
+-
+-AC_PATH_PROG(GENERIC_CPP, cpp, none, `echo $PATH | tr : ' '` /lib /usr/lib /usr/ccs/lib)
+-if test X"$GENERIC_CPP" = Xnone; then
+- AC_MSG_WARN(Cannot find a working cpp.)
+- AC_MSG_WARN(please set the environment variable PATH to include)
+- AC_MSG_WARN(the path where cpp is located and rerun configure.)
+- exit 1
+ fi
+
+ AC_SUBST(HAVE_QT)
diff --git a/devel/mico/files/patch-am b/devel/mico/files/patch-am
new file mode 100644
index 000000000000..527068690be9
--- /dev/null
+++ b/devel/mico/files/patch-am
@@ -0,0 +1,102 @@
+--- MakeVars.in.orig Wed May 12 18:19:51 1999
++++ MakeVars.in Wed May 12 18:20:40 1999
+@@ -25,7 +25,7 @@
+ exec_prefix = @exec_prefix@
+ SRCDIR = @ABSSRCDIR@
+ INSTDIR = $(exec_prefix)
+-SHARED_INSTDIR = $(prefix)
++SHARED_INSTDIR = $(prefix)/share
+
+
+ HAVE_REPO = @HAVE_REPO@
+--- demo/MakeVars.orig Wed May 12 18:32:24 1999
++++ demo/MakeVars Wed May 12 18:32:47 1999
+@@ -78,14 +78,14 @@
+ endif
+
+ install:
+- $(IDIRCMD) $(INSTDIR)/doc/mico/examples/$(INSTALL_DIR)
++ $(IDIRCMD) $(SHARED_INSTDIR)/doc/mico/examples/$(INSTALL_DIR)
+ test -z "$(INSTALL_SRCS)" || \
+ eval 'for i in $(INSTALL_SRCS); do \
+- $(ISRCCMD) $$i $(INSTDIR)/doc/mico/examples/$(INSTALL_DIR); \
++ $(ISRCCMD) $$i $(SHARED_INSTDIR)/doc/mico/examples/$(INSTALL_DIR); \
+ done'
+ test -z "$(INSTALL_SCRIPTS)" || \
+ eval 'for i in $(INSTALL_SCRIPTS); do \
+- $(ISCRIPTCMD) $$i $(INSTDIR)/doc/mico/examples/$(INSTALL_DIR); \
++ $(ISCRIPTCMD) $$i $(SHARED_INSTDIR)/doc/mico/examples/$(INSTALL_DIR); \
+ done'
+
+ ifeq (.depend, $(wildcard .depend))
+--- demo/Makefile.orig Wed May 12 18:29:55 1999
++++ demo/Makefile Wed May 12 18:30:12 1999
+@@ -64,12 +64,12 @@
+ for i in $(DIRS); do $(MAKE) -C $$i clean || exit 1; done
+
+ install:
+- $(IDIRCMD) $(INSTDIR)/doc/mico/examples
++ $(IDIRCMD) $(SHARED_INSTDIR)/doc/mico/examples
+ sed -e s/@MICO_VERSION@/$(VERSION)/g \
+ < MakeVars.install > MakeVars.install.ver
+- $(ISRCCMD) MakeVars.install.ver $(INSTDIR)/doc/mico/examples/MakeVars
++ $(ISRCCMD) MakeVars.install.ver $(SHARED_INSTDIR)/doc/mico/examples/MakeVars
+ rm -f MakeVars.install.ver
+- $(ISRCCMD) README $(INSTDIR)/doc/mico/examples
++ $(ISRCCMD) README $(SHARED_INSTDIR)/doc/mico/examples
+ for i in $(INST_DIRS); do $(MAKE) -C $$i install || exit 1; done
+
+ install-cd: install
+--- demo/interop/Makefile.orig Wed May 12 18:30:42 1999
++++ demo/interop/Makefile Wed May 12 18:31:17 1999
+@@ -30,7 +30,7 @@
+ for i in $(DIRS); do $(MAKE) -C $$i clean || exit 1; done
+
+ install:
+- $(IDIRCMD) $(INSTDIR)/doc/mico/examples/interop
+- $(ISRCCMD) Makefile $(INSTDIR)/doc/mico/examples/interop
+- $(ISRCCMD) README $(INSTDIR)/doc/mico/examples/interop
++ $(IDIRCMD) $(SHARED_INSTDIR)/doc/mico/examples/interop
++ $(ISRCCMD) Makefile $(SHARED_INSTDIR)/doc/mico/examples/interop
++ $(ISRCCMD) README $(SHARED_INSTDIR)/doc/mico/examples/interop
+ for i in $(DIRS); do $(MAKE) -C $$i install || exit 1; done
+--- demo/poa/Makefile.orig Wed May 12 18:33:14 1999
++++ demo/poa/Makefile Wed May 12 18:33:28 1999
+@@ -13,7 +13,7 @@
+ rm -f *.o core *~ .depend
+
+ install:
+- $(IDIRCMD) $(INSTDIR)/doc/mico/examples/poa
+- $(ISRCCMD) Makefile $(INSTDIR)/doc/mico/examples/poa
+- $(ISRCCMD) README $(INSTDIR)/doc/mico/examples/poa
++ $(IDIRCMD) $(SHARED_INSTDIR)/doc/mico/examples/poa
++ $(ISRCCMD) Makefile $(SHARED_INSTDIR)/doc/mico/examples/poa
++ $(ISRCCMD) README $(SHARED_INSTDIR)/doc/mico/examples/poa
+ for i in $(DIRS); do $(MAKE) -C $$i install || exit 1; done
+--- demo/redlich/Makefile.orig Wed May 12 18:33:38 1999
++++ demo/redlich/Makefile Wed May 12 18:33:52 1999
+@@ -33,7 +33,7 @@
+ for i in $(DIRS); do $(MAKE) -C $$i clean || exit 1; done
+
+ install:
+- $(IDIRCMD) $(INSTDIR)/doc/mico/examples/redlich
+- $(ISRCCMD) Makefile $(INSTDIR)/doc/mico/examples/redlich
+- $(ISRCCMD) README $(INSTDIR)/doc/mico/examples/redlich
++ $(IDIRCMD) $(SHARED_INSTDIR)/doc/mico/examples/redlich
++ $(ISRCCMD) Makefile $(SHARED_INSTDIR)/doc/mico/examples/redlich
++ $(ISRCCMD) README $(SHARED_INSTDIR)/doc/mico/examples/redlich
+ for i in $(DIRS); do $(MAKE) -C $$i install || exit 1; done
+--- man/Makefile.orig Wed May 12 18:27:23 1999
++++ man/Makefile Wed May 12 18:27:40 1999
+@@ -26,9 +26,9 @@
+
+ install:
+ for i in $(DIRS); do \
+- $(IDIRCMD) $(SHARED_INSTDIR)/man/$$i; \
++ $(IDIRCMD) $(prefix)/man/$$i; \
+ for j in $$i/*.[1-9]; do $(IMANCMD) $$j \
+- $(SHARED_INSTDIR)/man/$$i/; done; \
++ $(prefix)/man/$$i/; done; \
+ done
+
+ install-cd: install
diff --git a/devel/mico/pkg-plist b/devel/mico/pkg-plist
index d350da44573e..a6a7ed0f695b 100644
--- a/devel/mico/pkg-plist
+++ b/devel/mico/pkg-plist
@@ -12,270 +12,6 @@ bin/micod
bin/nsadmin
bin/nsd
bin/propertyd
-doc/mico/examples/MakeVars
-doc/mico/examples/README
-doc/mico/examples/account/Makefile
-doc/mico/examples/account/account.idl
-doc/mico/examples/account/main.cc
-doc/mico/examples/account2/Makefile
-doc/mico/examples/account2/account
-doc/mico/examples/account2/account.idl
-doc/mico/examples/account2/client.cc
-doc/mico/examples/account2/server.cc
-doc/mico/examples/account3/Makefile
-doc/mico/examples/account3/account
-doc/mico/examples/account3/account.idl
-doc/mico/examples/account3/client.cc
-doc/mico/examples/account3/server.cc
-doc/mico/examples/account4/Makefile
-doc/mico/examples/account4/account
-doc/mico/examples/account4/account.idl
-doc/mico/examples/account4/client.cc
-doc/mico/examples/account4/server.cc
-doc/mico/examples/activate/Makefile
-doc/mico/examples/activate/client.cc
-doc/mico/examples/activate/hello-permethod
-doc/mico/examples/activate/hello-shared
-doc/mico/examples/activate/hello-unshared
-doc/mico/examples/activate/hello.idl
-doc/mico/examples/activate/server.cc
-doc/mico/examples/bench/Makefile
-doc/mico/examples/bench/bench
-doc/mico/examples/bench/bench.idl
-doc/mico/examples/bench/bench_impl.h
-doc/mico/examples/bench/client.cc
-doc/mico/examples/bench/server.cc
-doc/mico/examples/codesets/Makefile
-doc/mico/examples/codesets/client.cc
-doc/mico/examples/codesets/hello.idl
-doc/mico/examples/codesets/runit
-doc/mico/examples/codesets/server.cc
-doc/mico/examples/corba-c/Makefile
-doc/mico/examples/corba-c/client.c
-doc/mico/examples/corba-c/hello
-doc/mico/examples/corba-c/hello.idl
-doc/mico/examples/corba-c/server.c
-doc/mico/examples/dynany/Makefile
-doc/mico/examples/dynany/dynany.cc
-doc/mico/examples/dynany/dynanytest.cc
-doc/mico/examples/dynany/test.idl
-doc/mico/examples/events/Makefile
-doc/mico/examples/events/client.cc
-doc/mico/examples/events/client2.cc
-doc/mico/examples/events/runit
-doc/mico/examples/events/server.cc
-doc/mico/examples/events/server2.cc
-doc/mico/examples/events/server3.cc
-doc/mico/examples/gtkmico/Makefile
-doc/mico/examples/gtkmico/README
-doc/mico/examples/gtkmico/client.cc
-doc/mico/examples/gtkmico/gtkhello
-doc/mico/examples/gtkmico/hello.idl
-doc/mico/examples/gtkmico/server.cc
-doc/mico/examples/interceptor/Makefile
-doc/mico/examples/interceptor/client.cc
-doc/mico/examples/interceptor/hello.idl
-doc/mico/examples/interceptor/runit
-doc/mico/examples/interceptor/server.cc
-doc/mico/examples/interop/Makefile
-doc/mico/examples/interop/README
-doc/mico/examples/interop/jacorb/Account.idl
-doc/mico/examples/interop/jacorb/Client.java
-doc/mico/examples/interop/jacorb/ClientApplet.html.in
-doc/mico/examples/interop/jacorb/ClientApplet.java
-doc/mico/examples/interop/jacorb/Makefile
-doc/mico/examples/interop/jacorb/README
-doc/mico/examples/interop/jacorb/Server.java
-doc/mico/examples/interop/jacorb/account
-doc/mico/examples/interop/jacorb/client.cc
-doc/mico/examples/interop/jacorb/run_applet
-doc/mico/examples/interop/jacorb/server.cc
-doc/mico/examples/interop/jdk/Account.idl
-doc/mico/examples/interop/jdk/Client.java
-doc/mico/examples/interop/jdk/ClientApplet.html.in
-doc/mico/examples/interop/jdk/ClientApplet.java
-doc/mico/examples/interop/jdk/Makefile
-doc/mico/examples/interop/jdk/README
-doc/mico/examples/interop/jdk/account
-doc/mico/examples/interop/jdk/main.cc
-doc/mico/examples/interop/jdk/run_applet
-doc/mico/examples/interop/orbix/Makefile
-doc/mico/examples/interop/orbix/README
-doc/mico/examples/interop/orbix/grid.idl
-doc/mico/examples/interop/orbix/main.cc
-doc/mico/examples/interop/visibroker/Account.idl
-doc/mico/examples/interop/visibroker/Client.java
-doc/mico/examples/interop/visibroker/ClientApplet.html.in
-doc/mico/examples/interop/visibroker/ClientApplet.java
-doc/mico/examples/interop/visibroker/Makefile
-doc/mico/examples/interop/visibroker/README
-doc/mico/examples/interop/visibroker/account
-doc/mico/examples/interop/visibroker/main.cc
-doc/mico/examples/interop/visibroker/run_applet
-doc/mico/examples/naming/Makefile
-doc/mico/examples/naming/account.idl
-doc/mico/examples/naming/account_test
-doc/mico/examples/naming/client.cc
-doc/mico/examples/naming/server.cc
-doc/mico/examples/poa/Makefile
-doc/mico/examples/poa/README
-doc/mico/examples/poa/account-1/Makefile
-doc/mico/examples/poa/account-1/account
-doc/mico/examples/poa/account-1/account.idl
-doc/mico/examples/poa/account-1/client.cc
-doc/mico/examples/poa/account-1/server.cc
-doc/mico/examples/poa/account-2/Makefile
-doc/mico/examples/poa/account-2/account
-doc/mico/examples/poa/account-2/account.idl
-doc/mico/examples/poa/account-2/client.cc
-doc/mico/examples/poa/account-2/server.cc
-doc/mico/examples/poa/account-3/Makefile
-doc/mico/examples/poa/account-3/account
-doc/mico/examples/poa/account-3/account.idl
-doc/mico/examples/poa/account-3/client.cc
-doc/mico/examples/poa/account-3/server.cc
-doc/mico/examples/poa/hello-1/Makefile
-doc/mico/examples/poa/hello-1/client.cc
-doc/mico/examples/poa/hello-1/hello
-doc/mico/examples/poa/hello-1/hello.idl
-doc/mico/examples/poa/hello-1/server.cc
-doc/mico/examples/poa/hello-2/Makefile
-doc/mico/examples/poa/hello-2/client.cc
-doc/mico/examples/poa/hello-2/hello
-doc/mico/examples/poa/hello-2/hello.idl
-doc/mico/examples/poa/hello-2/server.cc
-doc/mico/examples/poa/inherit/Makefile
-doc/mico/examples/poa/inherit/client.cc
-doc/mico/examples/poa/inherit/inherit
-doc/mico/examples/poa/inherit/inherit.idl
-doc/mico/examples/poa/inherit/server.cc
-doc/mico/examples/qtmico/Makefile
-doc/mico/examples/qtmico/README
-doc/mico/examples/qtmico/client.cc
-doc/mico/examples/qtmico/hello.idl
-doc/mico/examples/qtmico/qthello1
-doc/mico/examples/qtmico/qthello2
-doc/mico/examples/qtmico/server.cc
-doc/mico/examples/redlich/Calc-1/Makefile
-doc/mico/examples/redlich/Calc-1/calc.idl
-doc/mico/examples/redlich/Calc-1/client.cc
-doc/mico/examples/redlich/Calc-1/server.cc
-doc/mico/examples/redlich/Calc-2/Makefile
-doc/mico/examples/redlich/Calc-2/calc.idl
-doc/mico/examples/redlich/Calc-2/client.cc
-doc/mico/examples/redlich/Calc-2/server.cc
-doc/mico/examples/redlich/Calc-3/Makefile
-doc/mico/examples/redlich/Calc-3/calc.idl
-doc/mico/examples/redlich/Calc-3/client.cc
-doc/mico/examples/redlich/Calc-3/server.cc
-doc/mico/examples/redlich/Calc-4/Makefile
-doc/mico/examples/redlich/Calc-4/calc.idl
-doc/mico/examples/redlich/Calc-4/client.cc
-doc/mico/examples/redlich/Calc-4/server.cc
-doc/mico/examples/redlich/Hello-1/Makefile
-doc/mico/examples/redlich/Hello-1/client.cc
-doc/mico/examples/redlich/Hello-1/server.cc
-doc/mico/examples/redlich/Hello-1/tty.idl
-doc/mico/examples/redlich/Hello-2/Makefile
-doc/mico/examples/redlich/Hello-2/client.cc
-doc/mico/examples/redlich/Hello-2/server.cc
-doc/mico/examples/redlich/Hello-2/tty.idl
-doc/mico/examples/redlich/Hello-3/Makefile
-doc/mico/examples/redlich/Hello-3/client.cc
-doc/mico/examples/redlich/Hello-3/server.cc
-doc/mico/examples/redlich/Hello-3/tty.idl
-doc/mico/examples/redlich/Hello-3/ttyplus.idl
-doc/mico/examples/redlich/Hello-4/Makefile
-doc/mico/examples/redlich/Hello-4/client.cc
-doc/mico/examples/redlich/Hello-4/server.cc
-doc/mico/examples/redlich/Hello-4/tty.idl
-doc/mico/examples/redlich/Hello-4/ttyplus.idl
-doc/mico/examples/redlich/Makefile
-doc/mico/examples/redlich/README
-doc/mico/examples/relship/Bank.idl
-doc/mico/examples/relship/BankServer.cc
-doc/mico/examples/relship/Bank_impl.cc
-doc/mico/examples/relship/Bank_impl.h
-doc/mico/examples/relship/ContainedInRoleServer.cc
-doc/mico/examples/relship/Containment.idl
-doc/mico/examples/relship/ContainmentServer.cc
-doc/mico/examples/relship/Containment_impl.cc
-doc/mico/examples/relship/Containment_impl.h
-doc/mico/examples/relship/ContainsRoleServer.cc
-doc/mico/examples/relship/Documents.idl
-doc/mico/examples/relship/Documents_impl.cc
-doc/mico/examples/relship/Documents_impl.h
-doc/mico/examples/relship/EmployeeRoleServer.cc
-doc/mico/examples/relship/EmployerRoleServer.cc
-doc/mico/examples/relship/Employment.idl
-doc/mico/examples/relship/EmploymentServer.cc
-doc/mico/examples/relship/Employment_impl.cc
-doc/mico/examples/relship/Employment_impl.h
-doc/mico/examples/relship/FigureServer.cc
-doc/mico/examples/relship/InterfaceDefsHelper.cc
-doc/mico/examples/relship/InterfaceDefsHelper.h
-doc/mico/examples/relship/Makefile
-doc/mico/examples/relship/NamedRoleTypesHelper.cc
-doc/mico/examples/relship/NamedRoleTypesHelper.h
-doc/mico/examples/relship/OwnedByRoleServer.cc
-doc/mico/examples/relship/OwnerRoleServer.cc
-doc/mico/examples/relship/Ownership.idl
-doc/mico/examples/relship/OwnershipServer.cc
-doc/mico/examples/relship/Ownership_impl.cc
-doc/mico/examples/relship/Ownership_impl.h
-doc/mico/examples/relship/Person.idl
-doc/mico/examples/relship/PersonServer.cc
-doc/mico/examples/relship/Person_impl.cc
-doc/mico/examples/relship/Person_impl.h
-doc/mico/examples/relship/Reference.idl
-doc/mico/examples/relship/ReferenceServer.cc
-doc/mico/examples/relship/Reference_impl.cc
-doc/mico/examples/relship/Reference_impl.h
-doc/mico/examples/relship/ReferencedByRoleServer.cc
-doc/mico/examples/relship/ReferencesRoleServer.cc
-doc/mico/examples/relship/RelationshipFactoryServer.cc
-doc/mico/examples/relship/RelationshipIteratorServer.cc
-doc/mico/examples/relship/RoleFactoryServer.cc
-doc/mico/examples/relship/TextServer.cc
-doc/mico/examples/relship/interactive
-doc/mico/examples/relship/interactive-client.cc
-doc/mico/examples/relship/simple
-doc/mico/examples/relship/simple-client.cc
-doc/mico/examples/relship/start-servers
-doc/mico/examples/relship/stop-servers
-doc/mico/examples/relship/test
-doc/mico/examples/relship/test-client.cc
-doc/mico/examples/shlib/Makefile
-doc/mico/examples/shlib/client.cc
-doc/mico/examples/shlib/hello
-doc/mico/examples/shlib/hello.idl
-doc/mico/examples/shlib/server.cc
-doc/mico/examples/siegel/README
-doc/mico/examples/siegel/diffs
-doc/mico/examples/ssl/Makefile
-doc/mico/examples/ssl/cert.pem
-doc/mico/examples/ssl/client.cc
-doc/mico/examples/ssl/hello.idl
-doc/mico/examples/ssl/key.pem
-doc/mico/examples/ssl/server.cc
-doc/mico/examples/ssl/ssl
-doc/mico/examples/stream-bench/Makefile
-doc/mico/examples/stream-bench/bench
-doc/mico/examples/stream-bench/req.idl
-doc/mico/examples/stream-bench/req_client.cc
-doc/mico/examples/stream-bench/req_server.cc
-doc/mico/examples/stream-bench/stream_client.cc
-doc/mico/examples/stream-bench/stream_server.cc
-doc/mico/examples/stream-sound/Makefile
-doc/mico/examples/stream-sound/client.cc
-doc/mico/examples/stream-sound/server.cc
-doc/mico/examples/stream-sound/sound.h
-doc/mico/examples/x11/Makefile
-doc/mico/examples/x11/client.cc
-doc/mico/examples/x11/hello.idl
-doc/mico/examples/x11/server.cc
-doc/mico/examples/x11/xhello
-doc/mico/manual.ps
include/CORBA-c.h
include/CORBA.h
include/mico/CosEventChannelAdmin.h
@@ -407,8 +143,6 @@ lib/libmico2.2.3.a
lib/libmicoaux2.2.3.a
lib/libmicoaux2.2.3.so.1
lib/libmicocoss2.2.3.a
-lib/libmicogtk2.2.3.a
-lib/libmicogtk2.2.3.so.1
lib/libmicoqt2.2.3.a
lib/libmicoqt2.2.3.so.1
lib/libmicotcl2.2.3.a
@@ -419,49 +153,313 @@ lib/libmicox2.2.3.so.1
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
lib/mico-setup.csh
lib/mico-setup.sh
+share/doc/mico/examples/MakeVars
+share/doc/mico/examples/README
+share/doc/mico/examples/account/Makefile
+share/doc/mico/examples/account/account.idl
+share/doc/mico/examples/account/main.cc
+share/doc/mico/examples/account2/Makefile
+share/doc/mico/examples/account2/account
+share/doc/mico/examples/account2/account.idl
+share/doc/mico/examples/account2/client.cc
+share/doc/mico/examples/account2/server.cc
+share/doc/mico/examples/account3/Makefile
+share/doc/mico/examples/account3/account
+share/doc/mico/examples/account3/account.idl
+share/doc/mico/examples/account3/client.cc
+share/doc/mico/examples/account3/server.cc
+share/doc/mico/examples/account4/Makefile
+share/doc/mico/examples/account4/account
+share/doc/mico/examples/account4/account.idl
+share/doc/mico/examples/account4/client.cc
+share/doc/mico/examples/account4/server.cc
+share/doc/mico/examples/activate/Makefile
+share/doc/mico/examples/activate/client.cc
+share/doc/mico/examples/activate/hello-permethod
+share/doc/mico/examples/activate/hello-shared
+share/doc/mico/examples/activate/hello-unshared
+share/doc/mico/examples/activate/hello.idl
+share/doc/mico/examples/activate/server.cc
+share/doc/mico/examples/bench/Makefile
+share/doc/mico/examples/bench/bench
+share/doc/mico/examples/bench/bench.idl
+share/doc/mico/examples/bench/bench_impl.h
+share/doc/mico/examples/bench/client.cc
+share/doc/mico/examples/bench/server.cc
+share/doc/mico/examples/codesets/Makefile
+share/doc/mico/examples/codesets/client.cc
+share/doc/mico/examples/codesets/hello.idl
+share/doc/mico/examples/codesets/runit
+share/doc/mico/examples/codesets/server.cc
+share/doc/mico/examples/corba-c/Makefile
+share/doc/mico/examples/corba-c/client.c
+share/doc/mico/examples/corba-c/hello
+share/doc/mico/examples/corba-c/hello.idl
+share/doc/mico/examples/corba-c/server.c
+share/doc/mico/examples/dynany/Makefile
+share/doc/mico/examples/dynany/dynany.cc
+share/doc/mico/examples/dynany/dynanytest.cc
+share/doc/mico/examples/dynany/test.idl
+share/doc/mico/examples/events/Makefile
+share/doc/mico/examples/events/client.cc
+share/doc/mico/examples/events/client2.cc
+share/doc/mico/examples/events/runit
+share/doc/mico/examples/events/server.cc
+share/doc/mico/examples/events/server2.cc
+share/doc/mico/examples/events/server3.cc
+share/doc/mico/examples/gtkmico/Makefile
+share/doc/mico/examples/gtkmico/README
+share/doc/mico/examples/gtkmico/client.cc
+share/doc/mico/examples/gtkmico/gtkhello
+share/doc/mico/examples/gtkmico/hello.idl
+share/doc/mico/examples/gtkmico/server.cc
+share/doc/mico/examples/interceptor/Makefile
+share/doc/mico/examples/interceptor/client.cc
+share/doc/mico/examples/interceptor/hello.idl
+share/doc/mico/examples/interceptor/runit
+share/doc/mico/examples/interceptor/server.cc
+share/doc/mico/examples/interop/Makefile
+share/doc/mico/examples/interop/README
+share/doc/mico/examples/interop/jacorb/Account.idl
+share/doc/mico/examples/interop/jacorb/Client.java
+share/doc/mico/examples/interop/jacorb/ClientApplet.html.in
+share/doc/mico/examples/interop/jacorb/ClientApplet.java
+share/doc/mico/examples/interop/jacorb/Makefile
+share/doc/mico/examples/interop/jacorb/README
+share/doc/mico/examples/interop/jacorb/Server.java
+share/doc/mico/examples/interop/jacorb/account
+share/doc/mico/examples/interop/jacorb/client.cc
+share/doc/mico/examples/interop/jacorb/run_applet
+share/doc/mico/examples/interop/jacorb/server.cc
+share/doc/mico/examples/interop/jdk/Account.idl
+share/doc/mico/examples/interop/jdk/Client.java
+share/doc/mico/examples/interop/jdk/ClientApplet.html.in
+share/doc/mico/examples/interop/jdk/ClientApplet.java
+share/doc/mico/examples/interop/jdk/Makefile
+share/doc/mico/examples/interop/jdk/README
+share/doc/mico/examples/interop/jdk/account
+share/doc/mico/examples/interop/jdk/main.cc
+share/doc/mico/examples/interop/jdk/run_applet
+share/doc/mico/examples/interop/orbix/Makefile
+share/doc/mico/examples/interop/orbix/README
+share/doc/mico/examples/interop/orbix/grid.idl
+share/doc/mico/examples/interop/orbix/main.cc
+share/doc/mico/examples/interop/visibroker/Account.idl
+share/doc/mico/examples/interop/visibroker/Client.java
+share/doc/mico/examples/interop/visibroker/ClientApplet.html.in
+share/doc/mico/examples/interop/visibroker/ClientApplet.java
+share/doc/mico/examples/interop/visibroker/Makefile
+share/doc/mico/examples/interop/visibroker/README
+share/doc/mico/examples/interop/visibroker/account
+share/doc/mico/examples/interop/visibroker/main.cc
+share/doc/mico/examples/interop/visibroker/run_applet
+share/doc/mico/examples/naming/Makefile
+share/doc/mico/examples/naming/account.idl
+share/doc/mico/examples/naming/account_test
+share/doc/mico/examples/naming/client.cc
+share/doc/mico/examples/naming/server.cc
+share/doc/mico/examples/poa/Makefile
+share/doc/mico/examples/poa/README
+share/doc/mico/examples/poa/account-1/Makefile
+share/doc/mico/examples/poa/account-1/account
+share/doc/mico/examples/poa/account-1/account.idl
+share/doc/mico/examples/poa/account-1/client.cc
+share/doc/mico/examples/poa/account-1/server.cc
+share/doc/mico/examples/poa/account-2/Makefile
+share/doc/mico/examples/poa/account-2/account
+share/doc/mico/examples/poa/account-2/account.idl
+share/doc/mico/examples/poa/account-2/client.cc
+share/doc/mico/examples/poa/account-2/server.cc
+share/doc/mico/examples/poa/account-3/Makefile
+share/doc/mico/examples/poa/account-3/account
+share/doc/mico/examples/poa/account-3/account.idl
+share/doc/mico/examples/poa/account-3/client.cc
+share/doc/mico/examples/poa/account-3/server.cc
+share/doc/mico/examples/poa/hello-1/Makefile
+share/doc/mico/examples/poa/hello-1/client.cc
+share/doc/mico/examples/poa/hello-1/hello
+share/doc/mico/examples/poa/hello-1/hello.idl
+share/doc/mico/examples/poa/hello-1/server.cc
+share/doc/mico/examples/poa/hello-2/Makefile
+share/doc/mico/examples/poa/hello-2/client.cc
+share/doc/mico/examples/poa/hello-2/hello
+share/doc/mico/examples/poa/hello-2/hello.idl
+share/doc/mico/examples/poa/hello-2/server.cc
+share/doc/mico/examples/poa/inherit/Makefile
+share/doc/mico/examples/poa/inherit/client.cc
+share/doc/mico/examples/poa/inherit/inherit
+share/doc/mico/examples/poa/inherit/inherit.idl
+share/doc/mico/examples/poa/inherit/server.cc
+share/doc/mico/examples/qtmico/Makefile
+share/doc/mico/examples/qtmico/README
+share/doc/mico/examples/qtmico/client.cc
+share/doc/mico/examples/qtmico/hello.idl
+share/doc/mico/examples/qtmico/qthello1
+share/doc/mico/examples/qtmico/qthello2
+share/doc/mico/examples/qtmico/server.cc
+share/doc/mico/examples/redlich/Calc-1/Makefile
+share/doc/mico/examples/redlich/Calc-1/calc.idl
+share/doc/mico/examples/redlich/Calc-1/client.cc
+share/doc/mico/examples/redlich/Calc-1/server.cc
+share/doc/mico/examples/redlich/Calc-2/Makefile
+share/doc/mico/examples/redlich/Calc-2/calc.idl
+share/doc/mico/examples/redlich/Calc-2/client.cc
+share/doc/mico/examples/redlich/Calc-2/server.cc
+share/doc/mico/examples/redlich/Calc-3/Makefile
+share/doc/mico/examples/redlich/Calc-3/calc.idl
+share/doc/mico/examples/redlich/Calc-3/client.cc
+share/doc/mico/examples/redlich/Calc-3/server.cc
+share/doc/mico/examples/redlich/Calc-4/Makefile
+share/doc/mico/examples/redlich/Calc-4/calc.idl
+share/doc/mico/examples/redlich/Calc-4/client.cc
+share/doc/mico/examples/redlich/Calc-4/server.cc
+share/doc/mico/examples/redlich/Hello-1/Makefile
+share/doc/mico/examples/redlich/Hello-1/client.cc
+share/doc/mico/examples/redlich/Hello-1/server.cc
+share/doc/mico/examples/redlich/Hello-1/tty.idl
+share/doc/mico/examples/redlich/Hello-2/Makefile
+share/doc/mico/examples/redlich/Hello-2/client.cc
+share/doc/mico/examples/redlich/Hello-2/server.cc
+share/doc/mico/examples/redlich/Hello-2/tty.idl
+share/doc/mico/examples/redlich/Hello-3/Makefile
+share/doc/mico/examples/redlich/Hello-3/client.cc
+share/doc/mico/examples/redlich/Hello-3/server.cc
+share/doc/mico/examples/redlich/Hello-3/tty.idl
+share/doc/mico/examples/redlich/Hello-3/ttyplus.idl
+share/doc/mico/examples/redlich/Hello-4/Makefile
+share/doc/mico/examples/redlich/Hello-4/client.cc
+share/doc/mico/examples/redlich/Hello-4/server.cc
+share/doc/mico/examples/redlich/Hello-4/tty.idl
+share/doc/mico/examples/redlich/Hello-4/ttyplus.idl
+share/doc/mico/examples/redlich/Makefile
+share/doc/mico/examples/redlich/README
+share/doc/mico/examples/relship/Bank.idl
+share/doc/mico/examples/relship/BankServer.cc
+share/doc/mico/examples/relship/Bank_impl.cc
+share/doc/mico/examples/relship/Bank_impl.h
+share/doc/mico/examples/relship/ContainedInRoleServer.cc
+share/doc/mico/examples/relship/Containment.idl
+share/doc/mico/examples/relship/ContainmentServer.cc
+share/doc/mico/examples/relship/Containment_impl.cc
+share/doc/mico/examples/relship/Containment_impl.h
+share/doc/mico/examples/relship/ContainsRoleServer.cc
+share/doc/mico/examples/relship/Documents.idl
+share/doc/mico/examples/relship/Documents_impl.cc
+share/doc/mico/examples/relship/Documents_impl.h
+share/doc/mico/examples/relship/EmployeeRoleServer.cc
+share/doc/mico/examples/relship/EmployerRoleServer.cc
+share/doc/mico/examples/relship/Employment.idl
+share/doc/mico/examples/relship/EmploymentServer.cc
+share/doc/mico/examples/relship/Employment_impl.cc
+share/doc/mico/examples/relship/Employment_impl.h
+share/doc/mico/examples/relship/FigureServer.cc
+share/doc/mico/examples/relship/InterfaceDefsHelper.cc
+share/doc/mico/examples/relship/InterfaceDefsHelper.h
+share/doc/mico/examples/relship/Makefile
+share/doc/mico/examples/relship/NamedRoleTypesHelper.cc
+share/doc/mico/examples/relship/NamedRoleTypesHelper.h
+share/doc/mico/examples/relship/OwnedByRoleServer.cc
+share/doc/mico/examples/relship/OwnerRoleServer.cc
+share/doc/mico/examples/relship/Ownership.idl
+share/doc/mico/examples/relship/OwnershipServer.cc
+share/doc/mico/examples/relship/Ownership_impl.cc
+share/doc/mico/examples/relship/Ownership_impl.h
+share/doc/mico/examples/relship/Person.idl
+share/doc/mico/examples/relship/PersonServer.cc
+share/doc/mico/examples/relship/Person_impl.cc
+share/doc/mico/examples/relship/Person_impl.h
+share/doc/mico/examples/relship/Reference.idl
+share/doc/mico/examples/relship/ReferenceServer.cc
+share/doc/mico/examples/relship/Reference_impl.cc
+share/doc/mico/examples/relship/Reference_impl.h
+share/doc/mico/examples/relship/ReferencedByRoleServer.cc
+share/doc/mico/examples/relship/ReferencesRoleServer.cc
+share/doc/mico/examples/relship/RelationshipFactoryServer.cc
+share/doc/mico/examples/relship/RelationshipIteratorServer.cc
+share/doc/mico/examples/relship/RoleFactoryServer.cc
+share/doc/mico/examples/relship/TextServer.cc
+share/doc/mico/examples/relship/interactive
+share/doc/mico/examples/relship/interactive-client.cc
+share/doc/mico/examples/relship/simple
+share/doc/mico/examples/relship/simple-client.cc
+share/doc/mico/examples/relship/start-servers
+share/doc/mico/examples/relship/stop-servers
+share/doc/mico/examples/relship/test
+share/doc/mico/examples/relship/test-client.cc
+share/doc/mico/examples/shlib/Makefile
+share/doc/mico/examples/shlib/client.cc
+share/doc/mico/examples/shlib/hello
+share/doc/mico/examples/shlib/hello.idl
+share/doc/mico/examples/shlib/server.cc
+share/doc/mico/examples/siegel/README
+share/doc/mico/examples/siegel/diffs
+share/doc/mico/examples/ssl/Makefile
+share/doc/mico/examples/ssl/cert.pem
+share/doc/mico/examples/ssl/client.cc
+share/doc/mico/examples/ssl/hello.idl
+share/doc/mico/examples/ssl/key.pem
+share/doc/mico/examples/ssl/server.cc
+share/doc/mico/examples/ssl/ssl
+share/doc/mico/examples/stream-bench/Makefile
+share/doc/mico/examples/stream-bench/bench
+share/doc/mico/examples/stream-bench/req.idl
+share/doc/mico/examples/stream-bench/req_client.cc
+share/doc/mico/examples/stream-bench/req_server.cc
+share/doc/mico/examples/stream-bench/stream_client.cc
+share/doc/mico/examples/stream-bench/stream_server.cc
+share/doc/mico/examples/stream-sound/Makefile
+share/doc/mico/examples/stream-sound/client.cc
+share/doc/mico/examples/stream-sound/server.cc
+share/doc/mico/examples/stream-sound/sound.h
+share/doc/mico/examples/x11/Makefile
+share/doc/mico/examples/x11/client.cc
+share/doc/mico/examples/x11/hello.idl
+share/doc/mico/examples/x11/server.cc
+share/doc/mico/examples/x11/xhello
+share/doc/mico/manual.ps
@dirrm include/ministl
@dirrm include/mico
-@dirrm doc/mico/examples/x11
-@dirrm doc/mico/examples/stream-sound
-@dirrm doc/mico/examples/stream-bench
-@dirrm doc/mico/examples/ssl
-@dirrm doc/mico/examples/siegel
-@dirrm doc/mico/examples/shlib
-@dirrm doc/mico/examples/relship
-@dirrm doc/mico/examples/redlich/Hello-4
-@dirrm doc/mico/examples/redlich/Hello-3
-@dirrm doc/mico/examples/redlich/Hello-2
-@dirrm doc/mico/examples/redlich/Hello-1
-@dirrm doc/mico/examples/redlich/Calc-4
-@dirrm doc/mico/examples/redlich/Calc-3
-@dirrm doc/mico/examples/redlich/Calc-2
-@dirrm doc/mico/examples/redlich/Calc-1
-@dirrm doc/mico/examples/redlich
-@dirrm doc/mico/examples/qtmico
-@dirrm doc/mico/examples/poa/inherit
-@dirrm doc/mico/examples/poa/hello-2
-@dirrm doc/mico/examples/poa/hello-1
-@dirrm doc/mico/examples/poa/account-3
-@dirrm doc/mico/examples/poa/account-2
-@dirrm doc/mico/examples/poa/account-1
-@dirrm doc/mico/examples/poa
-@dirrm doc/mico/examples/naming
-@dirrm doc/mico/examples/interop/visibroker
-@dirrm doc/mico/examples/interop/orbix
-@dirrm doc/mico/examples/interop/jdk
-@dirrm doc/mico/examples/interop/jacorb
-@dirrm doc/mico/examples/interop
-@dirrm doc/mico/examples/interceptor
-@dirrm doc/mico/examples/gtkmico
-@dirrm doc/mico/examples/events
-@dirrm doc/mico/examples/dynany
-@dirrm doc/mico/examples/corba-c
-@dirrm doc/mico/examples/codesets
-@dirrm doc/mico/examples/bench
-@dirrm doc/mico/examples/activate
-@dirrm doc/mico/examples/account4
-@dirrm doc/mico/examples/account3
-@dirrm doc/mico/examples/account2
-@dirrm doc/mico/examples/account
-@dirrm doc/mico/examples
-@dirrm doc/mico
+@dirrm share/doc/mico/examples/x11
+@dirrm share/doc/mico/examples/stream-sound
+@dirrm share/doc/mico/examples/stream-bench
+@dirrm share/doc/mico/examples/ssl
+@dirrm share/doc/mico/examples/siegel
+@dirrm share/doc/mico/examples/shlib
+@dirrm share/doc/mico/examples/relship
+@dirrm share/doc/mico/examples/redlich/Hello-4
+@dirrm share/doc/mico/examples/redlich/Hello-3
+@dirrm share/doc/mico/examples/redlich/Hello-2
+@dirrm share/doc/mico/examples/redlich/Hello-1
+@dirrm share/doc/mico/examples/redlich/Calc-4
+@dirrm share/doc/mico/examples/redlich/Calc-3
+@dirrm share/doc/mico/examples/redlich/Calc-2
+@dirrm share/doc/mico/examples/redlich/Calc-1
+@dirrm share/doc/mico/examples/redlich
+@dirrm share/doc/mico/examples/qtmico
+@dirrm share/doc/mico/examples/poa/inherit
+@dirrm share/doc/mico/examples/poa/hello-2
+@dirrm share/doc/mico/examples/poa/hello-1
+@dirrm share/doc/mico/examples/poa/account-3
+@dirrm share/doc/mico/examples/poa/account-2
+@dirrm share/doc/mico/examples/poa/account-1
+@dirrm share/doc/mico/examples/poa
+@dirrm share/doc/mico/examples/naming
+@dirrm share/doc/mico/examples/interop/visibroker
+@dirrm share/doc/mico/examples/interop/orbix
+@dirrm share/doc/mico/examples/interop/jdk
+@dirrm share/doc/mico/examples/interop/jacorb
+@dirrm share/doc/mico/examples/interop
+@dirrm share/doc/mico/examples/interceptor
+@dirrm share/doc/mico/examples/gtkmico
+@dirrm share/doc/mico/examples/events
+@dirrm share/doc/mico/examples/dynany
+@dirrm share/doc/mico/examples/corba-c
+@dirrm share/doc/mico/examples/codesets
+@dirrm share/doc/mico/examples/bench
+@dirrm share/doc/mico/examples/activate
+@dirrm share/doc/mico/examples/account4
+@dirrm share/doc/mico/examples/account3
+@dirrm share/doc/mico/examples/account2
+@dirrm share/doc/mico/examples/account
+@dirrm share/doc/mico/examples
+@dirrm share/doc/mico