aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-09-21 01:03:10 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-09-21 01:03:10 +0000
commit7c073e9d51318cf901385976915fa67afb769288 (patch)
tree0403d871e70bb6c20ab76c0411c385646a614d96
parent30f779debfef7e8718ce1b6e8941e575b1331695 (diff)
downloadports-7c073e9d51318cf901385976915fa67afb769288.tar.gz
ports-7c073e9d51318cf901385976915fa67afb769288.zip
* Support blowfish encription.
* Install the cfs's ssh as cfssh.
Notes
Notes: svn path=/head/; revision=13270
-rw-r--r--security/cfs/Makefile12
-rw-r--r--security/cfs/distinfo2
-rw-r--r--security/cfs/files/patch-ac21
-rw-r--r--security/cfs/pkg-plist1
4 files changed, 32 insertions, 4 deletions
diff --git a/security/cfs/Makefile b/security/cfs/Makefile
index 6b4f521360bf..c979f0c8396c 100644
--- a/security/cfs/Makefile
+++ b/security/cfs/Makefile
@@ -3,10 +3,11 @@
# Date created: 30 Jul 1997
# Whom: John Polstra <jdp@polstra.com>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/07/30 22:10:19 jdp Exp $
#
-DISTNAME= cfs-1.3.3
+DISTNAME= cfs-1.3.3bf
+PKGNAME= cfs-1.3.3.1
CATEGORIES= security
MASTER_SITES= ftp://utopia.hacktic.nl/pub/crypto/disk/ \
ftp://ftp.informatik.uni-hamburg.de/pub/virus/crypt/disk/
@@ -14,14 +15,19 @@ MASTER_SITES= ftp://utopia.hacktic.nl/pub/crypto/disk/ \
MAINTAINER= jdp@polstra.com
ALL_TARGET= cfs
-MAN1= cattach.1 cdetach.1 cmkdir.1 cpasswd.1
+MAN1= cattach.1 cdetach.1 cmkdir.1 cpasswd.1 cfssh.1
MAN8= ccat.8 cfsd.8 cname.8
RESTRICTED= "contains crypto code"
+pre-build:
+ @${CP} ${FILESDIR}/bf_tab.h ${WRKSRC}
+
do-install:
+ @${CP} ${WRKSRC}/ssh.1 ${WRKSRC}/cfssh.1
@cd ${WRKSRC}; \
${INSTALL_PROGRAM} ccat cfsd cname ${PREFIX}/sbin; \
${INSTALL_PROGRAM} cattach cdetach cmkdir cpasswd ${PREFIX}/bin; \
+ ${INSTALL_SCRIPT} ssh ${PREFIX}/bin/cfssh; \
${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1; \
${INSTALL_MAN} ${MAN8} ${PREFIX}/man/man8; \
${MKDIR} ${PREFIX}/share/doc/cfs; \
diff --git a/security/cfs/distinfo b/security/cfs/distinfo
index 0900ac4eab43..0be16f4a65fd 100644
--- a/security/cfs/distinfo
+++ b/security/cfs/distinfo
@@ -1 +1 @@
-MD5 (cfs-1.3.3.tar.gz) = 44accb7e102a78150dd35e9fa36d7f5f
+MD5 (cfs-1.3.3bf.tar.gz) = c0cb2dbb09eb2c0b583337aa784ba49d
diff --git a/security/cfs/files/patch-ac b/security/cfs/files/patch-ac
new file mode 100644
index 000000000000..810482602cee
--- /dev/null
+++ b/security/cfs/files/patch-ac
@@ -0,0 +1,21 @@
+--- ssh.1.orig Sat Jan 1 04:35:00 1994
++++ ssh.1 Sun Sep 20 17:59:46 1998
+@@ -1,14 +1,14 @@
+ .TH SSH 1 ""
+ .SH NAME
+-ssh - (somewhat) secure CFS shell
++cfssh - (somewhat) secure CFS shell
+ .SH SYNOPSIS
+-.B ssh
++.B cfssh
+ \fIdirectory\fP
+ .SH DESCRIPTION
+-\fBssh\fP uses \fBcattach\fP(1) to associate the encrypted
++\fBcfssh\fP uses \fBcattach\fP(1) to associate the encrypted
+ \fIdirectory\fP (previously created with \fBcmkdir\fP(1)) with a
+ randomly selected name. Once the correct passphrase is provided,
+-\fBssh\fP invokes a new shell with the random directory in /crypt as its
++\fBcfssh\fP invokes a new shell with the random directory in /crypt as its
+ working directory.
+ When the shell exits, the temporary attach name is deleted with
+ cdetach(1).
diff --git a/security/cfs/pkg-plist b/security/cfs/pkg-plist
index 4e7029eab53b..3b99528edf6a 100644
--- a/security/cfs/pkg-plist
+++ b/security/cfs/pkg-plist
@@ -2,6 +2,7 @@ bin/cattach
bin/cdetach
bin/cmkdir
bin/cpasswd
+bin/cfssh
etc/rc.d/cfsd.sh
sbin/ccat
sbin/cfsd