aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2000-10-28 12:44:15 +0000
committerJames E. Housley <jeh@FreeBSD.org>2000-10-28 12:44:15 +0000
commitb121518905294737790136be3413b6e3aa2e69e0 (patch)
tree9892e72fc66fc13660cb50ba0ba0c1f78035fae2
parentd391bfd2ddd76ec09177656933adbb0db01f55aa (diff)
downloadports-b121518905294737790136be3413b6e3aa2e69e0.tar.gz
ports-b121518905294737790136be3413b6e3aa2e69e0.zip
New Port: security/cksfv
Create or manipulate Simple File Verification (SFV) checksum files PR: 22075 Submitted by: Johann Visagie <johann@egenetics.com>
Notes
Notes: svn path=/head/; revision=34353
-rw-r--r--security/Makefile1
-rw-r--r--security/cksfv/Makefile26
-rw-r--r--security/cksfv/distinfo1
-rw-r--r--security/cksfv/files/patch-src-Makefile20
-rw-r--r--security/cksfv/pkg-comment1
-rw-r--r--security/cksfv/pkg-descr13
-rw-r--r--security/cksfv/pkg-plist3
7 files changed, 65 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a272665dffc6..6cf45c2551c5 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -12,6 +12,7 @@
SUBDIR += cfs
SUBDIR += checkpassword
SUBDIR += chrootuid
+ SUBDIR += cksfv
SUBDIR += cops
SUBDIR += crack
SUBDIR += cyrus-sasl
diff --git a/security/cksfv/Makefile b/security/cksfv/Makefile
new file mode 100644
index 000000000000..8ccdcb564f3c
--- /dev/null
+++ b/security/cksfv/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: cksfv
+# Date created: 18 October 2000
+# Whom: Johann Visagie <johann@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cksfv
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= http://www.fodder.org/cksfv/
+
+MAINTAINER= johann@egenetics.com
+
+BUILD_WRKSRC= ${WRKSRC}/src
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+USE_GMAKE= yes
+ALL_TARGET= cksfv
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/cksfv
+ @ ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/cksfv
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/cksfv/distinfo b/security/cksfv/distinfo
new file mode 100644
index 000000000000..a43d957cb80f
--- /dev/null
+++ b/security/cksfv/distinfo
@@ -0,0 +1 @@
+MD5 (cksfv-1.1.tar.gz) = e32e3fc05b99ce8ff06af57df3f16952
diff --git a/security/cksfv/files/patch-src-Makefile b/security/cksfv/files/patch-src-Makefile
new file mode 100644
index 000000000000..5b16eb6b2bac
--- /dev/null
+++ b/security/cksfv/files/patch-src-Makefile
@@ -0,0 +1,20 @@
+--- src/Makefile.orig Mon May 22 23:57:05 2000
++++ src/Makefile Wed Oct 18 10:14:25 2000
+@@ -17,14 +17,15 @@
+ # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+ PROG= cksfv
++CC?= gcc
+ CFLAGS+= -Wall -Werror -O2
+ SRCS= cksfv.c print.c crc32.c readsfv.c newsfv.c
+
+ cksfv: $(SRCS)
+- gcc $(CFLAGS) -o $(PROG) $(SRCS)
++ $(CC) $(CFLAGS) -o $(PROG) $(SRCS)
+
+ install: cksfv
+- cp $(PROG) /usr/local/bin
++ $(BSD_INSTALL_PROGRAM) $(PROG) $(PREFIX)/bin
+
+ clean:
+ rm -f *.o *~ *.core $(PROG)
diff --git a/security/cksfv/pkg-comment b/security/cksfv/pkg-comment
new file mode 100644
index 000000000000..9dc5537bb429
--- /dev/null
+++ b/security/cksfv/pkg-comment
@@ -0,0 +1 @@
+Create or manipulate Simple File Verification (SFV) checksum files
diff --git a/security/cksfv/pkg-descr b/security/cksfv/pkg-descr
new file mode 100644
index 000000000000..638550a12f73
--- /dev/null
+++ b/security/cksfv/pkg-descr
@@ -0,0 +1,13 @@
+The Simple File Verification (SFV) system is a file integrity verification
+system which is popular on some platforms. A software package may be
+accompanied by an SFV file (usually with extension .sfv) which contains
+CRC-32 checksums for all the files that comprise the package.
+
+cksfv (Check SFV) can both create simple file verification (SFV) files, and
+test file integrity against existing SFV files.
+
+Licence: GPL
+Author: Bryan Call <bc@fodder.org>
+WWW: http://www.fodder.org/cksfv/
+
+-- Johann Visagie <johann@egenetics.com>
diff --git a/security/cksfv/pkg-plist b/security/cksfv/pkg-plist
new file mode 100644
index 000000000000..58de1a5f076a
--- /dev/null
+++ b/security/cksfv/pkg-plist
@@ -0,0 +1,3 @@
+bin/cksfv
+share/doc/cksfv/README
+@dirrm share/doc/cksfv