aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-27 05:28:17 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-27 05:28:17 +0000
commitebb9c238ca7749709f3b6d55cd12b98fd6948378 (patch)
tree41307c8a3cd47439021c68129aae8d2561c72ec3
parentd395a83db428f921de83f7cc87bd1dcfad60077a (diff)
downloadports-ebb9c238ca7749709f3b6d55cd12b98fd6948378.tar.gz
ports-ebb9c238ca7749709f3b6d55cd12b98fd6948378.zip
Use libgmp4 on -CURRENT to allow this port to build on 64-bit architectures.
Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=94800
-rw-r--r--lang/librep/Makefile5
-rw-r--r--lang/librep/files/patch-src_numbers.c22
2 files changed, 2 insertions, 25 deletions
diff --git a/lang/librep/Makefile b/lang/librep/Makefile
index 8e85481295a6..df40be697547 100644
--- a/lang/librep/Makefile
+++ b/lang/librep/Makefile
@@ -7,7 +7,7 @@
PORTNAME= librep
PORTVERSION= 0.16.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang elisp gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= librep
@@ -40,8 +40,7 @@ PREFIX?= ${X11BASE}
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500023
-BUILD_DEPENDS+= ${LOCALBASE}/include/gmp.h:${PORTSDIR}/math/libgmp-freebsd
-RUN_DEPENDS+= ${LOCALBASE}/include/gmp.h:${PORTSDIR}/math/libgmp-freebsd
+LIB_DEPENDS+= gmp.6:${PORTSDIR}/math/libgmp4
.endif
.if ${XFREE86_VERSION} == 3
diff --git a/lang/librep/files/patch-src_numbers.c b/lang/librep/files/patch-src_numbers.c
deleted file mode 100644
index 189ad75de6ae..000000000000
--- a/lang/librep/files/patch-src_numbers.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/numbers.c.orig Sat May 31 17:50:08 2003
-+++ src/numbers.c Sat May 31 18:15:24 2003
-@@ -2696,13 +2696,14 @@
- #ifdef HAVE_GMP
- else
- {
-- rep_number_q *q;
-+ double x, y;
-+ rep_number_z *z;
-
-- q = make_number (rep_NUMBER_RATIONAL);
-- mpq_init (q->q);
-- mpq_set_d (q->q, rep_get_float (arg));
-+ rationalize (arg, &x, &y);
-+ z = make_number (rep_NUMBER_BIGNUM);
-+ mpz_init_set_d (z->z, (x / y));
-
-- return maybe_demote (rep_VAL (q));
-+ return maybe_demote (rep_VAL (z));
- }
- #else
- else