aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-10-08 18:41:38 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-10-08 18:41:38 +0000
commitc3b3164cc907a178fee5b65fc16bdc3f730cdf0e (patch)
tree7eb99dfe42e7126830c8e953c7281902fd91d132
parentadeb789b91635cbd3aba5503feebf5964d064cbd (diff)
downloadports-c3b3164cc907a178fee5b65fc16bdc3f730cdf0e.tar.gz
ports-c3b3164cc907a178fee5b65fc16bdc3f730cdf0e.zip
- Fix build under gcc34
PR: 72449 Submitted by: Michael Johnson Approved by: portmgr (marcus) Obtained from: vls cvs
Notes
Notes: svn path=/head/; revision=118589
-rw-r--r--net/vls/Makefile3
-rw-r--r--net/vls/files/patch-gcc3485
2 files changed, 87 insertions, 1 deletions
diff --git a/net/vls/Makefile b/net/vls/Makefile
index 8a5745ba291a..cd45641daa7d 100644
--- a/net/vls/Makefile
+++ b/net/vls/Makefile
@@ -48,7 +48,8 @@ CONFIGURE_ENV+= VLS_LIB="-L/usr/lib -lcipher"
.endif
.if ${OSVERSION} >= 502122
-BROKEN= new gcc: an explicit specialization must be preceded by template
+# allow nonconforming code to compile
+CFLAGS+= -fpermissive
.endif
.include <bsd.port.post.mk>
diff --git a/net/vls/files/patch-gcc34 b/net/vls/files/patch-gcc34
new file mode 100644
index 000000000000..618f7eeab4e3
--- /dev/null
+++ b/net/vls/files/patch-gcc34
@@ -0,0 +1,85 @@
+--- src/core/hashtable.h.orig Fri Oct 8 10:37:06 2004
++++ src/core/hashtable.h Fri Oct 8 10:37:16 2004
+@@ -2,7 +2,7 @@
+ * hashtable.h: Hashtable class definition
+ *-------------------------------------------------------------------------------
+ * (c)1999-2001 VideoLAN
+-* $Id: hashtable.h,v 1.1 2001/10/06 21:23:36 bozo Exp $
++* $Id$
+ *
+ * Authors: Benoit Steiner <benny@via.ecp.fr>
+ *
+@@ -63,7 +63,7 @@
+ };
+
+
+-class C_HashMethod<u32>
++template <> class C_HashMethod<u32>
+ {
+ public:
+ inline C_HashMethod(u32 uiMaxHash);
+@@ -76,7 +76,7 @@
+ };
+
+
+-class C_HashMethod<u16>
++template <> class C_HashMethod<u16>
+ {
+ public:
+ inline C_HashMethod(u32 uiMaxHash);
+@@ -89,7 +89,7 @@
+ };
+
+
+-class C_HashMethod<handle>
++template <> class C_HashMethod<handle>
+ {
+ public:
+ inline C_HashMethod(u32 uiMaxHash);
+--- src/core/library.cpp.orig Fri Oct 8 10:49:59 2004
++++ src/core/library.cpp Fri Oct 8 10:51:20 2004
+@@ -34,6 +34,7 @@
+ // use the template: look at vector.h for further explanation
+
+
++#define DL_LAZY 1
+
+ //******************************************************************************
+ // class C_Library
+--- src/core/stream.cpp.orig Fri Oct 8 11:03:00 2004
++++ src/core/stream.cpp Fri Oct 8 11:04:48 2004
+@@ -2,7 +2,7 @@
+ * stream.cpp: Stream class
+ *-------------------------------------------------------------------------------
+ * (c)1999-2001 VideoLAN
+-* $Id: stream.cpp,v 1.3 2002/09/04 10:56:34 jpsaman Exp $
++* $Id$
+ *
+ * Authors: Benoit Steiner <benny@via.ecp.fr>
+ *
+@@ -319,7 +319,7 @@
+ {
+ try
+ {
+- u32 iByteCount = cSerializer.NextBytesCount();
++ u32 iByteCount = this->cSerializer.NextBytesCount();
+ while(iByteCount > 0)
+ {
+ const byte aBytes[iByteCount];
+@@ -332,13 +332,13 @@
+ ASSERT(iRc >= 0 || iRc == FILE_EOF);
+ iOffset += iRc;
+ }
+- while(iByteCount > 0 && iRc != FILE_EOF);
++ while(iByteCount > 0 && this->iRc != FILE_EOF);
+
+ // Deserialize them
+- cSerializer.SetNextBytes(&aBytes);
++ this->cSerializer.SetNextBytes(&aBytes);
+
+ // Next iteration
+- iByteCount = cSerializer.NextBytesCount();
++ iByteCount = this->cSerializer.NextBytesCount();
+ }
+ }
+ catch(E_Exception e)