aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-22 16:19:30 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-22 16:19:30 +0000
commitb1f4290786633381dad1fd22a8386584345ea0c5 (patch)
tree84f738bd9da56ebc4653c2dc58c22addf49ae8d7
parent020a46efec69539e28f0c5b92999a5398115292d (diff)
downloadports-b1f4290786633381dad1fd22a8386584345ea0c5.tar.gz
ports-b1f4290786633381dad1fd22a8386584345ea0c5.zip
- Unbreak it on FreeBSD >= 6.x
PR: ports/85088 Submitted by: Johan van Selst <johans@stack.nl> Approved by: portmgr (linimon)
Notes
Notes: svn path=/head/; revision=140954
-rw-r--r--devel/ngpt/Makefile12
-rw-r--r--devel/ngpt/files/patch-pthread.h.in10
-rw-r--r--devel/ngpt/files/patch-uthread_spinlock.c14
3 files changed, 26 insertions, 10 deletions
diff --git a/devel/ngpt/Makefile b/devel/ngpt/Makefile
index f32416990959..c32a48d79c49 100644
--- a/devel/ngpt/Makefile
+++ b/devel/ngpt/Makefile
@@ -21,14 +21,6 @@ CONFIGURE_ARGS= --enable-tests=no --enable-maintainer=no --enable-pthread \
--disable-kernel-patch
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
+ONLY_FOR_ARCHS= amd64 i386
-.if ${ARCH} != "i386" && ${ARCH} != "amd64"
-BROKEN= "Does not compile on !i386 and !amd64"
-.endif
-
-.if ${OSVERSION} >= 600031
-BROKEN= "Does not compile on FreeBSD >= 6.0"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ngpt/files/patch-pthread.h.in b/devel/ngpt/files/patch-pthread.h.in
new file mode 100644
index 000000000000..993d3dfb4979
--- /dev/null
+++ b/devel/ngpt/files/patch-pthread.h.in
@@ -0,0 +1,10 @@
+--- pthread.h.in.orig Thu Aug 18 13:49:14 2005
++++ pthread.h.in Thu Aug 18 13:49:07 2005
+@@ -50,6 +50,7 @@
+ #define _SYS_PTHREAD_H_
+ #define SYS_PTHREAD_INCLUDED
+ #define _SYS_PTHREAD_INCLUDED
++#define _SYS__PTHREADTYPES_H_
+ #ifdef _PTHREAD_PRIVATE
+ #define BITS_PTHREADTYPES_H
+ #define _BITS_PTHREADTYPES_H
diff --git a/devel/ngpt/files/patch-uthread_spinlock.c b/devel/ngpt/files/patch-uthread_spinlock.c
new file mode 100644
index 000000000000..5d1fa80cffa9
--- /dev/null
+++ b/devel/ngpt/files/patch-uthread_spinlock.c
@@ -0,0 +1,14 @@
+--- uthread_spinlock.c.orig Thu Aug 18 13:45:38 2005
++++ uthread_spinlock.c Thu Aug 18 13:44:36 2005
+@@ -33,10 +33,10 @@
+ *
+ */
+
++#include <pthread.h>
+ #include <stdio.h>
+ #include <sched.h>
+ #include <unistd.h>
+-#include <pthread.h>
+ #include <string.h>
+ #include "spinlock.h"
+