aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2010-07-08 07:37:31 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2010-07-08 07:37:31 +0000
commitf2440db2ac6d1a099a0baae5d583f4fd8a043e0c (patch)
tree80ccee3e3c2d36dfe5fb8d3a28b95691fb21cc20
parentefd8042919814e2f9792c5e801d8f95fa78bbc77 (diff)
downloadports-f2440db2ac6d1a099a0baae5d583f4fd8a043e0c.tar.gz
ports-f2440db2ac6d1a099a0baae5d583f4fd8a043e0c.zip
Add an option to build the milter with SPF support.
Wished by: author Feature safe: yes
Notes
Notes: svn path=/head/; revision=257512
-rw-r--r--mail/milter-callback/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/mail/milter-callback/Makefile b/mail/milter-callback/Makefile
index 892067426363..0df7fafcc473 100644
--- a/mail/milter-callback/Makefile
+++ b/mail/milter-callback/Makefile
@@ -24,6 +24,15 @@ MAN8= milter-callback.8
EXTRACT_AFTER_ARGS= | (${MKDIR} ${WRKSRC}; ${TAR} -xf - --no-same-owner \
--no-same-permissions -C ${WRKSRC})
+OPTIONS= SPF "build with SPF support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_SPF)
+MAKE_ENV+= WITH_SPF=yes
+LIB_DEPENDS+= spf2.3:${PORTSDIR}/mail/libspf2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|" \
${WRKSRC}/${PORTNAME}.c
@@ -43,4 +52,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>