aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2012-11-12 18:20:20 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2012-11-12 18:20:20 +0000
commita3e5d9c0c326e13feb99f87ce77b7885553193a0 (patch)
treed8b14112721d635744d006d7293e591a472671ac
parent74f1232305e5d9c6e51a089771724c75d5656c61 (diff)
downloadports-a3e5d9c0c326e13feb99f87ce77b7885553193a0.tar.gz
ports-a3e5d9c0c326e13feb99f87ce77b7885553193a0.zip
MFH: r307194, r307256
- Update to 1.3.1. - Tidy up dependencies, trim Makefile header, and clean up style. Approved by: portmgr (tabthorpe) Feature safe: yes
Notes
Notes: svn path=/branches/RELENG_9_1_0/; revision=307341
-rw-r--r--java/icedtea-web/Makefile69
-rw-r--r--java/icedtea-web/distinfo4
-rw-r--r--java/icedtea-web/files/patch-Makefile.in38
3 files changed, 52 insertions, 59 deletions
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index 3448dc3917f4..d57938b9cda7 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -1,13 +1,7 @@
-# New ports collection makefile for: icedtea-web
-# Date created: July 11, 2011
-# Whom: Jung-uk Kim <jkim@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= icedtea-web
-PORTVERSION= 1.3
-PORTREVISION= 1
+PORTVERSION= 1.3.1
CATEGORIES= java www
MASTER_SITES= http://icedtea.wildebeest.org/download/source/ \
http://icedtea.classpath.org/download/source/
@@ -17,22 +11,22 @@ COMMENT= A free Java plug-in and Java Web Start for OpenJDK
LICENSE= GPLv2
+BUILD_DEPENDS= ${LOCALBASE}/bin/zip:${PORTSDIR}/archivers/zip \
+ ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_JAVA= yes
JAVA_OS= native
JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6+
+USE_PKGCONFIG= yes
USE_PERL5_BUILD=yes
USE_XORG= x11
+WANT_GNOME= yes
-OPTIONS_DEFINE= PLUGIN RHINO TEST
-OPTIONS_DEFAULT=PLUGIN
-PLUGIN_DESC= Enable the browser plug-in
-RHINO_DESC= Add support for Proxy Auto Config files
-TEST_DESC= Add support for running regression test
-
-.include <bsd.port.options.mk>
+EXTRACT_AFTER_ARGS= | ${SETENV} LC_ALL=en_US.UTF-8 ${TAR} -xf -
MAN1= itweb-javaws.1
PLIST_FILES= bin/itweb-javaws bin/itweb-settings \
@@ -42,22 +36,24 @@ PLIST_FILES= bin/itweb-javaws bin/itweb-settings \
PORTDATA= about.jar about.jnlp netx.jar
PORTDOCS= netx
-BUILD_DEPENDS+= ${LOCALBASE}/bin/zip:${PORTSDIR}/archivers/zip
-RUN_DEPENDS+= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
-
-USE_PKGCONFIG= yes
-
-CONFIGURE_ARGS+=--with-ecj=no --with-jdk-home="${JAVA_HOME}"
+CONFIGURE_ARGS= --with-ecj=no --with-jdk-home="${JAVA_HOME}"
+SH= ${LOCALBASE}/bin/bash
-EXTRACT_AFTER_ARGS= | ${SETENV} LC_ALL=en_US.UTF-8 ${TAR} -xf -
+OPTIONS_DEFINE= PLUGIN RHINO TEST
+OPTIONS_DEFAULT=PLUGIN
+PLUGIN_DESC= Enable the browser plug-in
+RHINO_DESC= Add support for Proxy Auto Config files
+TEST_DESC= Add support for running regression test
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if empty(PORT_OPTIONS:MDOCS)
-CONFIGURE_ARGS+= --disable-docs
+CONFIGURE_ARGS+=--disable-docs
.endif
.if ${PORT_OPTIONS:MPLUGIN}
+USE_GECKO= libxul libxul19
+USE_GNOME= glib20 gtk20
USE_WEBPLUGINS= native
WEBPLUGINS_DIR= ${PREFIX}/lib
WEBPLUGINS_FILES=IcedTeaPlugin.so
@@ -66,10 +62,6 @@ PLIST_FILES+= lib/IcedTeaPlugin.so
PORTDATA+= plugin.jar
PORTDOCS+= plugin
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/glib-2.0.pc:${PORTSDIR}/devel/glib20 \
- ${LOCALBASE}/libdata/pkgconfig/gtk+-2.0.pc:${PORTSDIR}/x11-toolkits/gtk20 \
- ${LOCALBASE}/libdata/pkgconfig/mozilla-plugin.pc:${PORTSDIR}/www/libxul19
-
CONFIGURE_ARGS+=--with-gtk=2
.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
.else
@@ -77,25 +69,21 @@ CONFIGURE_ARGS+=--disable-plugin
.endif
.if ${PORT_OPTIONS:MRHINO}
-CONFIGURE_ARGS+=--with-rhino=${JAVASHAREDIR}/rhino/rhino.jar
BUILD_DEPENDS+= ${JAVASHAREDIR}/rhino/rhino.jar:${PORTSDIR}/lang/rhino
RUN_DEPENDS+= ${JAVASHAREDIR}/rhino/rhino.jar:${PORTSDIR}/lang/rhino
+CONFIGURE_ARGS+=--with-rhino=${JAVASHAREDIR}/rhino/rhino.jar
.else
CONFIGURE_ARGS+=--with-rhino=no
.endif
.if ${PORT_OPTIONS:MTEST}
+BUILD_DEPENDS+= ${JAVALIBDIR}/junit.jar:${PORTSDIR}/java/junit
CONFIGURE_ARGS+=--with-junit=${JAVALIBDIR}/junit.jar
-BUILD_DEPENDS+= ${JAVALIBDIR}/junit.jar:${PORTSDIR}/java/junit \
- ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
.else
CONFIGURE_ARGS+=--with-junit=no
.endif
-post-patch:
- ${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/javac.in
- ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
- ${WRKSRC}/launcher/javaws.in
+.include <bsd.port.pre.mk>
.if ${JAVA_PORT_VERSION} == "1.6.0"
pre-extract:
@@ -103,9 +91,14 @@ pre-extract:
@${ECHO_MSG} "IMPORTANT: To build IcedTea-Web ${PORTVERSION}, you have to turn on 'ICEDTEA' option"
@${ECHO_MSG} "for ${JAVA_PORT} (default). Otherwise, it will neither build nor work."
@${ECHO_MSG}
- @sleep 10
+ @sleep 5
.endif
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/javac.in
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
+ ${WRKSRC}/launcher/javaws.in
+
.if ${PORT_OPTIONS:MTEST}
post-build:
@${ECHO_MSG}
@@ -125,11 +118,9 @@ post-install:
.if ${PORT_OPTIONS:MTEST}
test: build
- @${SED} -e 's|^SHELL = /bin/sh|SHELL = ${LOCALBASE}/bin/bash|' \
- ${WRKSRC}/Makefile > ${WRKSRC}/Makefile.test
- @(cd ${WRKSRC}; ${GMAKE} -f Makefile.test check)
+ @(cd ${WRKSRC}; ${GMAKE} check)
.if ${PORT_OPTIONS:MPLUGIN}
- @(cd ${WRKSRC}; ${GMAKE} -f Makefile.test plugin-tests)
+ @(cd ${WRKSRC}; ${GMAKE} plugin-tests)
.endif
.endif
diff --git a/java/icedtea-web/distinfo b/java/icedtea-web/distinfo
index 83fcac8acfa1..656442c7431c 100644
--- a/java/icedtea-web/distinfo
+++ b/java/icedtea-web/distinfo
@@ -1,2 +1,2 @@
-SHA256 (icedtea-web-1.3.tar.gz) = d46ec10700732cea103da2aae64ff01e717cb1281b83e1797ce48cc53280b49f
-SIZE (icedtea-web-1.3.tar.gz) = 987785
+SHA256 (icedtea-web-1.3.1.tar.gz) = 20c7fd1eef6c79cbc6478bb01236a3eb2f0af6184eaed24baca59a3c37eafb56
+SIZE (icedtea-web-1.3.1.tar.gz) = 995777
diff --git a/java/icedtea-web/files/patch-Makefile.in b/java/icedtea-web/files/patch-Makefile.in
index 511d4ec16da7..dc32efb72fe2 100644
--- a/java/icedtea-web/files/patch-Makefile.in
+++ b/java/icedtea-web/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2012-08-27 15:36:58.431461000 -0400
-+++ Makefile.in 2012-09-06 17:00:58.000000000 -0400
-@@ -235,14 +235,14 @@
+--- Makefile.in.orig 2012-11-01 12:51:47.732805000 -0400
++++ Makefile.in 2012-11-07 18:38:48.000000000 -0500
+@@ -257,14 +257,14 @@
#end of exported autoconf copies
# binary names
@@ -17,7 +17,7 @@
-e 's|[@]ITWEB_SETTINGS_BIN_LOCATION[@]|$(bindir)/$(itweb_settings)|g' \
-e 's|[@]JAVA[@]|$(JAVA)|g' \
-e 's|[@]JRE[@]|$(SYSTEM_JRE_DIR)|g'
-@@ -724,8 +724,8 @@
+@@ -746,8 +746,8 @@
# Top-Level Targets
# =================
@@ -28,7 +28,7 @@
check-local: $(RHINO_TESTS) $(JUNIT_TESTS)
-@@ -745,24 +745,26 @@
+@@ -767,24 +767,26 @@
@ENABLE_PLUGIN_TRUE@ ${INSTALL_PROGRAM} $(PLUGIN_DIR)/$(BUILT_PLUGIN_LIBRARY) $(DESTDIR)$(libdir)
@ENABLE_PLUGIN_TRUE@ ${INSTALL_DATA} $(abs_top_builddir)/liveconnect/lib/classes.jar $(DESTDIR)$(datadir)/$(PACKAGE_NAME)/plugin.jar
${INSTALL_DATA} $(NETX_DIR)/lib/classes.jar $(DESTDIR)$(datadir)/$(PACKAGE_NAME)/netx.jar
@@ -60,7 +60,7 @@
@ENABLE_DOCS_TRUE@@ENABLE_PLUGIN_TRUE@ done)
uninstall-local:
-@@ -771,8 +773,8 @@
+@@ -793,8 +795,8 @@
rm -f $(DESTDIR)$(datadir)/$(PACKAGE_NAME)/netx.jar
rm -f $(DESTDIR)$(datadir)/$(PACKAGE_NAME)/about.jnlp
rm -f $(DESTDIR)$(datadir)/$(PACKAGE_NAME)/about.jar
@@ -71,16 +71,18 @@
rm -f $(DESTDIR)$(bindir)/$(itweb_settings)
rm -rf $(DESTDIR)$(htmldir)
-@@ -862,7 +864,7 @@
+@@ -884,8 +886,8 @@
netx-source-files.txt:
find $(NETX_SRCDIR) -name '*.java' | sort > $@
-@WITH_RHINO_FALSE@ sed -i '/RhinoBasedPacEvaluator/ d' $@
+-@HAVE_JAVA7_FALSE@ sed -i '/VariableX509TrustManagerJDK7/ d' $@
+@WITH_RHINO_FALSE@ sed -i -e '/RhinoBasedPacEvaluator/ d' $@
++@HAVE_JAVA7_FALSE@ sed -i -e '/VariableX509TrustManagerJDK7/ d' $@
stamps/netx.stamp: netx-source-files.txt stamps/bootstrap-directory.stamp
mkdir -p $(NETX_DIR)
-@@ -874,7 +876,8 @@
+@@ -897,7 +899,8 @@
(cd $(NETX_RESOURCE_DIR); \
for files in $$(find . -type f); \
do \
@@ -90,7 +92,7 @@
$(NETX_DIR)/net/sourceforge/jnlp/resources/$${files}; \
done)
cp -a $(NETX_SRCDIR)/net/sourceforge/jnlp/runtime/pac-funcs.js \
-@@ -902,10 +905,10 @@
+@@ -925,10 +928,10 @@
rm -f stamps/netx.stamp
clean-desktop-files:
@@ -103,7 +105,7 @@
extra-source-files.txt:
find $(abs_top_srcdir)/extra -name '*.java' | sort > $@
-@@ -917,7 +920,8 @@
+@@ -940,7 +943,8 @@
(cd $(NETX_EXTRA_DIR); \
for files in $$(find . -type f); \
do \
@@ -113,7 +115,7 @@
$(NETX_EXTRA_DIST_DIR)/$${files}; \
done)
mkdir -p stamps
-@@ -931,7 +935,7 @@
+@@ -954,7 +958,7 @@
extra-lib/about.jar: stamps/extra-class-files.stamp
$(BOOT_DIR)/bin/jar cf $@ -C extra-lib net ;
@@ -122,7 +124,7 @@
mkdir -p launcher.build
$(edit_launcher_script) < $< > $@
-@@ -940,14 +944,14 @@
+@@ -963,14 +967,14 @@
$(edit_launcher_script) < $< > $@
clean-launchers:
@@ -140,7 +142,7 @@
itweb-settings.desktop: $(srcdir)/itweb-settings.desktop.in
sed "s#PATH_TO_ITWEB_SETTINGS#$(bindir)/$(itweb_settings)#" \
-@@ -1001,7 +1005,7 @@
+@@ -1024,7 +1028,7 @@
fi
stamps/check-pac-functions.stamp: stamps/bootstrap-directory.stamp
@@ -149,7 +151,7 @@
$$(readlink -f $(abs_top_srcdir)/netx/net/sourceforge/jnlp/runtime/pac-funcs.js) ; \
mkdir -p stamps && \
touch $@
-@@ -1056,7 +1060,7 @@
+@@ -1079,7 +1082,7 @@
notSrcFiles=`find . -mindepth 1 -type f \! -name "*.java" | sed "s/.\/*//"` ; \
$(BOOT_DIR)/bin/javac -cp $(NETX_DIR)/lib/classes.jar -d "$(JNLP_TESTS_DIR)/$$dir/" $$srcFiles ; \
if [ -n "$$notSrcFiles" ] ; then \
@@ -158,7 +160,7 @@
fi ; \
cd "$(JNLP_TESTS_DIR)/$$dir/" ; \
if [ -f $(META_MANIFEST) ]; \
-@@ -1209,7 +1213,7 @@
+@@ -1232,7 +1234,7 @@
whiteListed=`cat $(REPRODUCERS_CLASS_WHITELIST)`; \
cd $(JNLP_TESTS_ENGINE_TESTS_DIR) ; \
class_names= ; \
@@ -167,7 +169,7 @@
class_name=`echo $$test | sed -e 's|\.class$$||' -e 's|^\./||'` ; \
class_name=`echo $$class_name | sed -e 's|/|.|g' ` ; \
INLCUDE="NO" ; \
-@@ -1393,7 +1397,7 @@
+@@ -1416,7 +1416,7 @@
$(UNIT_CLASS_NAMES):
cd $(NETX_UNIT_TEST_DIR) ; \
class_names= ; \
@@ -176,7 +178,7 @@
class_name=`echo $$test | sed -e 's|\.class$$||' -e 's|^\./||'` ; \
class_name=`echo $$class_name | sed -e 's|/|.|g' ` ; \
class_names="$$class_names $$class_name" ; \
-@@ -1404,10 +1408,7 @@
+@@ -1427,10 +1427,7 @@
$(TESTS_DIR)/$(REPORT_STYLES_DIRNAME) $(UNIT_CLASS_NAMES)
filename=" " ; \
cd $(NETX_UNIT_TEST_SRCDIR) ; \
@@ -188,7 +190,7 @@
cd $(NETX_UNIT_TEST_DIR) ; \
class_names=`cat $(UNIT_CLASS_NAMES)` ; \
CLASSPATH=$(NETX_DIR)/lib/classes.jar:$(JUNIT_JAR):$(JUNIT_RUNNER_JAR):$(JNLP_TESTS_ENGINE_DIR):. \
-@@ -1663,9 +1664,7 @@
+@@ -1686,9 +1683,7 @@
@ENABLE_PLUGIN_TRUE@ $(PLUGIN_TEST_SRCS) ;
@ENABLE_PLUGIN_TRUE@ $(BOOT_DIR)/bin/jar cf plugin/tests/LiveConnect/PluginTest.jar \
@ENABLE_PLUGIN_TRUE@ plugin/tests/LiveConnect/*.class ;