aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-06-06 09:21:08 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-06-06 09:21:08 +0000
commit404a096bf7c6c5b6b9dd96c89c2bcaebe5fcf38f (patch)
treeba51dd33188356d0f836cbe3d5d6cbc3d4a52453
parente239bfbcadfa2f0d2e2f579c225ec6ccc4c465b5 (diff)
downloadports-404a096bf7c6c5b6b9dd96c89c2bcaebe5fcf38f.tar.gz
ports-404a096bf7c6c5b6b9dd96c89c2bcaebe5fcf38f.zip
MFH: r356693
- Fix build on 10.x+ - Fix and sort plist - Use new LIB_DEPENDS syntax - Whitespace nits Approved by: portmgr
Notes
Notes: svn path=/branches/2014Q2/; revision=356751
-rw-r--r--x11/workrave/Makefile18
-rw-r--r--x11/workrave/files/patch-backend__include__ICore.hh10
-rw-r--r--x11/workrave/pkg-plist33
3 files changed, 36 insertions, 25 deletions
diff --git a/x11/workrave/Makefile b/x11/workrave/Makefile
index 57c64cd14e16..df81f78cbe2f 100644
--- a/x11/workrave/Makefile
+++ b/x11/workrave/Makefile
@@ -16,11 +16,11 @@ OPTIONS_DEFINE= GNOME NETWORK NLS
NETWORK_DESC= Build with network support
INSTALLS_ICONS= yes
-DESKTOP_ENTRIES= "Workrave" "RSI prevention tool" \
- "${DATADIR}/images/workrave-icon-small.png" \
- "workrave" \
- "Utility;" \
- false
+DESKTOP_ENTRIES="Workrave" "RSI prevention tool" \
+ "${DATADIR}/images/workrave-icon-small.png" \
+ "workrave" \
+ "Utility;" \
+ false
USE_XORG= x11 xmu recordproto xtst xext
USES= pathfix pkgconfig gmake
@@ -32,20 +32,20 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-gconf --disable-pulse
.include <bsd.port.options.mk>
-LIB_DEPENDS+= gdome.8:${PORTSDIR}/textproc/gdome2
+LIB_DEPENDS+= libgdome.so:${PORTSDIR}/textproc/gdome2
.if ${PORT_OPTIONS:MGNOME}
-LIB_DEPENDS+= gnomeuimm-2.6.1:${PORTSDIR}/x11-toolkits/libgnomeuimm26
+LIB_DEPENDS+= libgnomeuimm-2.6.so:${PORTSDIR}/x11-toolkits/libgnomeuimm26
USE_GNOME+= gnomepanel
PLIST_SUB+= GNOME=""
.else
-LIB_DEPENDS+= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
+LIB_DEPENDS+= libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24
CONFIGURE_ARGS+=--disable-gnome
PLIST_SUB+= GNOME="@comment "
.endif
.if ${PORT_OPTIONS:MNETWORK}
-LIB_DEPENDS+= gnet-2.0.0:${PORTSDIR}/net/gnet2
+LIB_DEPENDS+= libgnet-2.0.so:${PORTSDIR}/net/gnet2
.else
CONFIGURE_ARGS+=--disable-distribution
.endif
diff --git a/x11/workrave/files/patch-backend__include__ICore.hh b/x11/workrave/files/patch-backend__include__ICore.hh
new file mode 100644
index 000000000000..554e87c4b117
--- /dev/null
+++ b/x11/workrave/files/patch-backend__include__ICore.hh
@@ -0,0 +1,10 @@
+--- backend/include/ICore.hh.orig 2010-12-05 21:01:31.000000000 +0300
++++ backend/include/ICore.hh 2014-05-17 03:18:53.674936521 +0400
+@@ -21,6 +21,7 @@
+ #define ICORE_HH
+
+ #include <string>
++#include <ctime>
+
+ namespace workrave {
+
diff --git a/x11/workrave/pkg-plist b/x11/workrave/pkg-plist
index a4c57f6b3414..27022384b960 100644
--- a/x11/workrave/pkg-plist
+++ b/x11/workrave/pkg-plist
@@ -1,25 +1,15 @@
bin/workrave
-%%GNOME%%libdata/bonobo/servers/Workrave-Applet.server
-%%GNOME%%libdata/bonobo/servers/Workrave-Control.server
+%%GNOME%%etc/sound/events/workrave.soundlist
%%GNOME%%libexec/workrave-applet
-%%GNOME%%share/gnome-2.0/ui/GNOME_WorkraveApplet.xml
share/dbus-1/services/org.workrave.Workrave.service
+%%GNOME%%share/dbus-1/services/org.workrave.WorkraveAppletFactory.service
+%%GNOME%%share/gnome-panel/applets/org.workrave.WorkraveApplet.panel-applet
+%%GNOME%%share/gnome-panel/ui/workrave-applet-menu.xml
+share/icons/hicolor/48x48/apps/workrave-icon-huge.png
+share/icons/hicolor/scalable/apps/workrave-sheep.svg
share/locale/ga/LC_MESSAGES/workrave.mo
share/locale/ko/LC_MESSAGES/workrave.mo
share/locale/te/LC_MESSAGES/workrave.mo
-share/icons/hicolor/48x48/apps/workrave-icon-huge.png
-share/icons/hicolor/scalable/apps/workrave-sheep.svg
-share/sounds/workrave/subtle/break-ignored.wav
-share/sounds/workrave/subtle/break-prelude.wav
-share/sounds/workrave/subtle/daily-limit.wav
-share/sounds/workrave/subtle/exercise-ended.wav
-share/sounds/workrave/subtle/exercise-step.wav
-share/sounds/workrave/subtle/exercises-ended.wav
-share/sounds/workrave/subtle/micro-break-ended.wav
-share/sounds/workrave/subtle/micro-break-started.wav
-share/sounds/workrave/subtle/rest-break-ended.wav
-share/sounds/workrave/subtle/rest-break-started.wav
-share/sounds/workrave/subtle/soundtheme
share/sounds/workrave/default/break-ignored.wav
share/sounds/workrave/default/break-prelude.wav
share/sounds/workrave/default/daily-limit.wav
@@ -31,6 +21,17 @@ share/sounds/workrave/default/micro-break-started.wav
share/sounds/workrave/default/rest-break-ended.wav
share/sounds/workrave/default/rest-break-started.wav
share/sounds/workrave/default/soundtheme
+share/sounds/workrave/subtle/break-ignored.wav
+share/sounds/workrave/subtle/break-prelude.wav
+share/sounds/workrave/subtle/daily-limit.wav
+share/sounds/workrave/subtle/exercise-ended.wav
+share/sounds/workrave/subtle/exercise-step.wav
+share/sounds/workrave/subtle/exercises-ended.wav
+share/sounds/workrave/subtle/micro-break-ended.wav
+share/sounds/workrave/subtle/micro-break-started.wav
+share/sounds/workrave/subtle/rest-break-ended.wav
+share/sounds/workrave/subtle/rest-break-started.wav
+share/sounds/workrave/subtle/soundtheme
share/workrave/images/workrave.xpm
%%DATADIR%%/exercises/backward-shoulder-stretch.png
%%DATADIR%%/exercises/chair-pushup-1.png