aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-12-23 10:58:42 +0000
committerWill Andrews <will@FreeBSD.org>2001-12-23 10:58:42 +0000
commit5c4150e92b9d06afb2d6216d85d783369553e7fb (patch)
tree74fecfaef3049ba52c6d4cbdadbae634a5b41692 /Makefile
parent5302aeeaa55fc39ed216f6dd77ffe021a60d8090 (diff)
downloadports-5c4150e92b9d06afb2d6216d85d783369553e7fb.tar.gz
ports-5c4150e92b9d06afb2d6216d85d783369553e7fb.zip
Don't use cat(1) needlessly -- pipe the INDEX to awk(1).
PR: 30099 Submitted by: schweikh
Notes
Notes: svn path=/head/; revision=52042
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 189ad662ba48..1d59b909da23 100644
--- a/Makefile
+++ b/Makefile
@@ -84,7 +84,7 @@ parallel: ${.CURDIR}/INDEX
.for dir in ${SUBDIR}
@echo "all: ${dir}-all"
.endfor
- @cat ${.CURDIR}/INDEX | awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; split(here, tmp, "/"); if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print tmp[4] "-all: " me ".tgz"; print me ": " me ".tgz"; print me ".tgz: " bdep " " rdep; printf("\t@/var/portbuild/scripts/pdispatch ${branch} /var/portbuild/scripts/portbuild %s.tgz %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}'
+ @awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; split(here, tmp, "/"); if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print tmp[4] "-all: " me ".tgz"; print me ": " me ".tgz"; print me ".tgz: " bdep " " rdep; printf("\t@/var/portbuild/scripts/pdispatch ${branch} /var/portbuild/scripts/portbuild %s.tgz %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}' < ${.CURDIR}/INDEX
CVS?= cvs
.if defined(SUPHOST)