aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1997-03-10 22:59:36 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1997-03-10 22:59:36 +0000
commit3cb42d62d420774d06be81733566d60321caea04 (patch)
treee2ac46b2f93bfd508396fd29b9944baa95ab633c /Makefile
parent8468c52a0a73cc8b95eebb4c4f48f30f79b98cad (diff)
downloadports-3cb42d62d420774d06be81733566d60321caea04.tar.gz
ports-3cb42d62d420774d06be81733566d60321caea04.zip
Add a search target.
Notes
Notes: svn path=/head/; revision=5933
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f660842b8f97..7dafbea082c7 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-# $Id: Makefile,v 1.28 1996/12/05 11:09:04 asami Exp $
+# $Id: Makefile,v 1.29 1997/03/06 05:52:26 asami Exp $
#
SUBDIR += archivers
@@ -48,3 +48,11 @@ ${.CURDIR}/INDEX:
print-index: ${.CURDIR}/INDEX
@awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }' < ${.CURDIR}/INDEX
+
+search: ${.CURDIR}/INDEX
+.if !defined(key)
+ @echo "The search target requires a keyword parameter,"
+ @echo "e.g.: \"make search key=somekeyword\""
+.else
+ @grep ${key} ${.CURDIR}/INDEX | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'
+.endif