aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2000-10-31 21:00:02 +0000
committerJames E. Housley <jeh@FreeBSD.org>2000-10-31 21:00:02 +0000
commit66067235bb82136c72193cb01819e901bee3dd83 (patch)
tree5b9d95e515f9acc8c20feee9d0cbe77802524cd6 /Makefile
parent12050036281f09397b4a2a73d127486d6462bbf4 (diff)
downloadports-66067235bb82136c72193cb01819e901bee3dd83.tar.gz
ports-66067235bb82136c72193cb01819e901bee3dd83.zip
Allow both SUP_UPDATE and CVS_UPDATE to be used, similar to src/Makefile
PR: 17903 Submitted by: James Housley <jim@thehousleys.net> Reviewed by: billf
Notes
Notes: svn path=/head/; revision=34512
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index e48790981277..1bba492159bf 100644
--- a/Makefile
+++ b/Makefile
@@ -88,11 +88,7 @@ CVS?= cvs
SUPFLAGS+= -h ${SUPHOST}
.endif
update:
-.if defined(SUP_UPDATE)
-.if !defined(PORTSSUPFILE)
- @${ECHO_MSG} "Error: Please define PORTSSUPFILE before doing make update."
- @exit 1
-.endif
+.if defined(SUP_UPDATE) && defined(PORTSSUPFILE)
@echo "--------------------------------------------------------------"
@echo ">>> Running ${SUP}"
@echo "--------------------------------------------------------------"
@@ -102,6 +98,9 @@ update:
@echo ">>> Updating ${.CURDIR} from cvs repository" ${CVSROOT}
@echo "--------------------------------------------------------------"
cd ${.CURDIR}; ${CVS} -q update -P -d
+.elif defined(SUP_UPDATE) && !defined(PORTSSUPFILE)
+ @${ECHO_MSG} "Error: Please define PORTSSUPFILE before doing make update."
+ @exit 1
.else
@${ECHO_MSG} "Error: Please define either SUP_UPDATE or CVS_UPDATE first."
.endif