aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-02-24 03:54:41 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-02-24 03:54:41 +0000
commitf26c3131fea103b313c5c35fffab1df7ecdec12c (patch)
tree7440fac5df228256ae54ecd222fd001d6c830a8f /Makefile
parente53dff475ff3ad2cb284c8c251de9b322499a57f (diff)
downloadports-f26c3131fea103b313c5c35fffab1df7ecdec12c.tar.gz
ports-f26c3131fea103b313c5c35fffab1df7ecdec12c.zip
Correct the bug in 'make index' that failed to substitute back the
canonical PREFIX locations for /nonexistent*
Notes
Notes: svn path=/head/; revision=76348
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index de7fbc773c21..f3eedd920a20 100644
--- a/Makefile
+++ b/Makefile
@@ -70,7 +70,7 @@ ${.CURDIR}/${INDEXFILE}:
export X11BASE=/nonexistentx; \
cd ${.CURDIR} && make describe ECHO_MSG="echo > /dev/null" | \
perl ${.CURDIR}/Tools/make_index | \
- sed -e 's/ */ /g' -e 's/| */|/g' -e 's/ *|/|/g' -e "s,${LOCALBASE},/usr/local," -e "s,${X11BASE},/usr/X11R6," > ${INDEXFILE}
+ sed -e 's/ */ /g' -e 's/| */|/g' -e 's/ *|/|/g' -e "s,$${LOCALBASE},/usr/local," -e "s,$${X11BASE},/usr/X11R6," > ${INDEXFILE}
.if !defined(INDEX_NOSORT)
@sed -e 's./..g' ${.CURDIR}/${INDEXFILE} | \
sort -t '|' +1 -2 | \