diff options
author | Kris Kennaway <kris@FreeBSD.org> | 2004-06-10 07:30:19 +0000 |
---|---|---|
committer | Kris Kennaway <kris@FreeBSD.org> | 2004-06-10 07:30:19 +0000 |
commit | 22cbe54b9abcdbf749c3480a40f5a21daa03a05d (patch) | |
tree | 8490ea6b208576582001969c79ba9e7700d59889 /Makefile | |
parent | 9abd9a00856e4204e2d017467bba88f712806d6c (diff) | |
download | ports-22cbe54b9abcdbf749c3480a40f5a21daa03a05d.tar.gz ports-22cbe54b9abcdbf749c3480a40f5a21daa03a05d.zip |
* Support verbose index builds with INDEX_VERBOSE [1]
* Don't assume root is using /bin/sh when switching credentials to
configure OPTIONS. [2]
* Support glob expressions in USE_GETTEXT to allow more flexibility
in the face of future gratuitous library version bumps by the gettext
developers [3]:
USE_GETTEXT=yEs # Works as before (case-insensitive)
USE_GETTEXT=[5-7] # Accepts any of those libintl.so.x versions
# in the LIB_DEPENDS
* Correctly register dependencies when a non-system perl port is used
on 4.x [4]
* Extend 'make search' support to allow much more flexible searching.
Syntax will be documented in CHANGES for brevity. [5]
* Reorder the post-install-script target to before add-plist-info for
consistency [6]
* Various fixes to support port operations when a port directory
exists under /usr/obj [7]
* Extend USE_PERL5_BUILD and USE_PERL5 to add EXTRACT and PATCH
dependencies since many ports require perl in those stages [8]
* Move info file deregistration later in the deinstallation process so
it works properly. [9]
* Improve wording in EXPIRATION_DATE message. [10]
* Fix dependencies for XFREE86_VERSION==3 (obtain imake from
x11/XFree86 now that the former port is gone) [11]
* While building index, treat non-existent dependencies as fatal.
Previously the error was being hidden by the stderr redirection. [12]
* Don't always retry BROKEN ports when package building (it is taking
too much time to continually rebuild ports that are usually going to
really be broken). Set TRYBROKEN if you want to attempt a build of
a BROKEN port. [12]
* Revert incorrect change from 1.487 relating to ALL-DEPENDS-LIST [13]
PR: 24214 [1], 67529 [2], 63937 [3], 65554 [4], 40699 [5],
59162 [6], 63372 66567 [7], 63394 [8], 65304 [9],
65931 [10], 66565 [11], 66743 [13]
Submitted by: roam [1], will [1], hrs [2], mi [3], ade [4],
Roman Neuhauser <roman@bellavista.cz> [5],
Sergey Matveychuk <sem@ciam.ru> [6], gad [7],
adamw [8], kris [8][12], dinoex [9],
Alexey Dokuchaev <danfe@regency.nsu.ru> [10],
eik [11][13]
Notes
Notes:
svn path=/head/; revision=111198
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 12 |
1 files changed, 10 insertions, 2 deletions
@@ -75,8 +75,16 @@ fetchindex: INDEX_JOBS?= 2 +.if !defined(INDEX_VERBOSE) +INDEX_ECHO_MSG= echo > /dev/null +INDEX_ECHO_1ST= echo -n +.else +INDEX_ECHO_MSG= echo 1>&2 +INDEX_ECHO_1ST= echo +.endif + ${.CURDIR}/${INDEXFILE}: - @echo -n "Generating ${INDEXFILE} - please wait.."; \ + @${INDEX_ECHO_1ST} "Generating ${INDEXFILE} - please wait.."; \ if [ "${INDEX_PRISTINE}" != "" ]; then \ export LOCALBASE=/nonexistentlocal; \ export X11BASE=/nonexistentx; \ @@ -84,7 +92,7 @@ ${.CURDIR}/${INDEXFILE}: tmpdir=`/usr/bin/mktemp -d -t index` || exit 1; \ trap "rm -rf $${tmpdir}; exit 1" 1 2 3 5 10 13 15; \ ( cd ${.CURDIR} && make -j${INDEX_JOBS} INDEX_TMPDIR=$${tmpdir} BUILDING_INDEX=1 \ - ECHO_MSG="echo > /dev/null" describe ) || \ + ECHO_MSG="${INDEX_ECHO_MSG}" describe ) || \ (rm -rf $${tmpdir} ; \ if [ "${INDEX_QUIET}" = "" ]; then \ echo; \ |