diff options
author | Satoshi Asami <asami@FreeBSD.org> | 1999-07-23 09:36:55 +0000 |
---|---|---|
committer | Satoshi Asami <asami@FreeBSD.org> | 1999-07-23 09:36:55 +0000 |
commit | a163079f0d26f857c023dc7f21ed9acaeeb8590c (patch) | |
tree | 76e97537a2030bd95501b69d988c7beee0db6f72 /Makefile | |
parent | cd7e9ffb8c14a1b7981b7087c7317d6978df808a (diff) | |
download | ports-a163079f0d26f857c023dc7f21ed9acaeeb8590c.tar.gz ports-a163079f0d26f857c023dc7f21ed9acaeeb8590c.zip |
Makefile:
(1) Sort INDEX lines since with the new parallel patch, the lines can
come in out of order. (see 2)
Mk/bsd.port.subdir.mk:
(2) Make the targets parallelizable.
Submitted by: hoek
Reviewed by: steve, among others
Mk/bsd.port.mk:
(3) Serious speedup of bsd.port.mk startup. In particular, this helps
cut down "make index" time from an hour and a half to 8 minutes on
our system with a parallel make describe (see 2). Try to pass
unchanged variables down from parent makes instead of rerunning
commands to define them, etc.
Submitted by: hoek
Reviewed by: steve, among others
(4) Change a bunch of "FreeBSD.ORG"s and "freebsd.org"s to "FreeBSD.org".
(5) XFree86 is now at version 3.3.4.
(6) Update for gnome master sites.
Submitted by: mharo
(7) Remove old system tcl check, I don't think people with systems
from way back are still submitting ports.
(8) Fix comment on "make describe" line description (www site was missing).
Notes
Notes:
svn path=/head/; revision=20327
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 8 |
1 files changed, 7 insertions, 1 deletions
@@ -1,4 +1,4 @@ -# $Id: Makefile,v 1.48 1999/06/04 17:30:31 billf Exp $ +# $Id: Makefile,v 1.49 1999/06/26 22:29:57 asami Exp $ # SUBDIR += archivers @@ -58,6 +58,12 @@ ${.CURDIR}/INDEX: @echo -n "Generating INDEX - please wait.." @make describe ECHO_MSG="echo > /dev/null" | \ perl ${.CURDIR}/Tools/make_index > ${.CURDIR}/INDEX +.if !defined(INDEX_NOSORT) + @sed -e 's./..g' ${.CURDIR}/INDEX | \ + sort -t '|' +1 -2 | \ + sed -e 's../.g' > ${.CURDIR}/INDEX.tmp + @mv -f ${.CURDIR}/INDEX.tmp ${.CURDIR}/INDEX +.endif @echo " Done." print-index: ${.CURDIR}/INDEX |