aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-09-27 02:08:53 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-09-27 02:08:53 +0000
commitb320b1f626dcedf33be5666976ebeccd24d34517 (patch)
tree1ecae006e002dd5640a7a79202e2d6a49608e3a2 /Makefile
parentb139324d137f82c5f9406096be4f395213fa3485 (diff)
downloadports-b320b1f626dcedf33be5666976ebeccd24d34517.tar.gz
ports-b320b1f626dcedf33be5666976ebeccd24d34517.zip
For "make parallel", provide out an extra target without the ".tgz".
(Makes it easier to cut and paste, so you can do something like "make gnome-1.2".) Also change /a/asami/portbuild -> /var/portbuild.
Notes
Notes: svn path=/head/; revision=33174
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 9a9e763ae36f..e48790981277 100644
--- a/Makefile
+++ b/Makefile
@@ -81,7 +81,7 @@ parallel: ${.CURDIR}/INDEX
.for dir in ${SUBDIR}
@echo "all:: ${dir}-all"
.endfor
- @sed -e 's/|/.tgz|/' ${.CURDIR}/INDEX | awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; split(here, tmp, "/"); if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print tmp[4] "-all:: " me; print me ": " bdep " " rdep; printf("\t@/a/asami/portbuild/scripts/pdispatch ${branch} /a/asami/portbuild/scripts/portbuild %s %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}'
+ @cat ${.CURDIR}/INDEX | awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; split(here, tmp, "/"); if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print tmp[4] "-all:: " me ".tgz"; print me ": " me ".tgz"; print me ".tgz: " bdep " " rdep; printf("\t@/var/portbuild/scripts/pdispatch ${branch} /var/portbuild/scripts/portbuild %s.tgz %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}'
CVS?= cvs
.if defined(SUPHOST)