aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJosef Karthauser <joe@FreeBSD.org>2000-03-22 20:36:55 +0000
committerJosef Karthauser <joe@FreeBSD.org>2000-03-22 20:36:55 +0000
commit97315fc9f27b54289717939b9dcf99d9cc20b552 (patch)
treef325ba0d5bcb949d389591f60356601441c4f806 /Makefile
parent831aee2711c4186bf0cadcfdaea0af662063faff (diff)
downloadports-97315fc9f27b54289717939b9dcf99d9cc20b552.tar.gz
ports-97315fc9f27b54289717939b9dcf99d9cc20b552.zip
Additions to the 'make search' mechanism.
* You can now 'make search' from a ports subdirectory. This will will restrict the search to ports within this subdirectory. * Added an additional search option to search just the port names, e.g. 'make search name=foo' will only return ports that have 'foo' in their name. Approved by: asami
Notes
Notes: svn path=/head/; revision=26963
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 0 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 9a151e0c6063..574860414da0 100644
--- a/Makefile
+++ b/Makefile
@@ -70,14 +70,6 @@ ${.CURDIR}/INDEX:
print-index: ${.CURDIR}/INDEX
@awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }' < ${.CURDIR}/INDEX
-search: ${.CURDIR}/INDEX
-.if !defined(key)
- @echo "The search target requires a keyword parameter,"
- @echo "e.g.: \"make search key=somekeyword\""
-.else
- @grep -i "${key}" ${.CURDIR}/INDEX | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'
-.endif
-
parallel: ${.CURDIR}/INDEX
.for dir in ${SUBDIR}
@echo "all:: ${dir}-all"