aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1999-06-01 02:55:43 +0000
committerBill Fumerola <billf@FreeBSD.org>1999-06-01 02:55:43 +0000
commit261e0c06583352533f49756e5f336789b8cade7f (patch)
treef330567fc518046013db033b003ffc6808363d2f /Makefile
parenta126c81cf37743f99bd5a44cb416b7fc14773ea6 (diff)
downloadports-261e0c06583352533f49756e5f336789b8cade7f.tar.gz
ports-261e0c06583352533f49756e5f336789b8cade7f.zip
'make update' in the ports directory.
Notes
Notes: svn path=/head/; revision=19156
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 05e5cc5dc4af..74363b39189d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
-# $Id: Makefile,v 1.45 1999/01/22 10:32:32 asami Exp $
+# $Id: Makefile,v 1.46 1999/01/26 03:58:55 asami Exp $
#
SUBDIR += archivers
@@ -73,3 +73,19 @@ parallel: ${.CURDIR}/INDEX
@echo "all:: ${dir}-all"
.endfor
@sed -e 's/|/.tgz|/' ${.CURDIR}/INDEX | awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; split(here, tmp, "/"); if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print tmp[4] "-all:: " me; print me ": " bdep " " rdep; printf("\t@/a/asami/portbuild/scripts/pdispatch /a/asami/portbuild/scripts/portbuild %s %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}'
+
+update:
+.if defined(SUP_UPDATE)
+ @echo "--------------------------------------------------------------"
+ @echo ">>> Running ${SUP}"
+ @echo "--------------------------------------------------------------"
+.if defined(PORTSSUPFILE)
+ @${SUP} ${SUPFLAGS} ${PORTSSUPFILE}
+.endif
+.endif
+.if defined(CVS_UPDATE)
+ @echo "--------------------------------------------------------------"
+ @echo ">>> Updating /usr/src from cvs repository" ${CVSROOT}
+ @echo "--------------------------------------------------------------"
+ cd ${.CURDIR}; cvs -q update -P -d
+.endif