aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorJosef Karthauser <joe@FreeBSD.org>2000-08-13 12:38:41 +0000
committerJosef Karthauser <joe@FreeBSD.org>2000-08-13 12:38:41 +0000
commit18853d9756b986c4e681a4e8891cca66c68d00f2 (patch)
treef0900a91ea83d985767896e0c83d8ca59cfa20df /Makefile
parente3fa0b1c960e7fd1ff5ff8637fab5297003a914e (diff)
downloadports-18853d9756b986c4e681a4e8891cca66c68d00f2.tar.gz
ports-18853d9756b986c4e681a4e8891cca66c68d00f2.zip
Use the SUPHOST in the 'make update' if it's defined.
Notes
Notes: svn path=/head/; revision=31606
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 08a22ed77f45..2d66859aa9ae 100644
--- a/Makefile
+++ b/Makefile
@@ -83,6 +83,9 @@ parallel: ${.CURDIR}/INDEX
@sed -e 's/|/.tgz|/' ${.CURDIR}/INDEX | awk -F '|' '{me=$$1; here=$$2; bdep=$$8; rdep=$$9; split(here, tmp, "/"); if (bdep != "") { gsub("$$", ".tgz", bdep); gsub(" ", ".tgz ", bdep); } if (rdep != "") { gsub("$$", ".tgz", rdep); gsub(" ", ".tgz ", rdep); } print tmp[4] "-all:: " me; print me ": " bdep " " rdep; printf("\t@/a/asami/portbuild/scripts/pdispatch ${branch} /a/asami/portbuild/scripts/portbuild %s %s", me, here); if (bdep != "") printf(" %s", bdep); if (rdep != "") printf(" %s", rdep); printf("\n")}'
CVS?= cvs
+.if defined(SUPHOST)
+SUPFLAGS+= -h ${SUPHOST}
+.endif
update:
.if defined(SUP_UPDATE)
.if !defined(PORTSSUPFILE)