aboutsummaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-11-15 21:05:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-11-15 21:05:18 +0000
commit9d8843348db510843e56a713dcb05119f012b149 (patch)
tree31c0cda56d4adf57a9552f43069f4ebf4039a3e6 /Makefile
parentf758ddcecd2ae8d15ed6303c2c0274aa8ef13d44 (diff)
downloadports-9d8843348db510843e56a713dcb05119f012b149.tar.gz
ports-9d8843348db510843e56a713dcb05119f012b149.zip
- In fetchindex target:
Fetch bzip2 compressed copy of INDEX and decompress locally. This should cut down both time and bandwidth. Approved by: kris (portmgr hat)
Notes
Notes: svn path=/head/; revision=121702
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index b9ac02bcc7ea..534b99a04731 100644
--- a/Makefile
+++ b/Makefile
@@ -71,7 +71,7 @@ index:
@cd ${.CURDIR} && make ${.CURDIR}/${INDEXFILE}
fetchindex:
- @cd ${.CURDIR} && fetch -am http://www.FreeBSD.org/ports/${INDEXFILE} && chmod a+r ${INDEXFILE}
+ @cd ${.CURDIR} && fetch -am http://www.FreeBSD.org/ports/${INDEXFILE}.bz2 && bunzip2 -f ${INDEXFILE}.bz2 && chmod a+r ${INDEXFILE}
INDEX_JOBS?= 2