aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses/lha.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-12 09:17:06 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-12 09:17:06 +0000
commitd17874dc5dcb4c3b59645d6bc71480b475762237 (patch)
treed6e76f5325a21119fdbe2459737f9f41582d71e1 /Mk/Uses/lha.mk
parentf699107c2b7c0c7a0fe28c441be7b811b1e92503 (diff)
downloadports-d17874dc5dcb4c3b59645d6bc71480b475762237.tar.gz
ports-d17874dc5dcb4c3b59645d6bc71480b475762237.zip
Two new USES added to finish handling distfiles formats a consistent way:
USES=tar[:[xz|bzip2|Z|tgz]] handles distributions files in format: - plain tar - tar.xz - tar.bz2 - tar.Z - tgz USES=lha handles distributions files info LHA format
Notes
Notes: svn path=/head/; revision=347964
Diffstat (limited to 'Mk/Uses/lha.mk')
-rw-r--r--Mk/Uses/lha.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/Mk/Uses/lha.mk b/Mk/Uses/lha.mk
new file mode 100644
index 000000000000..452896f754d8
--- /dev/null
+++ b/Mk/Uses/lha.mk
@@ -0,0 +1,22 @@
+# $FreeBSD$
+#
+# handle lha archives
+#
+# Feature: lha
+# Usage: USES=lha
+#
+.if !defined(_INCLUDE_USES_LHA_Mk)
+_INCLUDE_USES_LHA_MK= yes
+
+EXTRACT_SUFX?= .lzh
+
+.if defined(lha_ARGS)
+IGNORE= Incorrect 'USES+=lha:${lha_ARGS}' expecting 'USES+=lha'
+.endif
+
+EXTRACT_DEPENDS+= lha:${PORTSDIR}/archivers/lha
+EXTRACT_CMD?= ${LHA_CMD}
+EXTRACT_BEFORE_ARGS?= xfpw=${WRKDIR}
+EXTRACT_AFTER_ARGS?=
+
+.endif