aboutsummaryrefslogtreecommitdiff
path: root/Mk/Uses
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-30 11:41:44 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-30 11:41:44 +0000
commit0fb68fa55f5b6b885ac7dd4738fedfa3e61d3c92 (patch)
treef11b770da4e864b184551e61a6d0ea0744762817 /Mk/Uses
parente2328653a6a84c5c8b93558bb03b309f2b80388c (diff)
downloadports-0fb68fa55f5b6b885ac7dd4738fedfa3e61d3c92.tar.gz
ports-0fb68fa55f5b6b885ac7dd4738fedfa3e61d3c92.zip
Add a new USES ada.mk to establish Ada-capable compiler as a build dependency
and set the build environement properly Submitted by: John Marino <draco@marino.st>
Notes
Notes: svn path=/head/; revision=316916
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/ada.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/Mk/Uses/ada.mk b/Mk/Uses/ada.mk
new file mode 100644
index 000000000000..6f133eb79378
--- /dev/null
+++ b/Mk/Uses/ada.mk
@@ -0,0 +1,27 @@
+# $FreeBSD$
+#
+# Establish Ada-capable compiler as a build dependency
+#
+# MAINTAINER: draco@marino.st
+#
+# Feature: ada
+# Usage: USES=ada
+# Valid ARGS: does not require args
+
+.if !defined(_INCLUDE_USES_ADA_MK)
+_INCLUDE_USES_ADA_MK= yes
+
+.if defined(ada_ARGS)
+IGNORE= USES=ada does not require args
+.endif
+
+CC= ada
+BUILD_DEPENDS+= ${LOCALBASE}/gcc-aux/bin/ada:${PORTSDIR}/lang/gcc-aux
+
+MAKE_ENV+= PATH=${LOCALBASE}/gcc-aux/bin:${PATH}
+MAKE_ENV+= ADA_PROJECT_PATH=${LOCALBASE}/lib/gnat
+
+CONFIGURE_ENV+= PATH=${LOCALBASE}/gcc-aux/bin:${PATH}
+CONFIGURE_ENV+= ADA_PROJECT_PATH=${LOCALBASE}/lib/gnat
+
+.endif