aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.database.mk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-10-07 10:22:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-10-07 10:22:24 +0000
commit3ea8108fd307a3e8e40d1b15a20e7730730c16b3 (patch)
tree253bbb79604f8e44e1817a8d11aae382529652b9 /Mk/bsd.database.mk
parent600c6a6eca18f41c9da5471a1447639aa2d5dd68 (diff)
downloadports-3ea8108fd307a3e8e40d1b15a20e7730730c16b3.tar.gz
ports-3ea8108fd307a3e8e40d1b15a20e7730730c16b3.zip
- The whitespace police is back in town!
PR: ports/104013 Submitted by: Edwin Groothuis <edwin(at)mavetju.org> Sponsored by: FreeBSD Bug-a-thon #1
Notes
Notes: svn path=/head/; revision=174732
Diffstat (limited to 'Mk/bsd.database.mk')
-rw-r--r--Mk/bsd.database.mk51
1 files changed, 28 insertions, 23 deletions
diff --git a/Mk/bsd.database.mk b/Mk/bsd.database.mk
index 392d4b9b4846..e0b437bc168b 100644
--- a/Mk/bsd.database.mk
+++ b/Mk/bsd.database.mk
@@ -51,33 +51,38 @@ Database_Include_MAINTAINER= ports@FreeBSD.org
# - Detected PostgreSQL version.
##
# USE_BDB - Add Berkeley DB library dependency.
-# If no version is given (by the maintainer via the port or
-# by the user via defined variable), try to find the
-# currently installed version. Fall back to default if
-# necessary (db41+).
-# INVALID_BDB_VER - This variable can be defined when the port doesn't
-# support one or more versions of Berkeley DB.
-# WANT_BDB_VER - Maintainer can set a version of Berkeley DB to always
-# build this port with (overrides WITH_BDB_VER).
-# WITH_BDB_VER - User defined global variable to set Berkeley DB version
-# <UNIQUENAME>_WITH_BDB_VER - User defined port specific variable to set
-# Berkeley DB version
-# WITH_BDB_HIGHEST - Use the highest installed version of Berkeley DB
-# BDB_LIB_NAME - This variable is automatically set to the name of the
-# Berkeley DB library (default: db41)
-# BDB_LIB_CXX_NAME - This variable is automatically set to the name of the
-# Berkeley DB c++ library (default: db41_cxx)
-# BDB_INCLUDE_DIR - This variable is automatically set to the location of
-# the Berkeley DB include directory.
-# (default: ${LOCALBASE}/include/db41)
-# BDB_LIB_DIR - This variable is automatically set to the location of
-# the Berkeley DB library directory.
+# If no version is given (by the maintainer via the port or
+# by the user via defined variable), try to find the
+# currently installed version. Fall back to default if
+# necessary (db41+).
+# INVALID_BDB_VER
+# - This variable can be defined when the port doesn't
+# support one or more versions of Berkeley DB.
+# WANT_BDB_VER - Maintainer can set a version of Berkeley DB to always
+# build this port with (overrides WITH_BDB_VER).
+# WITH_BDB_VER - User defined global variable to set Berkeley DB version
+# <UNIQUENAME>_WITH_BDB_VER
+# - User defined port specific variable to set
+# Berkeley DB version
+# WITH_BDB_HIGHEST
+# - Use the highest installed version of Berkeley DB
+# BDB_LIB_NAME - This variable is automatically set to the name of the
+# Berkeley DB library (default: db41)
+# BDB_LIB_CXX_NAME
+# - This variable is automatically set to the name of the
+# Berkeley DB c++ library (default: db41_cxx)
+# BDB_INCLUDE_DIR
+# - This variable is automatically set to the location of
+# the Berkeley DB include directory.
+# (default: ${LOCALBASE}/include/db41)
+# BDB_LIB_DIR - This variable is automatically set to the location of
+# the Berkeley DB library directory.
# BDB_VER - Detected Berkeley DB version.
##
# USE_SQLITE - Add dependency on sqlite library. Valid values are:
# 3 and 2. If version is not specified directly then
# sqlite3 is used (if USE_SQLITE= yes).
-# SQLITE_VER - Detected sqlite version.
+# SQLITE_VER - Detected sqlite version.
##
# USE_FIREBIRD - Add dependency on Firebird library. Valid values are:
# 2 and 1. If no version is given by the maintainer (if
@@ -85,7 +90,7 @@ Database_Include_MAINTAINER= ports@FreeBSD.org
# WITH_FIREBIRD_VER variable, fall back to default "2".
# WITH_FIREBIRD_VER
# - User defined variable to set Firebird version.
-# FIREBIRD_VER - Detected Firebird version.
+# FIREBIRD_VER - Detected Firebird version.
.if defined(USE_MYSQL)
DEFAULT_MYSQL_VER?= 50