aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-02-07 11:17:50 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-02-07 11:17:50 +0000
commit1c8dc16ebeeccddc2d8286cfbd294b5991861411 (patch)
tree467f9d3f0764e6de38445cebb714f5ae04b9bd80 /Mk/bsd.gcc.mk
parenta74cb3b9f72cda444a645c2494bd67b8700d6475 (diff)
downloadports-1c8dc16ebeeccddc2d8286cfbd294b5991861411.tar.gz
ports-1c8dc16ebeeccddc2d8286cfbd294b5991861411.zip
* Change bento to pointyhat names in comments. [1]
* Document DISABLE_VULNERABILITIES variable. [2] * Add WWW: line for 'search' target. [3] * Speedup check-vulnerable invokation, if portaudit is installed. [4] * Run install-info for all .info files. [5] * Run add-plist-docs more strictly and prevent some situations with leftover files in the future. [6] * Introduce two new variables: MASTER_PORT and SLAVE_PORT. The results from these variables is only used as information for users. [7] * Honour OPTIONS if PACKAGE_BUILDING or BATCH are defined. [8] * Move all USE_GCC entries to new file - bsd.gcc.mk. 'test-gcc' target allows users to check gcc version if USE_GCC is used. Give maintainers opportunity to add '+' character to USE_GCC version for using specified and higher versions. [9] * Install startup scripts with the help of USE_RC_SUBR variable. [10] * Add three new targets: config-recursive, rmconfig-recursive and config-conditional. You can set or delete OPTIONS for all dependencies before every build. config-conditional target is used to skip configuring ports which have already been configured. [11] * Fix using of WANT_PGSQL_VER variable if postgresql is already installed. [12] PR: ports/75768 [1], ports/75728 [2], ports/76187 [3], ports/76191 [4], ports/76182 [5], ports/75379 [6], ports/75286 [7], ports/75727 [8], ports/76489 [9], ports/73691 ports/69217 [10], ports/76254 [11], ports/76988 [12] Submitted by: dinoex [1], edwin [2] [5] [6] [8] [9] [10], Marcus Grando <marcus@corp.grupos.com.br> [3], tobez and Valentin Nechayev <netch@netch.kiev.ua> [4], linimon [7], Florent Thoumie <flz@xbsd.org> [10], Chris Dillon <cdillon@wolves.k12.mo.us> [11], girgen [12]
Notes
Notes: svn path=/head/; revision=128219
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk156
1 files changed, 156 insertions, 0 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
new file mode 100644
index 000000000000..a623c2e48b72
--- /dev/null
+++ b/Mk/bsd.gcc.mk
@@ -0,0 +1,156 @@
+#-*- mode: Fundamental; tab-width: 4; -*-
+# ex:ts=4
+#
+# bsd.gcc.mk - Support for smarter USE_GCC usage.
+#
+# Created by: Edwin Groothuis <edwin@freebsd.org>
+#
+# For port developers:
+# If your port needs a specific version of GCC, you can easily specify
+# that with the "USE_GCC=" statement. If you need a certain minimal version,
+# but don't care if about the upperversion, just the + sign behind
+# the version.
+#
+# For example:
+# USE_GCC= 3.3 # port requires gcc 3.3 to build with.
+# USE_GCC= 3.1+ # port requires gcc 3.1 or later to build with.
+#
+# If you are wondering what your port exactly does, use "make test-gcc"
+# to see some debugging.
+#
+# $FreeBSD$
+#
+
+GCC_Include_MAINTAINER= portmgr@FreeBSD.org
+
+#
+# All GCC versions supported by the ports framework.
+# Please keep them in ascending order.
+#
+GCCVERSIONS= 020702 029500 030100 030200 030301 030402 040000
+
+#
+# Versions of GCC shipped.
+# The first field if the OSVERSION in which it appeared in the base system.
+# The second field is the OSVERSION in which it disappeared from
+# the base system.
+# The third field is the version as USE_GCC would use.
+#
+GCCVERSION_020702= 000000 400012 2.7
+GCCVERSION_029500= 400012 500035 2.95
+GCCVERSION_030100= 500035 500039 3.1
+GCCVERSION_030200= 500039 501103 3.2
+GCCVERSION_030301= 501103 502126 3.3
+GCCVERSION_030402= 502126 999999 3.4
+GCCVERSION_040000= 999999 999999 4.0
+
+#
+# No configurable parts below this.
+#
+
+#
+# See if we can use a later version
+#
+_USE_GCC:= ${USE_GCC:S/+//}
+.if ${USE_GCC} != ${_USE_GCC}
+_GCC_ORLATER:= true
+.endif
+
+#
+# Extract the fields from GCCVERSION_ and check if USE_GCC points to a valid
+# version.
+#
+.for v in ${GCCVERSIONS}
+. for j in ${GCCVERSION_${v}}
+. if !defined(_GCCVERSION_${v}_L)
+_GCCVERSION_${v}_L= ${j}
+. elif !defined(_GCCVERSION_${v}_R)
+_GCCVERSION_${v}_R= ${j}
+. elif !defined(_GCCVERSION_${v}_V)
+_GCCVERSION_${v}_V= ${j}
+. if ${_USE_GCC}==${j}
+_GCCVERSION_OKAY= true;
+. endif
+. endif
+. endfor
+.endfor
+
+.if !defined(_GCCVERSION_OKAY)
+BROKEN= "Unknown version of GCC specified (USE_GCC=${USE_GCC})"
+.endif
+
+#
+# Determine current GCCVERSION
+#
+.for v in ${GCCVERSIONS}
+. if exists(${LOCALBASE}/bin/gcc${_GCCVERSION_${v}_V:S/.//})
+_GCC_FOUND${v}= port
+. endif
+. if ${OSVERSION} >= ${_GCCVERSION_${v}_L} && ${OSVERSION} < ${_GCCVERSION_${v}_R}
+_GCCVERSION:= ${v}
+_GCC_FOUND${v}:= base
+. endif
+.endfor
+.if !defined(_GCCVERSION)
+BROKEN= "Couldn't find your current GCCVERSION (OSVERSION=${OSVERSION})"
+.endif
+
+#
+# If the GCC package defined in USE_GCC does not exist, but a later
+# version is allowed (for example 3.1+), see if there is a later.
+# The first available version will be used.
+#
+.if defined(_GCC_ORLATER)
+. for v in ${GCCVERSIONS}
+. if ${_USE_GCC} == ${_GCCVERSION_${v}_V}
+_GCC_MIN:= true
+. endif
+. if defined(_GCC_MIN) && defined(_GCC_FOUND${v}) && !defined(_GCC_FOUND)
+_GCC_FOUND:= ${_GCCVERSION_${v}_V}
+. endif
+. endfor
+.endif
+.if defined(_GCC_FOUND)
+_USE_GCC:=${_GCC_FOUND}
+.endif
+
+#
+# Determine if the installed OS already has this GCCVERSION, and if not
+# then set BUILD_DEPENDS, CC, CXX and F77
+#
+.for v in ${GCCVERSIONS}
+. if ${_USE_GCC} == ${_GCCVERSION_${v}_V}
+. if ${OSVERSION} < ${_GCCVERSION_${v}_L} || ${OSVERSION} > ${_GCCVERSION_${v}_R}
+V:= ${_GCCVERSION_${v}_V:S/.//}
+CC:= gcc${V}
+CXX:= g++${V}
+F77:= g77-${V}
+_GCC_BUILD_DEPENDS:= ${CC}
+. endif
+. endif
+.endfor
+.undef V
+
+.if defined(_GCC_BUILD_DEPENDS)
+BUILD_DEPENDS+= ${_GCC_BUILD_DEPENDS}:${PORTSDIR}/lang/${_GCC_BUILD_DEPENDS}
+.endif
+
+MAKE_ENV+= CC="${CC}" CXX="${CXX}"
+
+test-gcc:
+ @echo USE_GCC=${USE_GCC}
+.if defined(_GCC_ORLATER)
+ @echo Port can use later versions.
+.else
+ @echo Port cannot use later versions.
+.endif
+.for v in ${GCCVERSIONS}
+ @echo -n "GCC version: ${_GCCVERSION_${v}_V} "
+.if defined(_GCC_FOUND${v})
+ @echo -n "(${_GCC_FOUND${v}}) "
+.endif
+ @echo "- OSVERSION from ${_GCCVERSION_${v}_L} to ${_GCCVERSION_${v}_R}"
+# @echo ${v} - ${_GCC_FOUND${v}} - ${_GCCVERSION_${v}_L} to ${_GCCVERSION_${v}_R} - ${_GCCVERSION_${v}_V}
+.endfor
+ @echo Using GCC vesion ${_USE_GCC}
+ @echo CC:${CC} - CXX:${CXX} - F77:${F77} - BUILD_DEPENDS:${BUILD_DEPENDS}