aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gcc.mk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2012-08-03 21:23:04 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2012-08-03 21:23:04 +0000
commit7926c3c9094498348759baae0b305ddb7be9f7ba (patch)
treed4f0a8b9cf55576eb93d6b2b5250ed6b8913610f /Mk/bsd.gcc.mk
parentb219c9ea54b70833c8a794bc88d67cf00c5d771f (diff)
downloadports-7926c3c9094498348759baae0b305ddb7be9f7ba.tar.gz
ports-7926c3c9094498348759baae0b305ddb7be9f7ba.zip
Introduce _GCC_RUNTIME, to be used by ports in need of knowing the
run-time directory of the version of GCC in use. As a side effect this fixes the inclusion of said directory into CFLAGS and LDFLAGS (and FFLAGS where applicable). [1] Reported by: Scott Allendorf <scott-allendorf@uiowa.edu> [1]
Notes
Notes: svn path=/head/; revision=301973
Diffstat (limited to 'Mk/bsd.gcc.mk')
-rw-r--r--Mk/bsd.gcc.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 4de739f0877d..72fe92ea9a60 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -189,11 +189,12 @@ CC:= gcc${V}
CXX:= g++${V}
CPP:= cpp${V}
. if ${_USE_GCC} != 3.4
-CFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
-LDFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
+_GCC_RUNTIME:= ${LOCALBASE}/lib/gcc${V}
+CFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
+LDFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
. if defined (USE_FORTRAN)
. if ${USE_FORTRAN} == yes
-FFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
+FFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
. endif
. endif
# The following is for the sakes of some ports which use this without