aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.gnome.mk
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2006-07-05 02:18:09 +0000
committerMark Linimon <linimon@FreeBSD.org>2006-07-05 02:18:09 +0000
commite2d64eefa615da78a7422ba3138dc59b63977201 (patch)
tree669f512f039d1cfcaedb6d0eb84b04a026e6dad7 /Mk/bsd.gnome.mk
parent30fc425b564a926e65aed480a73762a98c707557 (diff)
downloadports-e2d64eefa615da78a7422ba3138dc59b63977201.tar.gz
ports-e2d64eefa615da78a7422ba3138dc59b63977201.zip
* Change all bogus uses of BROKEN to IGNORE. Note: the BROKEN_WITH_*
forms are retained for compatibility but deprecated [1] * Add sha256 to CHECKSUM_ALGORITHMS [2] * Remove some whitespace [2] * Add USE_SCONS and bsd.scons.mk for the Python-based SCons build system [3] * Fix USE_LDCONFIG with non-default PREFIX [4] * Add USE_WX and friends, and bsd.wx.mk, for common code for WxWidgets support [5] * Add 'make missing' to show missing dependencies [6] * Fix DESKTOP_ENTRIES processing on 4.x [7] PR: 92445 [1], 98206 [2], 98731 [3], 99370 [4], 89398 [5], 93601 [6], 98891 [7] Submitted by: linimon [1], edwin [2], alex at foxybanana dot com [3], gerald [4], flz [4], alepulver [5], alex at fafula dot com [6], shaun [7]
Notes
Notes: svn path=/head/; revision=166954
Diffstat (limited to 'Mk/bsd.gnome.mk')
-rw-r--r--Mk/bsd.gnome.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/Mk/bsd.gnome.mk b/Mk/bsd.gnome.mk
index 2bacd1536e8b..107656e57e9d 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/bsd.gnome.mk
@@ -613,18 +613,18 @@ ${component}_USE_GNOME_IMPL+=${${subcomponent}_USE_GNOME_IMPL}
# Then use already expanded USE_GNOME_IMPL to expand USE_GNOME.
# Also, check to see if each component has a desktop requirement. If it does,
# and if the user's chosen desktop is not of the same version, mark the
-# port as broken.
+# port as IGNORE.
. for component in ${USE_GNOME}
. if defined(GNOME_DESKTOP_VERSION) && \
defined(${component}_GNOME_DESKTOP_VERSION)
. if ${GNOME_DESKTOP_VERSION}!=${${component}_GNOME_DESKTOP_VERSION}
-BROKEN= ${PORTNAME} wants to use the GNOME
-BROKEN+=${${component}_GNOME_DESKTOP_VERSION} desktop, but you wish to use
-BROKEN+=the GNOME ${GNOME_DESKTOP_VERSION} desktop
+IGNORE= cannot install: ${PORTNAME} wants to use the GNOME
+IGNORE+=${${component}_GNOME_DESKTOP_VERSION} desktop, but you wish to use
+IGNORE+=the GNOME ${GNOME_DESKTOP_VERSION} desktop
. endif
. endif
. if ${_USE_GNOME_ALL:M${component}}==""
-BROKEN= Unknown component ${component}
+IGNORE= cannot install: unknown component ${component}
. endif
_USE_GNOME+= ${${component}_USE_GNOME_IMPL} ${component}
. endfor
@@ -647,7 +647,7 @@ ltverhack_PRE_PATCH= ${CP} -pf ${LTMAIN} ${WRKDIR}/gnome-ltmain.sh && \
done;
.else
. if ${USE_GNOME:Mltverhack}!=""
-BROKEN= ${PORTNAME} uses the ltverhack GNOME component but does not use libtool
+IGNORE= cannot install: ${PORTNAME} uses the ltverhack GNOME component but does not use libtool
. endif
.endif