aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.kde.mk
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-05-05 09:55:30 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-05-05 09:55:30 +0000
commit53cd1ee38cd28e2daeef08e9872b3677abc120aa (patch)
tree5b79793b671e49dbc6153e339bbc787d2add383f /Mk/bsd.kde.mk
parent20b7b06c48c149442d3f2c387dcd8b52feb60ac1 (diff)
downloadports-53cd1ee38cd28e2daeef08e9872b3677abc120aa.tar.gz
ports-53cd1ee38cd28e2daeef08e9872b3677abc120aa.zip
Add back the qt145 port and support for qt-1.x. This should not
have been removed because it was not broken and a lot of working ports depended on it. The qt145 port now installs files named *qt1* instead of *qt* so it does not conflict with the other qt versions.
Notes
Notes: svn path=/head/; revision=58580
Diffstat (limited to 'Mk/bsd.kde.mk')
-rw-r--r--Mk/bsd.kde.mk14
1 files changed, 13 insertions, 1 deletions
diff --git a/Mk/bsd.kde.mk b/Mk/bsd.kde.mk
index 185b392d90fb..9bed9e774bd2 100644
--- a/Mk/bsd.kde.mk
+++ b/Mk/bsd.kde.mk
@@ -81,7 +81,19 @@ USE_QT_VER= 2
# USE_QT_VER section
.if defined(USE_QT_VER)
-.if ${USE_QT_VER} == 3
+# Qt 1.x common stuff
+.if ${USE_QT_VER} == 1
+LIB_DEPENDS+= qt1.3:${PORTSDIR}/x11-toolkits/qt145
+USE_NEWGCC= yes
+MOC?= ${X11BASE}/bin/moc1
+.if defined(PREFIX)
+QTDIR= ${PREFIX}
+.else
+QTDIR= ${X11BASE}
+.endif
+CONFIGURE_ENV+= MOC="${MOC}" QTDIR="${QTDIR}"
+
+.elif ${USE_QT_VER} == 3
QTCPPFLAGS?=
QTCGFLIBS?=