aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.kde.mk
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2002-06-16 20:27:51 +0000
committerWill Andrews <will@FreeBSD.org>2002-06-16 20:27:51 +0000
commitcf3e405f21ebfc8da332b5bd11c2f2a7a42fdbcd (patch)
tree89c37cb9fa170c981506ed20702938464408d013 /Mk/bsd.kde.mk
parent3288f29385ca63cd723d0d9970e136ea6c22389c (diff)
downloadports-cf3e405f21ebfc8da332b5bd11c2f2a7a42fdbcd.tar.gz
ports-cf3e405f21ebfc8da332b5bd11c2f2a7a42fdbcd.zip
Get rid of old cruft that was inserted a long time ago to workaround
problems people were seeing with e.g. devel/pth and friends installed. They conflict with GCC3 and may not be an issue anymore. But if someone reports the issue again we'll address it with a finer comb next time.
Notes
Notes: svn path=/head/; revision=61393
Diffstat (limited to 'Mk/bsd.kde.mk')
-rw-r--r--Mk/bsd.kde.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.kde.mk b/Mk/bsd.kde.mk
index c35e97b8d69f..0bf1eb4a8f46 100644
--- a/Mk/bsd.kde.mk
+++ b/Mk/bsd.kde.mk
@@ -105,7 +105,7 @@ MOC?= ${QT_PREFIX}/bin/moc
BUILD_DEPENDS+= ${QT_PREFIX}/bin/moc:${PORTSDIR}/x11-toolkits/qt30
RUN_DEPENDS+= ${QT_PREFIX}/bin/moc:${PORTSDIR}/x11-toolkits/qt30
USE_NEWGCC= yes
-QTCPPFLAGS+= -I/usr/include -I${LOCALBASE}/include -I${PREFIX}/include \
+QTCPPFLAGS+= -I${LOCALBASE}/include -I${PREFIX}/include \
-I${QT_PREFIX}/include
QTCFGLIBS+= -Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -ljpeg \
-L${QT_PREFIX}/lib
@@ -126,8 +126,8 @@ LIB_DEPENDS+= qt2.4:${PORTSDIR}/x11-toolkits/qt23
USE_NEWGCC= yes
QTNAME= qt2
MOC?= ${X11BASE}/bin/moc2
-QTCPPFLAGS+= -I/usr/include -D_GETOPT_H -D_PTH_H_ -D_PTH_PTHREAD_H_ \
- -I${LOCALBASE}/include -I${PREFIX}/include -I${X11BASE}/include/qt2
+QTCPPFLAGS+= -D_GETOPT_H -I${LOCALBASE}/include -I${PREFIX}/include \
+ -I${X11BASE}/include/qt2
QTCFGLIBS+= -Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -ljpeg -lgcc -lstdc++
.if !defined(QT_NONSTANDARD)
CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \