aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.kde4.mk
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-02-05 01:23:10 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-02-05 01:23:10 +0000
commit38a92d46fecb74d6b431e72fb051d4852ae09192 (patch)
tree9175166a8d864537bf06b6192f8990ba59164986 /Mk/bsd.kde4.mk
parentbaa573cc0f3c67d02f961def5da5d4b3fccc5e54 (diff)
downloadports-38a92d46fecb74d6b431e72fb051d4852ae09192.tar.gz
ports-38a92d46fecb74d6b431e72fb051d4852ae09192.zip
Update to KDE 3.2.0
Important changes: ================== - Kmail and knode have been moved from kdenetwork to kdepim. This means you will have to install kdepim if you want to continue using kmail or knode. This is to ease integration with korganizer, in the new 'Kontact' application. - The arabic translations for KDE and KOffice have been moved from misc to the arabic category. - There is a new module called kdeaccessibility in the accessibility category. It contains a few utilities for disabled users like a magnification lens and a text-to-speech frontend. - In KDM, you need to select the 'CUSTOM' session profile in order to have your .xsession executed. This is particularly important if you're using the aegypten tools (http://freebsd.kde.org/howtos/aegypten-kmail.php). - We have started making more parts of the ports optional. In kdepim, both Kandy and KPilot can be turned off with ports-knobs. This process will continue in the 3.2 series.
Notes
Notes: svn path=/head/; revision=100015
Diffstat (limited to 'Mk/bsd.kde4.mk')
-rw-r--r--Mk/bsd.kde4.mk11
1 files changed, 6 insertions, 5 deletions
diff --git a/Mk/bsd.kde4.mk b/Mk/bsd.kde4.mk
index f5c3d7570f49..3119c7c2a279 100644
--- a/Mk/bsd.kde4.mk
+++ b/Mk/bsd.kde4.mk
@@ -105,7 +105,7 @@ QTCPPFLAGS+= -D_GETOPT_H # added to work around broken getopt.h #inc
.if !defined (QT_NONSTANDARD)
CONFIGURE_ARGS+=--with-extra-libs="${LOCALBASE}/lib" \
--with-extra-includes="${LOCALBASE}/include"
-CONFIGURE_ENV+= MOC="${MOC}" CPPFLAGS="${QTCPPFLAGS}" LIBS="${QTCFGLIBS}" \
+CONFIGURE_ENV+= MOC="${MOC}" CPPFLAGS="${CPPFLAGS} ${QTCPPFLAGS}" LIBS="${QTCFGLIBS}" \
QTDIR="${QT_CVS_PREFIX}" KDEDIR="${KDE_CVS_PREFIX}"
.endif
@@ -113,7 +113,7 @@ CONFIGURE_ENV+= MOC="${MOC}" CPPFLAGS="${QTCPPFLAGS}" LIBS="${QTCFGLIBS}" \
# Yeah, it's namespace pollution, but this is really the best place for this
# stuff. Arts does NOT use it anymore.
-KDE_VERSION= 3.1.4
+KDE_VERSION= 3.2.0
KDE_ORIGVER= ${KDE_VERSION}
KDE_PREFIX?= ${LOCALBASE}
@@ -133,8 +133,9 @@ QTCFGLIBS+= -Wl,-export-dynamic -L${LOCALBASE}/lib -L${X11BASE}/lib -ljpeg \
.if !defined(QT_NONSTANDARD)
CONFIGURE_ARGS+=--with-qt-includes=${QT_PREFIX}/include \
--with-qt-libraries=${QT_PREFIX}/lib \
- --with-extra-libs=${LOCALBASE}/lib
-CONFIGURE_ENV+= MOC="${MOC}" CPPFLAGS="${QTCPPFLAGS}" LIBS="${QTCFGLIBS}"
+ --with-extra-libs=${LOCALBASE}/lib \
+ --with-extra-includes=${LOCALBASE}/include
+CONFIGURE_ENV+= MOC="${MOC}" CPPFLAGS="${CPPFLAGS} ${QTCPPFLAGS}" LIBS="${QTCFGLIBS}"
.endif # !defined(QT_NONSTANDARD)
.else # QT2
@@ -154,7 +155,7 @@ CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
--with-qt-libraries=${X11BASE}/lib \
--with-extra-libs=${LOCALBASE}/lib
CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-l${QTNAME}" \
- CPPFLAGS="${QTCPPFLAGS}" LIBS="${QTCFGLIBS}"
+ CPPFLAGS="${CPPFLAGS} ${QTCPPFLAGS}" LIBS="${QTCFGLIBS}"
.endif # !defined(QT_NONSTANDARD)
.endif # USE_QT_VER == ???