aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.linux-rpm.mk
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2006-06-07 18:47:40 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2006-06-07 18:47:40 +0000
commit16930c800dfd0fa9fc4dd907bdb086531f8e0906 (patch)
tree6f0c971096cbc26009626acc377b98193d6885bf /Mk/bsd.linux-rpm.mk
parent0a95856432a99676d68afadd78b99bb0ef3c8eac (diff)
downloadports-16930c800dfd0fa9fc4dd907bdb086531f8e0906.tar.gz
ports-16930c800dfd0fa9fc4dd907bdb086531f8e0906.zip
When generating the automatic plist, also understand @dirrmtry when looking
up linux_base-X owned dirs. Submitted by: Boris Samorodov <bsam@ipt.ru>
Notes
Notes: svn path=/head/; revision=164738
Diffstat (limited to 'Mk/bsd.linux-rpm.mk')
-rw-r--r--Mk/bsd.linux-rpm.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.linux-rpm.mk b/Mk/bsd.linux-rpm.mk
index 1ac0164c54d6..ac55be12d17a 100644
--- a/Mk/bsd.linux-rpm.mk
+++ b/Mk/bsd.linux-rpm.mk
@@ -1,7 +1,7 @@
#-*- mode: Makefile; tab-width: 4; -*-
# ex:ts=4
#
-# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.linux-rpm.mk,v 1.6 2006-05-20 15:54:24 netchild Exp $
+# $FreeBSD: /tmp/pcvs/ports/Mk/bsd.linux-rpm.mk,v 1.7 2006-06-07 18:47:40 netchild Exp $
#
# Variables:
@@ -127,7 +127,7 @@ linux-rpm-generate-plist:
@cd ${WRKSRC} && \
${FIND} * ! -type d | ${SORT} > ${PLIST} && \
${FIND} * -type d | ${SORT} | ${SED} -e 's|^|@dirrm |' > ${PLIST}.dirs
- @${GREP} '^@dirrm' ${PORTSDIR}/emulators/linux_base-${_LINUX_BASE_SUFFIX}/pkg-plist | ${SORT} > ${PLIST}.shared-dirs
+ @${GREP} '^@dirrm' ${PORTSDIR}/emulators/linux_base-${_LINUX_BASE_SUFFIX}/pkg-plist | ${SED} 's:^@dirrmtry:@dirrm:g' | ${SORT} > ${PLIST}.shared-dirs
@${COMM} -1 -3 ${PLIST}.shared-dirs ${PLIST}.dirs | ${SORT} -r >> ${PLIST}
. endif
. endif