aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2016-05-19 22:55:26 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2016-05-19 22:55:26 +0000
commitd4ae65b5973111c5887ccdda15e2977a1d0f2755 (patch)
tree0da3ef818a59535210aa9c219e6ffdfa5e498349 /Mk/bsd.port.mk
parentf3a16f6f4fdc9156e03e345f3dd5148c2d4a6ef7 (diff)
downloadports-d4ae65b5973111c5887ccdda15e2977a1d0f2755.tar.gz
ports-d4ae65b5973111c5887ccdda15e2977a1d0f2755.zip
Re-enable code from r415530 with safer MAKE_ENV support.
PR: D6271 Sponsored by: EMC / Isilon Storage Division
Notes
Notes: svn path=/head/; revision=415532
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c9c9323ef654..dc8768285184 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1641,13 +1641,13 @@ MAKE_ENV+= NO_PIE=yes
# We prefer to pass MK_*=no but it was only supported after a certain
# revision. Passing WITHOUT_* may conflict with a make.conf or src.conf's
# WITH_* value. Note that ports *do* pull in src.conf.
-.if 0 && ((${OSVERSION} >= 903510 && ${OSVERSION} < 1000000) || \
+.if (${OSVERSION} >= 903510 && ${OSVERSION} < 1000000) || \
(${OSVERSION} >= 1003503 && ${OSVERSION} < 1100000) || \
- ${OSVERSION} >= 1100000)
+ ${OSVERSION} >= 1100000
# We will control debug files. Don't let builds that use /usr/share/mk
# split out debug symbols since the plist won't know to expect it.
-MAKE_ARGS+= MK_DEBUG_FILES=no
-MAKE_ARGS+= MK_KERNEL_SYMBOLS=no
+MAKE_ENV+= MK_DEBUG_FILES=no
+MAKE_ENV+= MK_KERNEL_SYMBOLS=no
.else
MAKE_ENV+= WITHOUT_DEBUG_FILES=yes
MAKE_ENV+= WITHOUT_KERNEL_SYMBOLS=yes