aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2001-10-29 01:42:08 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2001-10-29 01:42:08 +0000
commiteec70b011f643228b14f1b9eb1f91c6b35b2bac1 (patch)
tree575f9d6fa274ff9d7743a44c11dcb6fd4dd0c2b6 /Mk/bsd.port.mk
parentfd5bde1e4736443bdb16536b5573028e13a12128 (diff)
downloadports-eec70b011f643228b14f1b9eb1f91c6b35b2bac1.tar.gz
ports-eec70b011f643228b14f1b9eb1f91c6b35b2bac1.zip
USE_AUTOCONF and USE_AUTOMAKE now depend and use the legacy versions.
This is the fastest way to move forward. A better way would be to set USE_AUTOCONF and USE_AUTOMAKE to the version desired. We can do that later, I don't want to hold up the update of the autoconf and automake ports the latest versions.
Notes
Notes: svn path=/head/; revision=49302
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 361d5394a167..0cab56529871 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -793,11 +793,11 @@ CONFIGURE_ENV+= MAKE=${GMAKE}
.endif
.if defined(USE_AUTOMAKE)
USE_AUTOCONF= yes
-BUILD_DEPENDS+= automake:${PORTSDIR}/devel/automake
+BUILD_DEPENDS+= ${AUTOMAKE}:${PORTSDIR}/devel/${AUTOMAKE}
.endif
.if defined(USE_AUTOCONF)
GNU_CONFIGURE= yes
-BUILD_DEPENDS+= autoconf:${PORTSDIR}/devel/autoconf
+BUILD_DEPENDS+= ${AUTOCONF}:${PORTSDIR}/devel/${AUTOCONF}
.endif
.if defined(USE_LIBTOOL)
GNU_CONFIGURE= yes
@@ -941,8 +941,8 @@ NONEXISTENT?= /nonexistent
# Miscellaneous overridable commands:
GMAKE?= gmake
-AUTOMAKE?= automake
-AUTOCONF?= autoconf
+AUTOMAKE?= automake14
+AUTOCONF?= autoconf213
LIBTOOL?= libtool
XMKMF?= xmkmf -a
.if exists(/sbin/md5)