aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-02-02 07:21:14 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-02-02 07:21:14 +0000
commit7654d2a185ebfbc8cc3a76deacccf644ee8ae098 (patch)
tree8f97ac32dfd7e2f516bd0fdab302d94f12ba3fb6 /Mk/bsd.port.mk
parenta9f847ec7636702ebbd88435a36c95aa94eef040 (diff)
downloadports-7654d2a185ebfbc8cc3a76deacccf644ee8ae098.tar.gz
ports-7654d2a185ebfbc8cc3a76deacccf644ee8ae098.zip
Fix a regression in the default target chain introduced when pushing the new pkg-depends target.
Now check-sanity and all depending targets are called again With hat: portmgr
Notes
Notes: svn path=/head/; revision=290274
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 98e5eaa5bd78..50ef85751cee 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4284,7 +4284,7 @@ _SANITY_SEQ= ${_CHROOT_SEQ} pre-everything check-makefile \
_PKG_DEP= check-sanity
_PKG_SEQ= pkg-depends
-_FETCH_DEP= pkg-depends
+_FETCH_DEP= pkg
_FETCH_SEQ= fetch-depends pre-fetch pre-fetch-script \
do-fetch post-fetch post-fetch-script
_EXTRACT_DEP= fetch
@@ -4329,6 +4329,10 @@ check-sanity: ${_SANITY_SEQ}
fetch: ${_FETCH_DEP} ${_FETCH_SEQ}
.endif
+.if !target(pkg)
+pkg: ${_PKG_DEP} ${_PKG_SEQ}
+.endif
+
# Main logic. The loop generates 6 main targets and using cookies
# ensures that those already completed are skipped.