aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-09 15:33:28 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-06-09 15:33:28 +0000
commit33e3d901d4375c73d7a95b6894c0022d6be7eb95 (patch)
tree34bbfd02d2930c7d48865fddb99f6e755da7b857 /Mk/bsd.port.mk
parent842d1150059240d52d41ca8332c4895bd037e0a9 (diff)
downloadports-33e3d901d4375c73d7a95b6894c0022d6be7eb95.tar.gz
ports-33e3d901d4375c73d7a95b6894c0022d6be7eb95.zip
Convert most of remaining ports that depend on xorg-libraries to
modular xorg. - supply corresponding USE_XORG for all imake-using ports that need it - USE_IMAKE no longer implies USE_XLIB in absence of USE_XORG - retire USE_X_PREFIX which is not really used anywhere after the above change - a few minor nits like whitespace and SF macro Tested by: 2 tinderbox runs by pav Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=235506
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk19
1 files changed, 3 insertions, 16 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a873b1042de2..9540f4008545 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -368,10 +368,9 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# new features: 'build', 'run', 'both', implying build,
# runtime, and both build/run dependencies
##
-# USE_IMAKE - If set, this port uses imake. Implies USE_X_PREFIX.
+# USE_IMAKE - If set, this port uses imake.
# XMKMF - Set to path of `xmkmf' if not in $PATH
# Default: xmkmf -a
-# USE_X_PREFIX - If set, this port installs in ${X11BASE}. Implies USE_XLIB.
# USE_XLIB - If set, this port uses the X libraries. In the USE_LINUX
# case the linux X libraries are referenced.
# USE_DISPLAY - If set, this ports requires a (virtual) X11 environment
@@ -552,8 +551,7 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# LINUXBASE - Where Linux ports install things.
# Default: /compat/linux
# PREFIX - Where *this* port installs its files.
-# Default: ${X11BASE} if USE_X_PREFIX is set,
-# ${LINUXBASE} if USE_LINUX_PREFIX is set,
+# Default: ${LINUXBASE} if USE_LINUX_PREFIX is set,
# otherwise ${LOCALBASE}
#
# IGNORE_PATH_CHECKS
@@ -1396,18 +1394,7 @@ FILESDIR?= ${MASTERDIR}/files
SCRIPTDIR?= ${MASTERDIR}/scripts
PKGDIR?= ${MASTERDIR}
-.if defined(USE_IMAKE) && !defined(USE_X_PREFIX) && !defined(USE_XORG)
-USE_X_PREFIX= yes
-.endif
-.if defined(USE_X_PREFIX) && ${USE_X_PREFIX} == "no"
-.undef USE_X_PREFIX
-.endif
-.if defined(USE_X_PREFIX)
-USE_XLIB= yes
-.endif
-.if defined(USE_X_PREFIX)
-PREFIX?= ${X11BASE}
-.elif defined(USE_LINUX_PREFIX)
+.if defined(USE_LINUX_PREFIX)
PREFIX?= ${LINUXBASE}
NO_MTREE= yes
.else