aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1995-04-17 06:39:05 +0000
committerSatoshi Asami <asami@FreeBSD.org>1995-04-17 06:39:05 +0000
commit6f126de6edc5300abb29052427bbf2fb90824ce8 (patch)
tree212f047a65a74bfb67942e066ff9f55bc49f5aa5 /Mk/bsd.port.mk
parentcc70b7d6519dea2dd00de21323c3896f83da89a0 (diff)
downloadports-6f126de6edc5300abb29052427bbf2fb90824ce8.tar.gz
ports-6f126de6edc5300abb29052427bbf2fb90824ce8.zip
"package" now depends on "install", so we can do "make -k package" from
the top level and have the build-package sequence of each port work together. For the old behavior (i.e, just go ahead and blindly pack everything up, regardless of the contents of work/), there is a new target "repackage".
Notes
Notes: svn path=/head/; revision=1423
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk20
1 files changed, 18 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a3a8aae4de5e..15e46bf5cf43 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.138 1995/04/15 23:56:29 asami Exp $
+# $Id: bsd.port.mk,v 1.139 1995/04/17 06:28:15 asami Exp $
#
# Please view me with 4 column tabs!
@@ -349,6 +349,10 @@ build:
package:
@${DO_NADA}
.endif
+.if defined(NO_PACKAGE) && !target(repackage)
+repackage:
+ @${DO_NADA}
+.endif
.if defined(NO_INSTALL) && !target(install)
install:
@${TOUCH} ${TOUCH_FLAGS} ${INSTALL_COOKIE}
@@ -442,7 +446,19 @@ pre-package:
.endif
.if !target(package)
-package: pre-package
+package: install
+ @${MAKE} ${.MAKEFLAGS} pre-package
+ @${MAKE} ${.MAKEFLAGS} do-package
+.endif
+
+.if !target(repackage)
+repackage:
+ @${MAKE} ${.MAKEFLAGS} pre-package
+ @${MAKE} ${.MAKEFLAGS} do-package
+.endif
+
+.if !target(do-package)
+do-package:
@if [ -e ${PKGDIR}/PLIST ]; then \
${ECHO_MSG} "===> Building package for ${DISTNAME}"; \
if [ -d ${PACKAGES} ]; then \