aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-09 13:37:26 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-09 13:37:26 +0000
commitd722fa71e4463f5f7c4ea1ac8c36d1332d6f81a0 (patch)
tree50535601ad16a33b6f0d90cc399e1e16bf80f2a1 /Mk/bsd.port.mk
parent7487f2d1da9010b4f4ebca9e91dbf6a18c34f2f4 (diff)
downloadports-d722fa71e4463f5f7c4ea1ac8c36d1332d6f81a0.tar.gz
ports-d722fa71e4463f5f7c4ea1ac8c36d1332d6f81a0.zip
Move USE_REINPLACE detection downward, so that it is possible to set it from
bsd.gnomeng.mk. Also increase OSVERSION `sed -i'check to be 500036 on -current, as users report that 500034 isn't sufficient to catch new sed(1) functionality. Approved by: portmgr (silently)
Notes
Notes: svn path=/head/; revision=62694
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk22
1 files changed, 11 insertions, 11 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 2ba61643b274..50f8c60703e3 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -709,17 +709,6 @@ FILESDIR?= ${MASTERDIR}/files
SCRIPTDIR?= ${MASTERDIR}/scripts
PKGDIR?= ${MASTERDIR}
-# Special macro for doing in-place file editing using regexps
-.if defined(USE_REINPLACE)
-REINPLACE_ARGS?= -i.bak
-.if ${OSVERSION} < 460101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500034 )
-BUILD_DEPENDS+= ${LOCALBASE}/bin/sed_inplace:${PORTSDIR}/textproc/sed_inplace
-REINPLACE_CMD?= ${LOCALBASE}/bin/sed_inplace ${REINPLACE_ARGS}
-.else
-REINPLACE_CMD?= ${SED} ${REINPLACE_ARGS}
-.endif
-.endif
-
.if defined(USE_IMAKE) && !defined(USE_X_PREFIX)
USE_X_PREFIX= yes
.endif
@@ -1057,6 +1046,17 @@ CONFIGURE_ARGS+=--x-libraries=${X11BASE}/lib --x-includes=${X11BASE}/include
.include "${PORTSDIR}/../Makefile.inc"
.endif
+# Special macro for doing in-place file editing using regexps
+.if defined(USE_REINPLACE)
+REINPLACE_ARGS?= -i.bak
+.if ${OSVERSION} < 460101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500036 )
+BUILD_DEPENDS+= ${LOCALBASE}/bin/sed_inplace:${PORTSDIR}/textproc/sed_inplace
+REINPLACE_CMD?= ${LOCALBASE}/bin/sed_inplace ${REINPLACE_ARGS}
+.else
+REINPLACE_CMD?= ${SED} ${REINPLACE_ARGS}
+.endif
+.endif
+
# Names of cookies used to skip already completed stages
EXTRACT_COOKIE?= ${WRKDIR}/.extract_done.${PKGNAME}
CONFIGURE_COOKIE?= ${WRKDIR}/.configure_done.${PKGNAME}