aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-02-10 07:59:22 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-02-10 07:59:22 +0000
commit1508fdf4b81897c7d89b5533d119300e9cbb2b8b (patch)
tree9f99be68b1758bcb63611e4a8b2c38bd4d9b9b3c /Mk/bsd.port.subdir.mk
parent534ad9b411b8c3d3674501362b388be95a98e588 (diff)
downloadports-1508fdf4b81897c7d89b5533d119300e9cbb2b8b.tar.gz
ports-1508fdf4b81897c7d89b5533d119300e9cbb2b8b.zip
* pkg-comment removal, take 2: introduce the COMMENTFILE variable
with the same semantics as the current COMMENT variable (location of the pkg-comment file), and reclaim COMMENT for the comment string itself. To work around the problems with metacharacters in comment strings, comments are written to a temporary comment file as needed. [1] * Support regexps in LIB_DEPENDS [2] * Move the CD_MOUNTPTS variable to <bsd.port.pre.mk> [3] * Improve 'make readmes' target [4]: - ^A and ^B have been replaced by | to avoid printing problems in 'make readme'. - Add %%EMAIL%%, %%MAINTAINER%% (not used yet) and %%WEBSITE%% substitutions - Add pretty-print-www-site target. * Add support for USE_GCC=3.2 [5] * Use 'uname -p' instead of 'uname -m' to set the ARCH variable. [6] * Add a ${YACC} variable [7] * Path MANPREFIX in MAKE_ENV [8] * Use the full patch to mkhtmlindex in MKHTMLINDEX [9] * Avoid overflowing the commandline when constructing the _TMLINKS variable (fixes 'make index'). [10] Submitted by: lioux [1], mi [2], mbr [3][5], Cyrille Lefevre <clefevre@citeweb.net> [4], nyan [6], cy [7], dougb [8], anholt [9], fenner [10] (based on) PR: ports/34126 [2], ports/30983 [3] (based on), ports/31389 [4], ports/47306 [5] (based on), ports/35514 [6], ports/44496 [7], ports/44895 [8], ports/45549 [9]
Notes
Notes: svn path=/head/; revision=75228
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk18
1 files changed, 11 insertions, 7 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index ecb81bad33e5..2645e0f501d9 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -47,7 +47,7 @@ STRIP?= -s
.if !defined(NOPRECIOUSMAKEVARS)
.if !defined(ARCH)
-ARCH!= /usr/bin/uname -m
+ARCH!= /usr/bin/uname -p
.endif
.if !defined(OSREL)
OSREL!= /usr/bin/uname -r | sed -e 's/[-(].*//'
@@ -118,8 +118,8 @@ _SUBDIRUSE: .USE
${ECHO_MSG} "===> ${DIRPRFX}$$sub skipped"; \
fi; \
done; \
- if test -d ${.CURDIR}/${.TARGET:R}.${MACHINE}; then \
- edir=$${sub}.${MACHINE}; \
+ if test -d ${.CURDIR}/${.TARGET:R}.${MACHINE_ARCH}; then \
+ edir=$${sub}.${MACHINE_ARCH}; \
elif test -d ${.CURDIR}/$${sub}; then \
edir=$${sub}; \
else \
@@ -203,7 +203,7 @@ README= ${TEMPLATES}/README.top
.else
README= ${TEMPLATES}/README.category
.endif
-COMMENT?= ${.CURDIR}/pkg/COMMENT
+COMMENTFILE?= ${.CURDIR}/pkg/COMMENT
DESCR?= ${.CURDIR}/pkg/DESCR
.if ${OSVERSION} >= 500036
INDEXFILE?= INDEX-5
@@ -226,7 +226,7 @@ README.html:
.else
@echo -n '<a href="'${entry}/README.html'">'"`cd ${entry}; make package-name | ${HTMLIFY}`</a>: " >> $@.tmp
.endif
- @cat `cd ${entry}; make -V COMMENT` | ${HTMLIFY} >> $@.tmp
+ @echo `cd ${entry}; make -V COMMENT` | ${HTMLIFY} >> $@.tmp
.endif
.endfor
@sort -t '>' +1 -2 $@.tmp > $@.tmp2
@@ -235,11 +235,15 @@ README.html:
.else
@> $@.tmp3
.endif
-.if exists(${COMMENT})
- @${HTMLIFY} ${COMMENT} > $@.tmp4
+.if defined(COMMENT)
+ @echo "${COMMENT:Q}" | ${HTMLIFY} > $@.tmp4
+.else
+.if exists(${COMMENTFILE})
+ @${HTMLIFY} ${COMMENTFILE} > $@.tmp4
.else
@> $@.tmp4
.endif
+.endif
@cat ${README} | \
sed -e 's/%%CATEGORY%%/'"`basename ${.CURDIR}`"'/g' \
-e '/%%COMMENT%%/r$@.tmp4' \