aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-10-14 11:03:19 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-10-14 11:03:19 +0000
commitbddcc1202ec708e491ec2f68f145924a29b99a97 (patch)
tree2b1120a1ffaa9adc48d60d7e4bdf77501b08cd6d /Mk/bsd.port.subdir.mk
parent0bb98e36ab38f6fdd92bc279097567176806ee4b (diff)
downloadports-bddcc1202ec708e491ec2f68f145924a29b99a97.tar.gz
ports-bddcc1202ec708e491ec2f68f145924a29b99a97.zip
Fix COMMENT handling -- it was incorrectly using the fixed string
"pkg/COMMENT' which of course blew up in the entire tree when we changed the layout. Fix it to use `make -V COMMENT` so it will use even for ports that define MASTERDIR etc. Reported by PRs: 21851, 21952 While I'm here, add the contents of pkg/COMMENT in category READMEs. I don't know why I didn't include them in the first place when I've been creating all those files!
Notes
Notes: svn path=/head/; revision=33818
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk21
1 files changed, 13 insertions, 8 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index caed067281bd..40e1f2882c6c 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -195,6 +195,8 @@ README= ${TEMPLATES}/README.top
.else
README= ${TEMPLATES}/README.category
.endif
+COMMENT?= ${.CURDIR}/pkg/COMMENT
+DESCR?= ${.CURDIR}/pkg/DESCR
HTMLIFY= sed -e 's/&/\&amp;/g' -e 's/>/\&gt;/g' -e 's/</\&lt;/g'
@@ -210,26 +212,29 @@ README.html:
.else
@echo -n '<a href="'${entry}/README.html'">'"`cd ${entry}; make package-name | ${HTMLIFY}`</a>: " >> $@.tmp
.endif
-.if exists(${entry}/pkg/COMMENT)
- @${HTMLIFY} ${entry}/pkg/COMMENT >> $@.tmp
-.else
- @echo "(no description)" >> $@.tmp
-.endif
+ @cat `cd ${entry}; make -V COMMENT` | ${HTMLIFY} >> $@.tmp
.endfor
@sort -t '>' +1 -2 $@.tmp > $@.tmp2
-.if exists(${.CURDIR}/pkg/DESCR)
- @${HTMLIFY} ${.CURDIR}/pkg/DESCR > $@.tmp3
+.if exists(${DESCR})
+ @${HTMLIFY} ${DESCR} > $@.tmp3
.else
@> $@.tmp3
.endif
+.if exists(${COMMENT})
+ @${HTMLIFY} ${COMMENT} > $@.tmp4
+.else
+ @> $@.tmp4
+.endif
@cat ${README} | \
sed -e 's/%%CATEGORY%%/'"`basename ${.CURDIR}`"'/g' \
+ -e '/%%COMMENT%%/r$@.tmp4' \
+ -e '/%%COMMENT%%/d' \
-e '/%%DESCR%%/r$@.tmp3' \
-e '/%%DESCR%%/d' \
-e '/%%SUBDIR%%/r$@.tmp2' \
-e '/%%SUBDIR%%/d' \
> $@
- @rm -f $@.tmp $@.tmp2 $@.tmp3
+ @rm -f $@.tmp $@.tmp2 $@.tmp3 $@.tmp4
.if !defined(NOPRECIOUSMAKEVARS)
.MAKEFLAGS: \