aboutsummaryrefslogtreecommitdiff
path: root/Mk/bsd.port.subdir.mk
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-01-01 11:45:25 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-01-01 11:45:25 +0000
commitc31f9d6cf28e3aa831ff2390ee3ab6ea031dbc76 (patch)
tree2822398a0422fa19f62acc9f8dc06c4a938ebaa8 /Mk/bsd.port.subdir.mk
parent86bcefed82fad114f7568be3c3066a11cda855c1 (diff)
downloadports-c31f9d6cf28e3aa831ff2390ee3ab6ea031dbc76.tar.gz
ports-c31f9d6cf28e3aa831ff2390ee3ab6ea031dbc76.zip
Convert a few more uses of INDEX to ${INDEXFILE}
Notes
Notes: svn path=/head/; revision=72002
Diffstat (limited to 'Mk/bsd.port.subdir.mk')
-rw-r--r--Mk/bsd.port.subdir.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/bsd.port.subdir.mk b/Mk/bsd.port.subdir.mk
index 584d5213b5fc..ecb81bad33e5 100644
--- a/Mk/bsd.port.subdir.mk
+++ b/Mk/bsd.port.subdir.mk
@@ -262,15 +262,15 @@ README.html:
-search: ${PORTSDIR}/INDEX
+search: ${PORTSDIR}/${INDEXFILE}
@here=`pwd`; \
cd ${PORTSDIR}; \
top=`pwd -P`; \
there=`echo "$$here/" | sed s%$$top%${PORTSDIR}%`; \
if [ -n "$$key" ]; then \
- grep $$there ${PORTSDIR}/INDEX | grep -i "${key}" | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'; \
+ grep $$there ${PORTSDIR}/${INDEXFILE} | grep -i "${key}" | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'; \
elif [ $$name ]; then \
- grep $$there ${PORTSDIR}/INDEX | grep -i "^[^|]*${name}[^|]*|" | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'; \
+ grep $$there ${PORTSDIR}/${INDEXFILE} | grep -i "^[^|]*${name}[^|]*|" | awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9); }'; \
else \
echo "The search target requires a keyword parameter or name parameter,"; \
echo "e.g.: \"make search key=somekeyword\""; \